Skip navigation

fusion drive

1363 Views 14 Replies Latest reply: Feb 13, 2013 2:14 AM by teooooo RSS
teooooo Level 1 Level 1 (0 points)
Currently Being Moderated
Dec 3, 2012 3:13 PM

Hi,

first of all sorry for my english.

 

I have a problem with the brand new MacMini with Fusion Drive.

 

The Apple FAQ reports:

 

Can a Fusion Drive be mounted on another system in Target Disk Mode?

Yes, but the system attempting to mount the Fusion Drive in Target Disk Mode must have OS X Mountain Lion version 10.8.2 or later. A Fusion Drive will not appear as a Target Disk Mode volume or startup disk on earlier versions of Mac OS X.

 

This is not correct, I have a Macbook Pro 15" early 2011 (8,2) and I can't connect in Target Disk Mode even if I have installed 10.8.2 in my Pro. How is it possible? My Macbook Pro never boot and remain at the apple logo spinning if I have attached the mac mini in target disk mode.

 

It's seems to be a bug of 8,2 model, infact, if I use a Macbook Pro 13" or 17" early 2011 (8,1 and 8,3) or 2010 and 2012 models it always work, but when I used a different Macbook Pro 15" (8,2) in my office never worked.

 

Someone can confirm that there's a bug?

 

I hope that Apple solve it soon.

 

Thank you.

Mac mini, OS X Mountain Lion (10.8.2), Macbook Pro 15" early 2011 (8,2)
  • BDAqua Level 10 Level 10 (114,825 points)
    Currently Being Moderated
    Dec 3, 2012 9:14 PM (in response to teooooo)

    HI can't confirm the bug, but historically Apple messes up on the 1st or second version of anything new.

  • danibjor Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 9, 2012 5:47 AM (in response to teooooo)

    There is a bug here, yes. Me too manage to set up the logical volume, but I cannot boot the computer from the fusion drive.

     

    Setup wount install on a fusion drive on MBP8,2 and using carbon copy cloner to transfer the system from a working disk over to the fusion drive don't do it either. It simply wount boot the fusion drive.

     

    I've tried with both 10.8.2 and 10.8.3 beta. 2 different SSD drives and 3 different harddrives in any combination.

     

    Still no luck.

  • Tezgno Calculating status...
    Currently Being Moderated
    Dec 18, 2012 6:47 AM (in response to teooooo)

    I am also experiencing the same issue (and have posted my findings online). Definitely appears to be the MacbookPro8,2 and not the other 2011 models. I have fusion drives working (target disk mode and even internal) on just about every other year but this particular model. I just sent Apple some feedback through their feedback submission process. I would suggest that you do the same as if enough people report it, Apple will likely look into and fix it.

  • SixPM Calculating status...
    Currently Being Moderated
    Dec 18, 2012 8:27 AM (in response to teooooo)

    Teooooo,

     

    I have the same early 15" 2011 MBP as you and have the same problems. I tried to create a Fusion Drive with this laptop in 10.8.2 and it won't work.

     

    I think there is definitely something wrong with this MBP's motherboard. Either this, or it's chipset is somehow not compatible with certain brands of SSDs, without first getting a firmware update. I've built another Fusion Drive at work - one with OCZ Agility 3 which worked, and one with Intel 520 which didn't - so I'm presuming it is something to do with the hardware. Let's hope Apple gets it fixed...

  • danibjor Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 18, 2012 8:38 AM (in response to teooooo)

    I've manage to build a Fusion Drive on my 8,2 after much work and fiddling. But I cannot boot from it - and that's consistent with what people say when they try to boot in target drive mode or building the fusion drive on another Mac and transfers the disks to the 8,2 model.

     

    Edit: While I'm able to make it while booting from USB, I cannot install OSX on it, nor boot from it. I'm able to transfer an image to it to get an OS on there, but still not booting.

  • Tezgno Level 1 Level 1 (5 points)
    Currently Being Moderated
    Dec 18, 2012 9:19 AM (in response to SixPM)

    The drives being used do not matter. While it is true that some SSDs do not play nice with macs, this issue isn't related to the disks being used at all. Rather, no logical volume group (LVG) will load on a 8,2 MBP. I even tried two Apple branded hitachi HDD drives and they fail on the 8,2 (whereas they work perfectly on other models). More info can be found at:

     

    http://forums.macrumors.com/showthread.php?t=1480179&page=16

     

    Just look for my post.

     

    This needs to be fixed because this isn't about "fusion drives". The core principle being used by a fusion drive is Apple's Core Storage Logical Volumes. I actually use them to span data across multiple disks for performance (similar to what RAID0 does) at work. I have never connected one to my MBP, but I use them on my iMacs. This means that if my iMac were to die, I would have to use another computer to access the data as my MBP would fail.

  • SixPM Level 1 Level 1 (5 points)
    Currently Being Moderated
    Dec 18, 2012 10:11 AM (in response to Tezgno)

    Tezgno,

     

    Oh no...I think you're mistaken. I used an Intel 520 SSD with one setup and I couldn't get it going. It wasn't until I changed the drive to the OCZ that the Fusion Drive Logical Volume creation worked. The procedure was exactly the same for the both drives, so how can you explain it?

     

    Well I CAN explain it. A little while back in July, Intel had announced their 520 series SSDs was using an inferior SF2281 Sandforce controller, and that their design could only encrypt up to AES128-bit. The issue is that if you read the white paper called 'Infiltrate the Vault' behind how Core Storage works, ie. Fusion Drive, it is basically FileVault encryption, but used in a RAID-like manner. The key point is that, once the drive is formatted and treated as a Fusion Drive, the encryption key is held in the EFI/Recovery partition of the drive to decode it.

     

    But I've read some guides online, and needless to say I believe some of them have a made a grave mistake when formatting for the Fusion Drive. When you type 'diskutil cs create "FUSION" disk0 disk1' you are using the WHOLE disk for CoreStorage, and possibly wiping out the Recovery/EFI area data in the course of doing so. What you should really do, is type 'diskutil cs create "FUSION" disk0s2 disk1s2'. This will retain the Recovery Disk/EFI partition of the Fusion Drive drive along with the key - hence should allow it to boot externally.

     

    But that aside, yes I do believe the early 2011 15" MBP has problems...

  • Tezgno Level 1 Level 1 (5 points)
    Currently Being Moderated
    Dec 18, 2012 10:43 AM (in response to SixPM)

    Actually, you misunderstood me. I know exactly how core storage works. I'm not arguing that the Intel 520 SSDs do or do not work. What I am saying is that in the case of a fusion drive on a MacbookPro 8,2, it doesn't matter what drives you use, they all will fail. In your post, you suggest that the issue could be either the motherboard or possibly the SSD being used. What I am saying is that it has nothing to do with the SSD being used as any LVG plugged into the MacbookPro 8,2 will fail, regardless of the drives being used. In my test cases, I used SSDs from Samsung, OCZ, OWC, and Corsair as well as regular HDDs (meaning that I used no SSDs, just two HDDs) and in all cases, the LVG will fail to load on the 8,2. In fact, in each case of a failure, I would put the drives into another Mac and they would work just fine, which is why I posted that the issue appears to be related specifically to this model.

     

    With regards to your second point (using the command "diskutil cs create 'FUSION' disk0 disk1"), while your logic is correct there, it actually doesn't matter if you use "disk0 disk1" or if you use "disk0s2 disk1s2" in terms of the EFI partition. I wondered about that as well. Turns out that if you issue the command "diskutil cs create 'FUSION' disk0 disk1" and tail out the logs, what actually gets executed is:

     

    1. Reformat and repartition of both drives

    2. diskutil cs create 'FUSION' disk0s2 disk1s2

     

    I found this to be the case if you run the command across 3 or more disks as well (disk2s2 followed by disk3s2, etc). Essentially, diskutil does not appear to allow for you to execute a core storage volume across multiple disks and wipe out the EFT boot partition.

     

    Now, having said that, because of item number 1, if you executed this on a disk that has a Recovery Parition (not to be confused with the EFI boot partition), and you want to keep your recovery parition, then it makes a lot of sense to use "disk0" (where disk0 is the new SSD) and "disk1s2" (where disk1s2 is the partion on the second disk that you wish to use... make sure this partition isn't the recovery parition). When this is executed, the SSD is reformatted and only the partion selected on the HDD is formatted. Unfortunately, if your recovery parition is on the SSD (if your machine came with just SSD, no HDD), then you will loose the recovery partition if you attempted to make your own fusion drive. That setup is actually no supported and, when tried, creates a very unstable fusion drive setup. So, it's best to not do it that way.

     

    Now, having said all of that, finally, please go back and re-read the original post from teooooo and keep it on topic. Unfortunately, this post is not about creating your own fusion drive. Rather, this post is about a problem that myself and teooooo have identified in that according to Apple, you can take a Mac that ships with a fusion drive from Apple (in both of our cases, a Mac Mini) and target disk mode that machine to another Mac running 10.8.2 or higher (in both of our cases, a MacbookPro8,2). According to the support documentation, this is supported and should work just fine. However, what myself and teooooo are pointing out is that is that it doesn't work with our MBPs. This has to be fixed by Apple because Apple says that it should work and it doesn't. In cases like myself, I use target disk mode to image new machines, recover data off machines, etc. If I cannot target disk mode new machines that come with Fusion Drives like Apple says, then Apple is on the hook to fix whatever issue is going on with the MacbookPro8,2 or give me a new machine that can (it isn't a warranty issue because it should work according to Apple).

  • RRFS Level 5 Level 5 (4,425 points)
    Currently Being Moderated
    Dec 18, 2012 6:59 PM (in response to Tezgno)

    You need to be aware of the build number of 10.8.2  Some of the new Mac Minis and MBP's that are Fusion capable have a different build (12C2034) vs the version 12C60 that is in most other models and at the App Store. The Fusion version (12C2034) would not allow my mini to have seperated drives, it appeared to work normally but it didn't allow projects from iMovie to save (I didn't test it futher than that) and Recovery Disk Utility saw the drives as having an error although Applications > Utility > Disk Utility saw no errors. Hope this provides some insight.

  • Tezgno Level 1 Level 1 (5 points)
    Currently Being Moderated
    Dec 18, 2012 7:11 PM (in response to RRFS)

    @ RRFS

     

    Thanks, but that isn't what we are talking about here (nor are there any MBPs sold with Fusion Drives yet. iMac's, yes, but not MBPs). We are not trying to separate disks on Mac Mini's or remove their disks and use them in a MBP. Rather, what we are trying to do is target disk mode a Mac Mini to a MBP. According to Apple's FAQ, this should work with any Mac running 10.8.2 (regardless of build number) sans the MacbookPro8,2 that we have been referring to. For whatever reason that hasn't been determined, this model of MacbookPro has issues reading the Fusion Drive that is installed inside of the Mac Mini when in target disk mode to this model of MBP causing the MBP to crash and fail to boot. We can confirm that other models of MacbookPro can perform this just fine... just not this particular model. Thus, we are going to have to wait for Apple to determine the cause and fix it.

     

    Interestingly enough, I contacted my Apple rep and he informed me that currently, there are no known issues with this particular MBP and fusion drive Macs as reported by Apple so I'm actually going to be taking my MBP (which is having the issue) into Apple for them to use to determine root cause on Friday. Hopefully, this will result in Apple issuing a fix for the 8,2 or ultimately replacing whatever is causing the issue in the 8,2.

  • RRFS Level 5 Level 5 (4,425 points)
    Currently Being Moderated
    Dec 18, 2012 7:15 PM (in response to Tezgno)

    Have you tried creating a new User to see if it is system wide or User specific?

  • Tezgno Level 1 Level 1 (5 points)
    Currently Being Moderated
    Dec 18, 2012 7:26 PM (in response to RRFS)

    While I understand that you are trying to help, unfortunately that isn't going to be possible here. The issue is hardware related and has nothing to do with a user account. If you notice back in the original post, the MBP8,2 fails to boot (will not go beyond the Apple logo) when you target disk mode a machine with a fusion drive to it. It isn't specific to just the original posters laptop. I have 3 of them that all do the exact same thing (that is crash the minute it reads the system). It is only on the MBP8,2. I have a MBP8,1 and several 2012 MBPs that can all target disk mode the fusion Mac minis just fine. I even have it working on a 2010 MacBook and 2008 imac and the MBP8,1, the MacBook, and the imac all run the same build of 10.8.2 so it isn't a build issue nor is it an age of device issue. It is purely a hardware issue on this particular MBP model. What I am hoping is that it is determined to be a firmware issue and not a true hardware problem requiring a recall.

  • RRFS Level 5 Level 5 (4,425 points)
    Currently Being Moderated
    Dec 18, 2012 7:35 PM (in response to Tezgno)

    Good luck and Merry Christmas.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.