Skip navigation

CS3 Install Java Script Error

776 Views 10 Replies Latest reply: Dec 7, 2012 2:32 PM by Simon Murray RSS
Simon Murray Calculating status...
Currently Being Moderated
Dec 2, 2012 1:55 PM



For reasons of economy and if it ain't broke, don't fix it, I'm still running with a G5 Dual 2.0 PowerPC at 10.4.11 for my music and photography studio. Married, two lovely children and an adorable wife, so can't afford to upgrade, and anyway, it works. Mostly.


I have two boot disks, cloned using SuperDupa which I test regularly. I've recently been having a few minor niggles so I decided to rebuild one of the disks from scratch as this hasn't been done in a couple of years. Erase the disk using Disk Utility, clean os-x install from the original disks, patch the system using Software Update then bit by bit load all the applications and gradually rebuild the whole system.


All going well until I get to Adobe CS3. When I run setup to install CS3 I get the following error;


JavaScript Alert


Critical errors were found in the setup

          - The installer database is invalid: please re-install the product from the original media. Please see Setup log file for details.



I've done some research and found that this is mostly about an unclean uninstall of CS3 when reinstalling, and is fixed by either running a CS5 cleanup program, which doesn't apply in this case as I've done a clean install (and it won't run anyway) and the boot disk is the only disk mounted. The other fix is to  erase the disk and do a clean o/s install, which is I've done. That hasn't worked either.


I've tried running the setup on the other boot disk (at 10.4.11) and also on my MacBook Pro (at 10.6.8) and it works both times.


Any clues would be apprecaited.


thanks and regards



Power Mac G5 (Early 2005), Mac OS X (10.4.11), G5 Dual 2Gb PowerPC 10.4.11
  • BDAqua Level 10 Level 10 (114,825 points)
    Currently Being Moderated
    Dec 2, 2012 7:27 PM (in response to Simon Murray)

    I've had better luck with...

    Carbon Copy Cloner...


  • BDAqua Level 10 Level 10 (114,825 points)
    Currently Being Moderated
    Dec 3, 2012 10:28 AM (in response to Simon Murray)

    Oh, I thought you hd a working copy, but anyway...

    The installer database is invalid...

    As far as I can find, that means some Adobe stuff was left somewhere!???


    I wonder if it's looking at all Disks?


    Since you can't run the Adobe cleanup app, maybe...




  • BDAqua Level 10 Level 10 (114,825 points)
    Currently Being Moderated
    Dec 3, 2012 8:00 PM (in response to Simon Murray)

    Good work, anxious to hear the oucome.

  • BDAqua Level 10 Level 10 (114,825 points)
    Currently Being Moderated
    Dec 7, 2012 10:11 AM (in response to Simon Murray)

    Thanks for the report! 


    So did the failed not have /library/applicaiton support/adobe/installers/big_long_number/payloads, or was it a munged copy?

  • Neville Hillyer Level 4 Level 4 (1,845 points)
    Currently Being Moderated
    Dec 7, 2012 2:04 PM (in response to Simon Murray)
    JavaScript Alert


    I suspect this is a typo which has totally altered the meaning. Can I assume it should be Java Script Alert, ie a problem with Java rather than JavaScript?


    My advice is to do without Adobe products altogether if you can.


    Carbon Copy Cloner is no longer free but a few days ago it was still possible to download a free copy one version later than their stated free limit. It is such a useful utility that I advise all to get a free copy before it is too late.


More Like This

  • Retrieving data ...

Bookmarked By (0)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.