4 Replies Latest reply: Dec 3, 2012 8:56 PM by ChrisJ4203
ashleeyv Level 1 (0 points)

I want to use my iMessage but it's annoying since it shows my apple ID instead of my phone number. Anyone know how to fix this?


iPhone 4S, iOS 5.1.1
  • ashleeyv Level 1 (0 points)

    I've also signed out of my apple ID but it just sits there waiting for activation and tells me to use my apple ID

  • ChrisJ4203 Level 8 (47,806 points)

    Go back in and activate iMessage again. On the Messages page in Settings, tap on Send and Receive. It should have a checkmark by your phone number. Tap on the number, and there is a place to choose how to start a conversation, and a button for using your Apple ID for iMessage. Just make sure the phone number is what is selected in each position. That should correct your problem.

  • ashleeyv Level 1 (0 points)

    It doesn't give me that option. It's iMessage on/off then as I have it on under it says waiting for activation and under that it says use your apple ID for iMessage then sms/mms options.

  • ChrisJ4203 Level 8 (47,806 points)

    If it is still waiting for activation, then you cannot make any changes to it until it is activated. Try this support document for troubleshooting activation http://support.apple.com/kb/TS4268. Once it is activated, you can use this support document to troubleshoot iMessage http://support.apple.com/kb/TS2755. I believe between the two of them, it should get you going. If not, come back and we will work at it again.