Skip navigation

Enabling Autologin

11832 Views 8 Replies Latest reply: Jan 21, 2013 5:18 PM by onecuwldood RSS
chris.cam Level 1 Level 1 (0 points)
Currently Being Moderated
May 11, 2012 2:04 AM

OK, enabling autologin may not be universally applauded, but the family like this feature.

 

We have three macbooks and I'm using the workgroup manager (yes I migrated everything from Snow Leopard).  In the workgroup preferences, the "Enable automatic login" option in the Login options is enabled.

 

However, only two of the three Macbook have Automatic Login enabled.  These also had Automatic Login enabled under Snow Leopard.

 

Does anyone know how to force the other Macbook to enable Automatic Login?  This Macbook didn't have Automatic Login enabled under Snow Leopard and has Lion Server installed as it was my trial run before upgrading our server.

Mac mini, Mac OS X (10.7.4), Mac mini server
  • gracoat Level 3 Level 3 (645 points)
    Currently Being Moderated
    May 11, 2012 10:40 PM (in response to chris.cam)

    Try creating a new local user on that macbook.  Make sure it's an Administrator User. 

    Try setting auto log in for that new user.

    Log in as that user and see if you can change the auto login to the desired user.

    HTH

     

    -Graham

  • Christy1685 Calculating status...
    Currently Being Moderated
    May 28, 2012 5:15 PM (in response to chris.cam)

    What you are going to have to do is log in as a root user, To do so follow the below link:

     

    http://support.apple.com/kb/HT1528

     

    Then when you are logged in as root go to the accounts and enable automatic login for the user account you use, it wont be greyed out when you are logged in as a root user.

     

    Once your done log back into your account and disable the root user account the same way you enabled it. The enable (where you selected before) will now show disable.

     

    Hope this helps

     

    NB. just in case: after you log out select OTHER and type root as username and whatever password is the default (or what you just choose if you enabled root for the first time).

  • tingo Calculating status...
    Currently Being Moderated
    Aug 6, 2012 9:07 AM (in response to chris.cam)

    Maybe a bit late but I had the same problem and I have just discovered that you need to disable Firevault in Security & Privacy preference.

     

    Peace and love

  • WarrenO Level 1 Level 1 (5 points)
    Currently Being Moderated
    Dec 3, 2012 9:00 PM (in response to tingo)

    Perfect. Perfect, that was it! For me, anyway.

  • onecuwldood Calculating status...
    Currently Being Moderated
    Jan 21, 2013 5:18 PM (in response to chris.cam)

    My wife and I just got new MacBook Pros. Mine was logging in automatically, her's was not. I finally got her's to do it!

     

    I simply set hers to "not" login automatic and restarted. Then went back in and set it to auto again, restarted and BINGO! It works now.

     

    I hope yours is as easy...

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.