2 Replies Latest reply: Dec 3, 2012 9:27 PM by HACKINT0SH
ItsAmerico Level 1 Level 1 (0 points)

I just got a new capture card and it requires OS X 10.7 or .8 but I can't log into the store to update. Keep getting an unknown error has occured. I have 10.6.8. Any info would be fantastic, this is really frustrating.


MacBook Pro, Mac OS X (10.6.8)