Skip navigation

iPhone 5 wifi issues

1442295 Views 4,653 Replies Latest reply: Apr 5, 2014 1:09 PM by intuitionist RSS Branched to a new discussion.
  • jcruiser Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 4, 2012 1:04 AM (in response to markrich5000)

    I've been part of, and watching these posts for about 3 weeks now and have had iPhone5 for about 4 weeks.  I am in Adelaide, Australia and bought the phbone direct from Apple.  I've experienced all the issues mentioned.  Started with difficulty connecting to wifi and bluetooth.  Did all the resets etc.  Initially had to keep inputting the router password, then that issue seemed to disappear, but the inconsistent speeds remained.

     

    Phone picks up the wifi signal at home ok when near it but much weaker than my previous iPhone4 when in another room.

     

    I've now been monitoring my speeds at various times during the day and at various locations and these are recorded with Long/Lat etc, so the evidence is there.  I do most from my home with the router less than 2 feet (600mm) away, and the phone sitting in exactly the same position.  I then do some more att the local coffee shop and around the area, picking up some different publicly accessible wifi routers.

     

    At home I can get good speed (for here its around 14.9 down and .89 up.  On LTE its 14 down and 32 up!  On 3G around 8/2.  But then on wifi, sitting at home, in exactly the same spot and a minute after the earlier test, it can be .5/.25 - which is pretty typical - and has been down to .15/0.

     

    Out on the street, whilst I can pick up the wifi routers ok, download speeds are bad and generally its necessary to go to 3G or LTE to see anything meaningful.  But there are the occasions when it all seems to work ok.

     

    So for me, its not the router that's the issue - it can only be the phone!!

  • Shanon.Roberts Level 1 Level 1 (5 points)
    Currently Being Moderated
    Dec 4, 2012 1:31 AM (in response to jcruiser)

    Hi Jcruiser,

     

    Im in Sydney NSW myself,

     

    I've been an active contributer, tester etc for these WiFi issues probably since day one.

     

    I had an Iphone 4S, upgrade to IOS6 and everything fell apart

    This also goes for 5 Iphone, in addition.. I have purchased 5 * Iphone 5's that come with IOS6. Hmm am i to believe ive had 5 faulty phones ?, i'd take a chance and simply say now and blame the IOS 6.

     

    I have uppgraded all these to IOS 6.01 still have WiFi connectivity problem where it simply wont accept our key code for authentication to my WAP's in my buildings.

     

    I can also say that my Interstate Offices have the same branded Netgear WAP's with the LATEST firmware applied and this will prevent them from authenticating. I would also like to point out, Netgear are aware of this problem related to some of their WAP Devices and are not planning to revise firmware for certain WAP's that are affected. Simple answer there is, go buy another one if its really that much of a hassle.

     

    Downgrading the firmware was the only way out, though i dont recommend it. Shame on Netgear

     

    Long story short, upgrade/down grade your Wireless Access Points at home where possible, consult your Wifi Vendor for help if you dont know how to do this. If that fails, bite the bullet and go an buy a newer model of what you have OR try an alternative brand such as Belkin. Ive realised i havent had issues with this brand and i havent seen any posts on this forum of anyone identifying having issues. Otherwise its a case of pick your poison and try an alternative brand of your choice as im not recommending brands here

     

    As for WORK, Cafes etc that are out of your control, there's nothing you can really do, unless you can liaise with their IT gurus and advise them of connectivity issues. Eventually word will get around.

     

    If your Iphone 5 is brand new, takes a chance and get a NEW Iphone 5 replacement, try your luck there.

     

    It kinda sounds like Apple Support staff are instructed like The 3 Wise Monkeys... Hear No Evil, Speak No Evil, See No Evil.

     

    On a Final note, aside from Apple WAP Products that are having these WiFi issues, i'd like to point out ti would be best for EVERYONE to contact with WiFi Vendors and mention this problem as these Vendors from a software/developers perspective would somehow talk to Apple software/developers and write something in their coding for IOS 6 patches/fixes in their next releases that would hopefully reduce these ongoing issues.

     

    Its easy to blame hardware, but keep in mind SOFTWARE drives hardware.

     

    Good Luck

  • paoshee Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 4, 2012 1:29 AM (in response to jcruiser)

    yes its all about phone buddy,

    i done reaserch, and apple says that the back of iPhone 5 & 75% of it is aluminum right? and the upper part where camera is, is a glass part and the lower where the speaker is, is a glass also, apple says that iPhone 4s back is full glass where it is use for getting signal either Cellular, wifi, 3g or data, so it means that the iPhone 5 back (both black & white) is 75% aluminum so it is clearly less to get signal cause glass is only 25%, and the reason why apple put 25% of glass instead of making it all aluminum is to get signal, 

  • Shanon.Roberts Level 1 Level 1 (5 points)
    Currently Being Moderated
    Dec 4, 2012 1:37 AM (in response to paoshee)

    Hi Paoshee,

     

    Its an interesting perspective with respect to reception issues.

     

    Makes you wonder why this guy in the article as part of Telstra's extensive testing of their handsets failed to mention this, then again makes you think the percentage of glass/aluminium is the main reason ?

     

    If that was proven, then its a designed flaw, that would open up possible legal ramifications as the product is "not fit for purchase" according to our Fair Trading Consumer Laws in Australia, then again im not a lawyer so i could be wrong altogether

     

    http://www.gizmodo.com.au/2012/12/the-right-hand-of-telstra-meet-the-in-house-de athgrip-tester/

  • paoshee Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 4, 2012 1:50 AM (in response to Shanon.Roberts)

    im sorry i cant open the link below given coz im in my office right now and some sites are blocked here,

     

    i didnt say that was ALL the reason, maybe its a part thats why iPhone is inconsistent in terms of wifi,

    i did research buddy, they didnt make it all aluminum coz they might have problem if getting signal,

    thats why they leave some glass, (i dont know how the glass will attract signal & this is the info that i got base on iPhone 5 was made) but the thing is, they didnt specify specifically what they mean on that they migh have a problem on getting signal either 3g, data, wifi or cellular,

  • stephD1982 Calculating status...
    Currently Being Moderated
    Dec 4, 2012 11:26 AM (in response to tobifs)

    Yes here also the same problem! no wi-fi at home...

  • marshallfromct Calculating status...
    Currently Being Moderated
    Dec 4, 2012 5:57 PM (in response to tobifs)

    I have an Cisco WRT54G router the first night I connected with the new iPhone I lost connection. I then went to settings/wifi and noticed that the phone resolved the DNS address being the same address as the router. I then manually entered my routers first DNS address.  This worked for a few days until I again lost connection.  I then went back to settings and noticed that my routers address was no longer there but the DNS address was. I turned wifi off and then on and the phone found the router.  I then entered all four of my DNS addresses separated by a comma.  It has been working for a week now.  I have been reading some have noticed this lose of connection is related to router types.  I think they might be correct.  Lesson learned, so far, check your connection properties to insure the phone has resolved all the DNS addresses.

  • Lostmymind Calculating status...
    Currently Being Moderated
    Dec 4, 2012 6:10 PM (in response to tobifs)

    I have two new iPhone 5's and both have the same wifi issue. I have read extensively about this issue to no avail. I have tried every suggestion and works for long. Apple needs to get it repaired. Just an irritation to their customers. 

  • firefly11 Calculating status...
    Currently Being Moderated
    Dec 4, 2012 8:24 PM (in response to tobifs)

    I am on my second iPhone 5. 

     

    My first one worked fine on WiFi on IOS 6.0 and then started having problems on IOS 6.0.1 (but only on my router at home).  It had a very slow connection on my router at home but seemed fine elsewhere.  I have tried changing settings on my router and even removing all encryption settings but that did not make a difference.  My router is a DLINK DIR-655.

     

    My first iPhone 5 also had a problem with charging where it would only charge on one side of the cable.  If it switched the cable the other way around it would not charge.  I went to the Verizon store with my first iPhone 5 to figure out the charging problem and then ended up sending me a replacement phone.

     

    So, my second iPhone 5 has problems with wifi on both IOS 6.0 (which is what came on the phone) and IOS 6.0.1.  So far in my tests on two different wifi routers the connection has been slow.

     

    This is very frusturating and I am hoping Apple will be coming out with a software fix for this.  If it find my second iPhone 5 is not working good on any wifi connection I will probably go back to Verizon and see about getting another replacement.

     

    With my first iPhone there only seemed to be problems with wifi on my router at home so I was considering replacing it with a different wifi router but now I am not sure that is a good option.

  • sg1dhd Calculating status...
    Currently Being Moderated
    Dec 5, 2012 9:14 AM (in response to tobifs)

    I have an iphone 5 and I am also having trouble conecting to wifi, both on my home wifi and the WPA network at my University.

     

    It does sometimes connect, but it takes a long time to do so. Also, sometimes when it does connect, it gets a very slow connection.

     

    I'm on 6.0.1

     

    Apple, please fix this!

  • sbailey4 Level 1 Level 1 (5 points)
    Currently Being Moderated
    Dec 5, 2012 10:27 AM (in response to firefly11)

    Make sure your WMM setting in your router is enabled.

     

    http://support.apple.com/kb/TS3727?viewlocale=en_US&locale=en_US

     

    I have the same DLINK model and it works fantastic with 4s.

     

    also can read here http://nuangel.net/?p=257  Screen shots at bottom as to where to find this setting on some of the common routers.

  • firefly11 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 5, 2012 10:31 AM (in response to sbailey4)

    Yes, the WMM setting on my router is enabled.  I realized I should have mentioned that I have an iPhone 4s, iPod Touch 4G, and iPad 3 connected to this same router all with IOS 6.0.1 and they all work fine.  It is only the iPhone 5 that is having a problem.

  • Bruno J L Oliveira Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 5, 2012 2:28 PM (in response to tobifs)

    My iPhone Wi-fi si not the best. I had an androind and as soon as i parked my car it was connected to my home wifi. With iPhone 5 i walk all the way into my house and only very close to the wifi it is connected.

  • Egg Level 1 Level 1 (45 points)
    Currently Being Moderated
    Dec 6, 2012 1:48 AM (in response to tobifs)

    I need to do more testing ... but... i was never able to use the wifi in a specific room after getting the iphone 5 (vs 4). Also, the phone seemed to take 50>10 seconds to connect to the signal, even where it was strong.

     

    Yesterday, i changed my TP-Link router option for channel width from Auto to 40MHz. Straight way, things seem better. Connect time is instant, and I can get wifi in the room, unlike before. Used to get 0.3MB at very very most (usually no signal) ... now speedtest is pulling 4MB ....  (vs 11MB when im near the router).

     

    If this continues, and isn't just a fluke, i'll be very happy!

  • Milan Cools Calculating status...
    Currently Being Moderated
    Dec 6, 2012 3:06 AM (in response to tobifs)

    I'm having some trouble with my iPhone 5. It does connect to my 5 ghz WiFi network, but not to my 2.4 ghz network. Does anyone have the same problem? I tried resetting my Internet settings, without any luck. I really need the 2.4 because the signal goes farther than the 5. Also, public WiFi will most likely be 2.4 ghz.
    Thanks :/

Actions

More Like This

  • Retrieving data ...

Bookmarked By (127)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.