4 Replies Latest reply: Dec 5, 2012 7:22 AM by Kevin V
Kevin V Level 1 Level 1 (0 points)

Running Mac Server Lion with about 25 network users.  Office 2011.

 

Today, one user opens an existing Excel file and makes changes.  Password protects the file and saves the file to her desktop.

About 10 minutes later she goes back and opens the file again and cannot save any additional changes because the files reports that it is "Read-Only".  The user had to do a save-as in order to continue.  We have tried multiple times.

 

And of course, the user cannot delete this file.

 

"Get info" does not show a lock, and permissions appear to be correct.  Not to mention that the file was fine only a few minutes before going haywire.

 

Anyone??

 

Kevin V.


MS Excel and OS X Server, OS X Server
  • 1. Re: Network Users and "Read-Only" Excel files - again
    Gwashin Level 1 Level 1 (0 points)

    I had the same issue and found a possible solution.

    It appears that if the file name was causing my problem and when the file name has a "/" in it, then the Excel file will open it as a "read-only" file.

    If you remove the the "/" from the file name it will open correctly and editable. It seemed an unlikely solution but when I investigated the files that I was having trouble with, they all contained a / in their file names.

     

     

    Worth a try.   

     

    Gwashin

  • 2. Re: Network Users and "Read-Only" Excel files - again
    John Lockwood Level 5 Level 5 (5,370 points)

    Different operating systems have different 'illegal' characters. As an example Unix/Linux uses the / (forward slash) as the pathname separator, whereas Windows uses the \ (back slash) and depending on the type of program you are using on a Mac a Mac might use either the : (Colon) or / (forward slash).

     

    Normally, the Mac software will automatically translate between a : or / so that the different types of program can work together, it will also 'escape' the bad character so if you are using a program on the Mac that uses a : as its separator and you have a filename containing a : it is 'escaped' to a / or vice versa.

     

    In general however it is far better to avoid all these potentially restricted characters so you don't hit any problems like you found in Excel.

     

    Characters to avoid are

     

    # pound< left angle bracket$ dollar sign+ plus sign
    % percent> right angle bracket! exclamation point` backtick
    & ampersand* asterisk‘ single quotes| pipe
    { left bracket? question mark“ double quotes= equal sign
    } right bracket/ forward slash: colon
    \ back slashblank spaces@ at sign

     

    Not all of these are illegal in each operating system for example the Mac is normally happy with spaces, however Unix is more fussy but can still cope with them if your careful.

  • 3. Re: Network Users and "Read-Only" Excel files - again
    UptimeJeff Level 4 Level 4 (3,390 points)

    Any SMB users?

    strict file locking?

  • 4. Re: Network Users and "Read-Only" Excel files - again
    Kevin V Level 1 Level 1 (0 points)

    This happened back a while ago, so I don't have the file name, but I have had similar problems with other files not deleting on the desktop and these files do not have any special characters except a possible space.  Some include an underscore.  However; there are lots of files on our server that have both and no problems.

     

    SMB users - kinda.  We use Parrallels to gain access to our Accounting software that is Windows based.  Most of the time files are not shared between environments.

     

    Strict File Locking - Not sure where to find this option.  I found where some can add the SMB service in Server Admin, but I don't have this option. 

     

    Thanks everyone for the replies!