Skip navigation

NTLM domain not configured

2739 Views 3 Replies Latest reply: Feb 20, 2014 11:13 AM by azarzycki RSS
scherndon Calculating status...
Currently Being Moderated
Sep 9, 2011 7:25 AM

I need my Lion Server to share a folder out to about 30 PCs and Macs of various vintage and OSes.

 

I'm having major trouble with failures to log in from windows despite SMB being enabled in the Server App's File Sharing Pane.

 

The error that is ubiquitous is NTLM domain not configured.

 

I found a post telling me to change the NETBIOS computer name to a good token and then use that with the Windows authentication dialog like a domain name.  eg, domain called "harbor", set NETBIOS to "HARBOR" and use HARBOR\steve as the log in user.

 

This has sort of worked, but the netbios name isn't sticking through server reboots.

 

Furthermore, this authentication approach seems to break.  I don't know what is triggering it, but once it goes, the log I get from

sudo cat /private/var/log/krb5kdc/kdc.log

is fire with NTLM domain not configured errors from the now broken mapped network drives.

 

I read another post telling me to turn off AFP sharing.  I'm trying that now, but "really?"

 

Can anyone help me get to the bottom of this?  Everyone connected to this network can be trusted to have share level access, but I'm probably never going to be able to disable all authentication. 

 

Thanks for any thoughts.

Mac mini, Mac OS X (10.7.1)
  • sweavo Calculating status...
    Currently Being Moderated
    Jan 29, 2012 3:12 AM (in response to scherndon)

    I've just been battling with windows auth on samba shares from a regular lion (not server) box, and what cracked it for me go network->advanced then the WINS tab and enter the desired netbios name and workgroup name in there. This is after I already tried a macports install of darwin3 with no joy.

     

    Hope that helps

  • Ernst Mulder Level 1 Level 1 (5 points)
    Currently Being Moderated
    Dec 4, 2012 4:37 AM (in response to sweavo)

    Thanks for the hint. Setting the netbios and workgroupname solved this for me.

  • azarzycki Calculating status...
    Currently Being Moderated
    Feb 20, 2014 11:13 AM (in response to sweavo)

    Populating the NetBios and workgroup names appears to make a difference when a Windows machine fails to log into the Mac over SMB.

     

    I should note that some non-Windows devices that connect to the Mac over SMB may not trigger this problem: I've successfully used ES File Explorer from several Android devices to connect to the same Mac that I couldn't connect to from a Windows machine until I populated the NetBios and workgroup names.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.