Skip navigation

27 Inch Displays Flicker With Mountain Lion

1970 Views 12 Replies Latest reply: Jan 18, 2014 6:44 AM by Kachadurian RSS
moviedaze Calculating status...
Currently Being Moderated
Aug 20, 2012 5:17 PM

I have three 27 inch displays connected to three graphics cards on my Early 2009 Mac Pro.  Since upgrading to Mountain Lion, I am experiencing an annoying screen flicker.  Everything was working perfectly before the upgrade from Lion to ML.  I keep checking for sotware upgrades but nothign has fixed this problem.  Can anyone post any suggestions? 

Mac Pro, OS X Mountain Lion
  • Hans-Uwe Brackel Calculating status...
    Currently Being Moderated
    Aug 26, 2012 8:32 AM (in response to moviedaze)

    Same here. I have 2 Thunderbolt displays connected to my relatively recent Macbook Pro (pre-retina display). The flickering appeared after the last update of Mountain Lion to 10.8.1. I didn't see these problems earlier. It is usually the daisy chained display at the "far end" from the Macbook Pro.

    Working is hardly possible with this problem present. Is there any way to revert to Mountain Lion 10.8.0?

     

    Thanks, HU

  • Triphonius Calculating status...
    Currently Being Moderated
    Sep 1, 2012 1:07 AM (in response to moviedaze)

    Same problem here with 27'' Thunderbolt Cinema Display and MacBook pro Retina, when connected with Thunderbolt cable and magsafe2. The flickering isn't continous, often at startup. Very annoying.

  • fwsmroldan Calculating status...
    Currently Being Moderated
    Nov 12, 2012 3:04 PM (in response to moviedaze)

    We are also having the same issue: hardware: mid 2012 Macbook Pro, 13, 10.8.2 OS X. We do not have comparable hardware available for testing immediately, but there is another laptop we could test - perhaps, test with Lion OS X and see if the issue is specific to  Mountain Lion OS X.

     

    Edit: I am testing on similar harware/OS combination now: 10.8.2, 13-inch MBP. Post results by this week.

     

    Message was edited by: fwsmroldan

  • Hans-Uwe Brackel Level 1 Level 1 (5 points)
    Currently Being Moderated
    Nov 12, 2012 9:55 PM (in response to fwsmroldan)

    The problem had disappeared with one of the previous Mountain Lion updates, but returned with the mini update from last week. So I suspect it can indeed be software related rather than a hardware issue. The frequency of occurrence is not as often as in the beginning, though.

  • Jonathan UK Level 1 Level 1 (45 points)
    Currently Being Moderated
    Dec 4, 2012 6:44 AM (in response to moviedaze)

    I also have an intermittently flickering screen on a 27" LED Cinema Display connected to a MacBook Pro early 2011.

     

    This is continuing to happen after having applied the LED Cinema Display firmware update 1.1 (released 30 Nov 2012).

  • DaveHowden Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 17, 2013 11:07 PM (in response to Jonathan UK)

    I am having exactly the same issue.  Have you managed to resolve it?

  • Hans-Uwe Brackel Level 1 Level 1 (5 points)
    Currently Being Moderated
    Feb 17, 2013 11:35 PM (in response to DaveHowden)

    Unfortunately not. It is rather getting worse. It prevent (or delays for a long time) the booting of the MacBook. A temporary fix is to disconnect it from AC and everything else for some time (> 1hour). The it works okay until the next reboot. Sometimes when booting I also notice a "color spray pattern" on the display, which disappears when the normal screen appears.

    The problem is that all these phenomena are sporadic. When I'll take it to an Apple store it will certainly work okay for a moment, as it has been disconnected from AC. So this one is difficult to prove...

  • DaveHowden Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 17, 2013 11:40 PM (in response to Hans-Uwe Brackel)

    I might have found a temporary fix.

     

    The flickering has stopped since I disabled the "Automatic Graphics Switching" in System Preferences > Energy Saver.

     

    I use the word "might" because I then re-enabled it and the flickering hasn't returned.  Maybe it just needed a little kick...!  There are sporadic rendering errors in Safari which are apparently due to the graphics switching, so I wonder if these two problems are related?  10.8.3 is supposed to go some way to addressing the Safari issue, so fingers crossed for the display flickering too!

  • Hans-Uwe Brackel Level 1 Level 1 (5 points)
    Currently Being Moderated
    Feb 18, 2013 3:12 AM (in response to DaveHowden)

    Automatic Graphics Switching has been disabled for me at all times (I'm using the MacBook Pro more in a desktop mode). I disabled this as well as the sleep mode because the Thunderbolt devices didn't come back from sleep mode properly and I had to reboot - which defeats the purpose of the sleep mode. As I have 3 Thunderbolt displays and the flickering only appears with one I suspect a hardware related issue.

  • PKGM Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 25, 2013 11:28 AM (in response to moviedaze)

    Sorry for posting yet another thread to this post, but reading the many posts in this thread I am unsure which solution/approach will resolve the flickering issue I am experiencing.

     

    I recently received a newish laptop with MacBook Pro for work

    • 2GHz, Memory
    • 4GB 1333 Mhz DDR3
    • AMD Radeon HD 6490M 256MB
    • running Mac OS X Lion 10.7.5

     

    I have it hooked up to an older Cinema Display (2008) 24 inch

    AMD Radeon HD 6490M 256 MB graphics

     

    It flickers every 3-4 minutes and then eventually turns off.  I went to the apple store and they indicated my computer is too fast for the monitor...but since I did not bring in the monitor to demonstrate the flickering, it was an educated guess.

     

    Can someone confirm if this is indeed the case and/or if there is anything I can do to resolve this.  I am trying to upgrade my monitor for work and they think it may be the video card in my laptop..which has never failed while projecting to an LCD projector.

     

    Plead advise!

  • Hans-Uwe Brackel Level 1 Level 1 (5 points)
    Currently Being Moderated
    Mar 26, 2013 1:30 AM (in response to PKGM)

    At least for my case I can tell that the computer isn't too fast (which I doubt could be causing the trouble anyhow, as the thunderbolt interface should mitigate). I noticed, that the computer sometimes doesn't even boot with the second "malicious" display connected. Only after disconnecting the display from all (including AC! power) connections for some minutes, it will return to duty. Once "connected" it stay well on duty as long as I don't turn the computer off. If I wouldn't know better I'd take a guess that the display has some earthing or ES charging issue.

     

    Regards,

    Hans-Uwe

  • Kachadurian Calculating status...
    Currently Being Moderated
    Jan 18, 2014 6:44 AM (in response to moviedaze)

    I have the exact same problem on my MacPro 3,1. ATI Radeon HD 5770, two displays. 20" cinema is fine but the 27" LED (pre thunderbolt) flickers on start-up the eventually kicks in. Sometimes it takes 1 minute sometimes 10 minutes then it goes on and it's fine. 10.8.5

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.