Skip navigation

Safari 5: How do I disable address auto completion?

34296 Views 42 Replies Latest reply: Feb 17, 2014 6:00 AM by crew3lt RSS
  • Larryds Calculating status...
    I see that this thread is marked with a solved answer. I don't see a solution in any of the posts. Is there one?
    27" Imac, Mac OS X (10.6.4)
  • Zevie Tannenbaum Level 1 Level 1 (5 points)
    Mac Pro 8 core-----MacBook Pro 15", Mac OS X (10.5.6), Mac Pro 8 core, 10 Gb Ram, 750 GB/////MacBook Pro 15"
  • dTheory Calculating status...
    Keeping the thread open... since the Safari extensions don't work with ones existing bookmarks another solution is needed...
    Mac OS X (10.6.4), Safari 5.0.2
  • c.j.vincent Calculating status...
    This is severely annoying. Apple, patch this quick! I will be using Chrome until it is fixed.
    MacBook Pro
  • paolo1888 Level 1 Level 1 (0 points)
    BUMP!!! Cant let this go just yet - how the **** do you stop this problem!?
    Mac OS X (10.6.4)
  • enaz81 Calculating status...
    Currently Being Moderated
    Sep 14, 2010 5:10 PM (in response to Babaganoosh)
    ok. i thought i had the answer before but this seems to be working. follow the instructions on this website. http://www.shauninman.com/archive/2010/08/25/smrt
  • Brigid Alverson Calculating status...
    Currently Being Moderated
    Sep 16, 2010 8:05 PM (in response to enaz81)
    You know what? I appreciate the effort, but I don't want to download a work-around from a complete stranger.

    Safari worked just great until I upgraded. Now it gets in the way. I don't like Firefox, because the autocomplete in the address bar isn't as smooth as the OLD Safari, but now I'm seriously considering switching my default browser.

    Like a lot of the people who commented here, I used the autocomplete feature all the time. Most of the time, I could get to the correct website after two or three keystrokes. Now everything takes twice as long.

    This "feature" is illogical and poorly designed. It gets in the way, and it can't be disabled. Thanks, Safari, for making your browser less usable.
  • nooma Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 23, 2010 12:24 PM (in response to Brigid Alverson)
    I am absolutely infuriated by this. I have never cussed at my computer so much.
  • Nobleach Calculating status...

    What is so unacceptable about this is that my brand new iPad is now suggesting urls that I visited on my MacBook last year. Somehow apple saw fit to store these in the cloud, and then push them down to my new device. Thank you apple. Now I can't visit reddit.com without having nsfw reddit pushed in my face. And it looks like I'll have a reminder forever of the one freakin time I clicked a nsfw ink.

  • WebbieWorks Calculating status...

    When is everyone going to realize that apple does not care about your opinions or problems? All they care about is you buying their product. Once you buy the product you are on your own.

     

    Sad to say but it is true, Apple has the worst customer service I have ever delt with.

  • kmva Calculating status...

    Note to all - this problem has been SOLVED in Safari 7 (and possibly Safari 6).

     

    In Safari 7: Go to the Privacy tab of Safari Preferences. At the bottom, where you see "Smart Search Field", select "Prevent search engine from providing suggestions", which will limit the address/search bar's suggestions to sites in your history and bookmarks. If THAT annoys you, clear your history and remove/rename any problematic bookmarks.

     

    Cheers.

  • aheusingfeld Calculating status...
    Currently Being Moderated
    Dec 2, 2013 4:15 AM (in response to kmva)

    which will limit the address/search bar's suggestions to sites in your history and bookmarks. If THAT annoys you, clear your history and remove/rename any problematic bookmarks.

    Sorry, but IMO it is really no solution at all if users will have to remove all their bookmarks to not get those suggestions. Another thing that is really annoying and related  is that these auto-suggested URLs are immediately requested in the background by Safari! This might be intended as a kind of prefetch feature!

    But it currently seems that these prefetch requests don't even have special HTTP header so that website owners have no chance to detect those as prefetch requests.

     

    Conclusion: This feature is not just annoying to the user but also to website owners. Please Apple don't enable it by default.

  • crew3lt Calculating status...

    I think I might have figured this out.  Check to see if any of the websites or words you type into the URL bar are saved in your bookmarks or reading List.  I just did this and sure enough, they are listed in the bookmarks.  Not sure how to disable that feature, other than to delete your bookmarks.

1 2 3 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.