Skip navigation

No Sound From iMac Internal Speakers

20039 Views 21 Replies Latest reply: Mar 9, 2014 4:12 AM by jesman1 RSS
1 2 Previous Next
ObiJuan2080 Level 1 Level 1 (20 points)
Currently Being Moderated
Aug 31, 2012 4:02 PM

Screen Shot.png

Here's what I've tried so far to fix this:

 

1. I saw on the boards that someone said that all they had to do was uncheck "Mute" in the Audio MIDI Setup. All Mutes were unchecked. No go there.

 

2. Restted my SMC...that's didn't work at all.

 

3. What seems to work is resetting PRAM/NVRAM...that is until the iMac goes to Sleep Mode. Once out, it goes back to what you see in the pic above. Restting PRAM/NVRAM all the time can't be good for the iMac...right?

 

4. And no there is no red light coming from any of the audio connectors in the back.

 

 

 

 

What's off the table:

 

Reinstalling Lion 10.7.4. I can't, no way, don't want to.

 

 

 

Is there any other way to fix this? Any help would be greatly appreciated.

 

Message was edited by: ObiJuan2080

iMac, Mac OS X (10.7.4), 3.4GHz i7, 16GB RAM, ATI 2GB VRAM
  • rkaufmann87 Level 8 Level 8 (40,745 points)
    Currently Being Moderated
    Aug 31, 2012 4:03 PM (in response to ObiJuan2080)

    Have you tried turning up the volume and please describe the exact process  you did to reset the PRAM and SMC, please do not skip a step. Also check to see if anything is plugged into the audio connectors in the back.

  • rkaufmann87 Level 8 Level 8 (40,745 points)
    Currently Being Moderated
    Aug 31, 2012 4:27 PM (in response to ObiJuan2080)

    There are multiple methods for resetting the SMC based on the  type of Mac you have. Please describe the steps you took for your iMac, they are totally different than those of say a MacBook or MacBook Air.

  • rkaufmann87 Level 8 Level 8 (40,745 points)
    Currently Being Moderated
    Sep 1, 2012 12:44 AM (in response to ObiJuan2080)

    Try resetting it with all the peripherals unplugged. Leave them unplugged and then retry the sound. If that doesn't work create a new user account (call it TEST ACCOUNT), log into it and see if you have the same issue. If it disappears you know it's a software issue in your normal user account and not global.

  • leemsutton Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 3, 2012 4:41 AM (in response to ObiJuan2080)

    If its any use to anybody I had this exact same issue with no sound. I googled and tried everything suggested to no avail so booked a Genius appointment.

    I then remembered I had been trying to get the Dictation tool to work so I could dictate into the word processor instead of typing. So I went to Dictation and Speech and simply turned off dictation and the sound came back on! I hope it helps some of you.

  • kok kong hong Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 4, 2012 9:33 AM (in response to ObiJuan2080)

    me too !!no sound

  • intepid Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 6, 2012 4:04 AM (in response to ObiJuan2080)

    I had this problem a while back, but it went away before I could work it out. It happened again today and I now believe it is a transient hardware issue in the headphone jack (possibly related to temperature/humidity/dust). The system seemed to get confused and think it was using digital audio out when it wasn't, and plugging in my headphones in a few times and twisting the jack a little seemed to make it the problem go away.

     

    Similar description: http://forums.macrumors.com/showthread.php?t=1155397

  • Dean Huxley Level 1 Level 1 (130 points)
    Currently Being Moderated
    Dec 10, 2012 7:42 PM (in response to ObiJuan2080)

    Thanks ObiJuan2080!!!

     

    I just ran into the same problem as you.  Nothing plugged into my iMac except power, kbd and mouse and for some reason I had no sound.  Pressing volume up/down keys on the keyboard wouldn't do anything but show the "not permitted" circle with slash through it like the image in your original post.

     

    I killed coreaudiod and after it restarted (automatically from launchd I presume) the sound was working fine!

     

    A reboot might have fixed it, but killing coreaudiod was a lot quicker...

     

    Cheers,

    Dean

  • jehrke7 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 20, 2013 7:55 AM (in response to Dean Huxley)

    I had this same issue...my iMac's sound just mysteriously stopped working.  I went into System Preferences>Sound>Internal Speakers ....checked the mute button and then unchecked it and the sound magically came back....not sure what the deal was but it's working now. 

  • David Ross17 Level 1 Level 1 (45 points)
    Currently Being Moderated
    Feb 28, 2013 11:30 AM (in response to ObiJuan2080)

    I can't find 'coreaudiod' in the activity monitor or indeed anywhere on my Mac (21.5 inch mid 2011, OSX 10.8.2). Never had any sound problems on any revious mac until this one. Shop bought, not refurb. It worls fine with headphones but not without. The only options with the headphones out are: for output, Digital Out Digital-out port for which it says "The selcedt device has no output controls" and for input built in internal microphone and line ine audio line in port. The volume slider can be used but not input level or the mute button (unchecked) which are greyed out.

     

    With headphones in, output changes automatically to headphones port and there are no other options. On the input tab the volume slider works for both input and output and the mute button can be accessed.

     

    Nothinng else hooked up and iTunes works okay without headphones

     

    This is driving me crazy

1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Related Articles

Bookmarked By (1)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.