Skip navigation

Cannot access my Aperture library

409 Views 5 Replies Latest reply: Dec 4, 2012 12:20 PM by chachafrisk RSS
chachafrisk Calculating status...
Currently Being Moderated
Dec 4, 2012 4:14 AM

Please help - I cannot access my photos any more.  I have >400Gb in my library and all attempts to access it have failed.  If I click on Aperture it says I do not have the right file permissions to access.  I have read and write: I unlock it in Finder but there is nothing I can do.  I looked in Disk Utility and tried First Aid, but the Repair Disk says it is ok.  I have held down Option and Cmd and double clicked on Aperture, and have attempted to repair the permissions - it gets half way through a check then says "Could not enforce consitency of files".  The other options to repair do not work as it says I have the wrong permissions!!


My only idea now is to put my old discs for Aperture in and apply updates, as the library won't be readable on old versions.  Any ideas welcome ...... please?


Thanks, James

  • léonie Level 8 Level 8 (46,380 points)
    Currently Being Moderated
    Dec 4, 2012 5:52 AM (in response to chachafrisk)


    we need more information to get an idea what to suggest:

    • What is your current Aperture version and what version of Mac OS X?
    • Where is your Aperture library located? On an external drive or your system drive? Are the images referenced or managed?
    • If the library is on external drive, what kind of drive, and how is it connected, directly or network volume?
    • When did this start? Was there anything special before you could not open Aperture anymore? Did you install or upgrade new software? Were there any crashes?


    To narrow the problem down: Create a new, empty Aperture library for testing and import some images. Can Aperture work with a new library? Then probably reinstalling will not help.




  • léonie Level 8 Level 8 (46,380 points)
    Currently Being Moderated
    Dec 4, 2012 11:13 AM (in response to chachafrisk)

    You are welcome, James.


    It is good to know, you now have access again to your library. But I would really not trust your harddrive, if it is that temperamental, so you may want to check your backup if it is current and working, while your luck lasts




  • Lovie1 Calculating status...
    Currently Being Moderated
    Dec 4, 2012 11:30 AM (in response to chachafrisk)

    I had the same problem today and called APPLE. I have an older version of APERTURE (Version 2.1.4). They sent me a very helpful pdf file that gave me steps to follow to restore my library.  The very first step worked and all the photos in my 52 projects are back!


    The first step said to hold the Option and Command keys as you start Aperture. The Aperture Library First Aid dialog will appear and offer options. 


    I hit "Rebuild Database" and after a few minutes all my pictures returned. 


    Does Aperture get confused with you delete a number of projects from the library?  Is this "rebuilding" necessary after deleting a number of projects? Should I upgarde my Aperture (I will also have to upgrade my MAC OS) and am not sure I can on an older MacBook PRO?  Advice???


More Like This

  • Retrieving data ...

Bookmarked By (0)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.