Skip navigation

Resized Boot Camp partition; now have "disk0s4"

779 Views 9 Replies Latest reply: Jan 25, 2013 2:58 AM by flyingpostaldude RSS
ruffellprefley Level 1 Level 1 (0 points)
Currently Being Moderated
Dec 4, 2012 1:00 PM

Following this blog post: s-8/


I resized my Boot Camp partition to give Windows 7 more space.  In Disk Utility on OS X ML, I reduced the size of my OS X partition.  I booted into Windows and did a chkdsk /f.  Then I ran the freeware program to extend the size of the Boot Camp Windows partition to take the unallocated space as its own.


I can boot into OS X fine.

I can boot into Windows 7 fine.

I've run chkdsk /f again on Windows 7 to repair the disk.


The problem is that now I cannot access my Boot Camp partition from OS X like I used to be able to.  Disk Utility shows an unmountable disk0s4 drive instead of "BOOTCAMP".


Can anyone help me regain access to my Boot Camp partition (read only) so that I can copy files from my Windows partition to my OS X partition?


Ideally I would like to avoid deleting the Windows partition and recreating it using Boot Camp Assistant.



MacBook Pro, OS X Mountain Lion


More Like This

  • Retrieving data ...

Bookmarked By (0)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.