3 Replies Latest reply: Dec 4, 2012 7:12 PM by Frnch
Scandostevo Level 1 Level 1 (0 points)

I'm unable to open Airport Utility on my Windows 7 laptop because I keep getting an error message saying Airport Utility requires Windows 7 service pack 1 or later.  SP1 was already installed.  I tried deleting and reinstalling SP1 and Airport Utility still won't open.  Any ideas on how to fix this?

  • 1. Re: Unable to open airport utility on Windows 7
    Frnch Level 1 Level 1 (0 points)

    I have the same problem.  My Airport Express is working fine, but the Airport utility won't open.  I get the same message and I've tried re-installing as well.  Any ideas???

  • 2. Re: Unable to open airport utility on Windows 7
    CRMDVM Level 4 Level 4 (1,360 points)

    This can happen when the Airport Utility installation download can't find an authentication file - short of doing a clean install of Windows 7, try the following:

    1. Delete any old Windows folders if Windows 7 was an upgrade

    2. Turn off anti-virus programs

    3. Turn off the Windows Firewall

    4. Delete any partial installations of the AU that may be present

    If the above does not work then try to download the previous version of the AU 5.5.3 at http://support.apple.com/kb/DL1391

  • 3. Re: Unable to open airport utility on Windows 7
    Frnch Level 1 Level 1 (0 points)

    My problem solved....  When I right-clicked Airport Utility and checked under Properties/Compatability Mode, The compatability mode box was checked & was set to Windows 7.  This may have precluded it from running under Windows 7 SP1.  When I unchecked the box everything was fine.  Thanks...hope this helps someone else...