Skip navigation

Mac OsX Mountain Lion httpd doesn't start

925 Views 5 Replies Latest reply: Sep 14, 2013 1:08 PM by dodonian RSS
Daniele Outline Calculating status...
Currently Being Moderated
Dec 3, 2012 7:12 AM

Dear sirs,


we bought Mac Mini Server Version 10.8.2


We start Server App and we switched on Web Sites service.


It worked fine.


Then, we switch off the service, but we found httpd process in Activity Monitor, so we kill all httpd processes.


Then, we start again Server App, but if we try to switch on Web Sites service, nothing happen (no error) but we can not see httpd process in Activity Monitor and the web service doesn't run.


If we run from a terminal:


sudo apachectl -k start


the web service start but with the wrong root directory.


If we run from a terminal:


sudo serveradmin start web


the result is:

web:state = "RUNNING"

web:status = 0


Wait for a suggestion.




Mac mini, OS X Server
  • Camelot Level 8 Level 8 (45,670 points)
    Currently Being Moderated
    Dec 4, 2012 2:08 PM (in response to Daniele Outline)

    It's almost impossible to say, given the limited data available, but there are many possibilities.


    The fact that the web service starts manually but 'with the wrong root directory' implies you have multiple Apache installations. Did you manually install your own web server setup? If so most bets are off.


    Second to that, have you tried stopping the web server via serveradmin (sudo serveradmin stop web). It may be that ServerAdmin isn't noticing the fact you killed and restarted Apache while it wasn't looking, so telling it to stop might help.


    Beyond that, what do the logs say?

  • dodonian Calculating status...
    Currently Being Moderated
    Sep 14, 2013 1:08 PM (in response to Daniele Outline)

    Hello Daniele,


    I have the exact same problem, althouth PHP doesn't seem to be the issue. I have tried everythin else (re-installing etc) with no luck. The command you suggested produces the following:


    sudo ln -s libpq.5.4.dylib libpq.5.dylib

    ln: libpq.5.dylib: File exists


    The /usr/lib has the following relevant entries:


    -rwxr-xr-x  1 root  wheel  163840 Sep 13 23:23 libpq.5.4.dylib

    lrwxr-xr-x  1 root  wheel      15 Nov 16  2012 libpq.5.dylib -> libpq.5.4.dylib

    lrwxr-xr-x  1 root  wheel      15 Nov 16  2012 libpq.dylib -> libpq.5.4.dylib


    Could you please help?


    BTW, in our case we never touched the Websites configuration. When I wanted to activate it, it never started.


    Thanks in advance


More Like This

  • Retrieving data ...

Bookmarked By (0)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.