2 Replies Latest reply: Dec 4, 2012 4:46 PM by léonie
mr.gixo Level 1 Level 1 (0 points)

I am currently running Mac OS 10.8.2, yet only have Garageband 5.1 (aka Garageband '09).

 

I cannot find anywhere how to upgrade to a newer version of Garageband.

I see the newest (?) seems to be Garageband 6.0.5, but when I tried to download it, it tells me "GarageBand 6.0 or later is required to install this update." and will not allow the update to continue.

 

I cannot find a download for version 6.0 on the apple support page.  And even then, I don't know if it will tell me that I need to install an earlier version, before I attempt to update to version 6.0..... etc.

 

I hope my question makes sense?

 

I appreciate any and all responses, and appreciate your time.  Thank you in advance.

 

 

Ultimately, I am trying to use my Behringer Xenyx X1204USB mixer as an interface for Garageband.... if that's even possible?

 

Again, thank you for any help with this.  I really appreciate it.

 

You can reach me at:  mr.gixo@gmail.com   mr.gixo at gmail dot com

 

Thanks.

 

 

-Brian


MacBook Pro, OS X Mountain Lion (10.8.2), trying to update Garageband 5.1