Skip navigation

1st gen ATV sw upd: "AppleTV can't check right now" after factory reset

487 Views 4 Replies Latest reply: Dec 5, 2012 5:53 AM by Andy Stoffel RSS
six50joe1 Calculating status...
Currently Being Moderated
Dec 3, 2012 8:06 AM

After upgrading to ITunes 11 over the weekend, my 1st gen Apple TV no longer appeared in the devices list, but my IPhone remained.   I tried several things posted here, but I had no luck.

 

I decided to try a "clean start" approach, since I have no idea how the detection of devices part of ITunes 11 work (for that matter, I wasn't sure how it worked in previous versions either).  Just one of those Apple mysteries we must live with on occasion I guess.

 

I did a factory reset of the ATV, which caused an issue more troubling and frustrating than the original one. 

 

When the network status per the Network settings screen indicates the ATV is connected to my LAN AND the internet, and I try to initiate any software update,  Sometimes immediately, sometimes after several seconds I get a "AppleTV can't check right now.  Try again later." message.  If not "right now", does that mean it will in 5 minutes,at 3am, next month, when I've said pretty please?

 

I spent many hours on a Sunday afternoon (which I'd love to have back), trying different combinations of the following, beginning with a factory reset:

 

1. Ethernet conneciton (to my FIOS router)

2. Wifi

3. Automatic ATV network configuration

4. Manual IP configuration, with verified parameters I have tested on other network devices I use.

5. Dynamic DHCP IP assignment from the router.

6. Static IP assignment on the router via the ATV's mac address.

 

In each case, the Network screen status was connected to the internet (not just the LAN) before initiating the update.  All of my other IP devices on the same router have no problems using the internet via direct ethernet and WIFI.

 

Must be a firewall problem or something in the router, right?  Nope, I ruled that out by doing a factory reset and connecting the ATV to my mobile broadband WIFI network.  Confirmed connection to the internet, but no luck with sw update.

 

Are there any kind souls that can shed light on my dilema?

Apple TV, Mac OS X (10.7.5), 1st Generation Apple TV
  • Andy Stoffel Calculating status...

    I recently did a factory reset of my ATV1 ( last week) and upgraded the Mac I use to sync to it with ( late 2008 MacBook w/OSX 10.8.2 ) to iTunes 11 yesterday. It still shows up in iTunes, though I haven't tried to sync anything TO it since then.

     

    I did notice that all of the album covers ( and whatever they're called for other media like tv shows ) are all now generic gray icons when I go to them under the Apple TV section in iTunes.

  • Andy Stoffel Level 1 Level 1 (0 points)

    I selected the update option in the AppleTV's menu and it said there was no update.

     

    Not sure I believe that since there's now a video resolution ( 480i ) that ISN'T supposed to be there with the last update to the 1st Gen. AppleTV ( 3.0.2) and wasn't if I remember correctly. But I haven't had a chance to follow up on that. Can't remember how to get to the daignostic menus that tell you that kind of info.

     

    Note: My AppleTV isn't jailbroken but it was before the FR.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.