Skip navigation

Macbook Pro won't detect linux partitioned external HD.  HELP!

3902 Views 35 Replies Latest reply: Dec 13, 2012 3:47 PM by g_wolfman RSS
1 2 3 Previous Next
Turpulus Level 1 Level 1 (0 points)
Currently Being Moderated
Dec 4, 2012 9:57 PM

I have a Seagate external HD.  The external HD is running linux.  My brand new Macbook Pro is running Mountain Lion.  On my previous mac, I was running an older operating system.  Snow Leopard I believe.  When I plugged in the external linux HD, it would be detected and mount.  When I plug in the HD to my new computer, a popup reads "The disk you inserted was not readable by this computer.  I have the option to initiatize, ignore, or eject.  If I choose initialize or ignore, nothing happens and the disc won't mount.  It is detected by the disk utility app, but it won't allow me to repair or verify disk permissions or mount the disk.  I've already tried resetting PRAM and SMC.  Is there any other way for this linux HD to be detected?  I've heard that Mountain Lion doesn't have natice support for linux.  Is there anything I can do?  I just have to transfer some files from my mac to the linux partitioned drive.  THanks.

MacBook Pro, OS X Mountain Lion (10.8.2)
1 2 3 Previous Next


More Like This

  • Retrieving data ...

Bookmarked By (0)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.