1 2 Previous Next 18 Replies Latest reply: Dec 5, 2012 12:37 PM by Terence Devlin
llmedrano Level 1 Level 1 (0 points)

my photos show up as thumbnails in iphoto, but when i click on them they just show a big gray exclamation mark!  no photo to find


imac, Mac OS X (10.5.6)
  • 1. Re: thumbnail but no photo....
    stevenandtasha Level 1 Level 1 (0 points)

    This happened to me too. I have never had this problem before....What's going on?

  • 2. Re: thumbnail but no photo....
    mmmoosette Level 1 Level 1 (0 points)

    I see my photos as thumbnails. When I try to edit some of the  photos just a black screen appears in edit mode.  No photo to edit.  This happened when I upgraded to iPhoto '09.  Rebuilt iPhoto per Apple support but still nothing.  I'm desperate to edit my photos .  Hope someone can help.

  • 3. Re: thumbnail but no photo....
    bitman Level 2 Level 2 (290 points)

    I had the same problem. When you launch iPhoto while holding the Command and Options you get the Rebuild Library dialogue box. Check just the one that says Examine and repair file permissions. That worked for me. In my case some of my photos had file permissions set to not allow me to do anything other than view the thumbnail. Seemed to be related to multiple users for the same iPhoto library.

  • 4. Re: thumbnail but no photo....
    Terence Devlin Level 10 Level 10 (123,775 points)

    The ! turns up when iPhoto loses the connection between the thumbnail in the iPhoto Window and the file it represents.

     

    Option 1

    Back Up and try rebuild the library: hold down the command and option (or alt) keys while launching iPhoto. Use the resulting dialogue to rebuild. Choose to Rebuild iPhoto Library Database from automatic backup.

     

    If that fails:

     

    Option 2

    Download iPhoto Library Manager and use its rebuild function. This will create a new library based on data in the albumdata.xml file. Not everything will be brought over - no slideshows, books or calendars, for instance - but it should get all your albums and keywords back.

     

    Because this process creates an entirely new library and leaves your old one untouched, it is non-destructive, and if you're not happy with the results you can simply return to your old one. .

     

    Regards

     

    TD

  • 5. Re: thumbnail but no photo....
    mmmoosette Level 1 Level 1 (0 points)

    Thank you for the help.  Everything is good now.

  • 6. Re: thumbnail but no photo....
    nataliefromvictoria Level 1 Level 1 (0 points)

    Thank you so much!

    This just started happening, even to photos that I had previously edited, and I was freaking out. I used the "examine and repair file permissions" tip and it worked. I didn't have the "!" that others were describing, just the black screen with the thumbnails across the top.

    Thanks again!

  • 7. Re: thumbnail but no photo....
    srlake314 Level 1 Level 1 (0 points)

    This did not correct the problem.  I went through all the options listed under the CMD OPTION.  It is still showing this background/event photo but wont show it, just an exclamation point.  There's no way of tracing it back to where it is because the archaic way iPhoto works. 

  • 8. Re: thumbnail but no photo....
    Terence Devlin Level 10 Level 10 (123,775 points)

    Any reason why you're resurrecting a thread from 19 months ago? Now sure how you can complain that "this" did not correct the problem, then there are two options, and the second is clearly marked 'If that fails'. There is nothing archaic about how iPhoto works. Do you mean you don't understand it?

  • 9. Re: thumbnail but no photo....
    srlake314 Level 1 Level 1 (0 points)

    I did both post's suggestions and the icon still is there in my iPhoto libarary but I cannot access the actual photo.  So how does one find that photo since iPhoto works differently than it does in the finder.

     

    There's no get info option.

     

    The only option is to delete it and pray that I can find the photo again somewhere.

  • 10. Re: thumbnail but no photo....
    Terence Devlin Level 10 Level 10 (123,775 points)

    You know, it might help if you took the time to explain the actual problem you are having.

  • 11. Re: thumbnail but no photo....
    srlake314 Level 1 Level 1 (0 points)

    I thought I did.  It's the same as what the post is.  Let me extrapolate for you further.

     

    It started with me trying to change my desktop background randomizer.  I went to the finder and obviously clicking on the iPhoto Library icon doesnt reveal anything.  So I went to the source and opened iPhoto.  From there are two listed events, AppleDesktop and Pictures. 

     

    I selected the AppleDesktop and there it shows thumbnails of all the photos that are supposedly there, however when I click on the thumbnail of the picture that I want to look at, I get the exclamation point, just like this post says.

     

    I was led to this post via the search.  Neither solution gave me the results that everyone seems to says worked for them.  Hence why I posted this to see if I could get some help.

     

    Where is this photo?  Is my only option to delete it to clean out the library? 

  • 12. Re: thumbnail but no photo....
    Terence Devlin Level 10 Level 10 (123,775 points)

    Stick around here a while and you'll see people posting all sorts of things into threads that have no relevance whatever to their issue. So, frankly, I never assume that just because something is in a thread that it is actually the same problem.

     

    Were there any error messages when you ran iPhoto Library Manager? It also helps if you tell us what version of iPhoto you have.

  • 13. Re: thumbnail but no photo....
    srlake314 Level 1 Level 1 (0 points)

    iPhoto 11 on Lion OSX.  There are no Errors.  Are you not reading what i'm posting?  I ran all of the CMD OPT and they were fine, but the photo keeps appearing and not deleting or updating. 

     

    Regardless of what I do the picture is still being shown but when I go to access it or when the desktop randomizer runs it just skips over that photo.

  • 14. Re: thumbnail but no photo....
    LarryHN Level 9 Level 9 (56,670 points)

    Sorry but this thread is about

     

    my photos show up as thumbnails in iphoto, but when i click on them they just show a big gray exclamation mark!  no photo to find

    You are not using iPhoto but the system preferences to set background photos 

     

    Looking at the desktop using the system prefernce has nothing at all to do with iPhoto

     

    And your process does not compute - if you want iPhoto photos in your screen saver you simply select iPhoto

     

    LN

1 2 Previous Next