Skip navigation

AirPort Express (2012) drops network connection after ~1 hour...ideas?

29947 Views 86 Replies Latest reply: Jan 7, 2014 4:55 PM by Dannywave RSS
  • alk3_skiba Calculating status...

    I too am experiencing the same issue.  I recently purchased an AX to extend my AE signal.  It orignally stayed on the network for a day or so, but now drops off anywhere between 15min to an hour and blinks amber.  The only option to restore the connection is to unplug the device.  I also have a hidden SID but do not want to expose unless it is confirmed this is the root of the issue.

     

    All other devices connected to the AE remain connected while the AX drops.

  • eicio Calculating status...

    I have the same problem also.  My new AX is connected as a client (join a network) for airplay.  If I restart, it works fine for a while, then the amber light flashes and it can't be seen by Airplay.

     

    I have a gen 2 AX configured identically, and it works like a charm.

     

    Both are connected to Apple Airport Extreme.

  • jeremymaxwell Level 1 Level 1 (10 points)

    My old AX (802.11g) finally crapped out, so I got the new AX yesterday. I am using only for Airplay/ Airfoil in a very small house. The AX has dropped out 3 times in 24 hours already. I have the AX set to join the current network on my Airport Extreme. Is the issue possibly due to interference from the Direct TV wireless box that is nearby the tv/ sound system? That's about the only thing I can think of as the culprit, though there is nothing that can be done if this is the problem. Boo. Help please!

  • eicio Level 1 Level 1 (0 points)

    I have the same drop out issue, but don't have Direct TV.  The new AX product is flawed.  We can only hope Apple will fix this with a software/firmware update.

  • bewaudio Level 1 Level 1 (0 points)

    Same issues

     

    Airport Express can not stay on a pretty generic wifi network.

     

    Does not seem to matter what settings are used, join, extend, DHCP, static IP, after 2 min, no devices can see it.

     

    Poor product if this many people are having issues.

  • Dilznik Level 1 Level 1 (125 points)

    Hi,

     

    I don't think it's a new Express issue.  I was having the issue with my old Express and thought it was the microwave.  It dropped all the time.  So I got a new Express out of frustration.  Same issue.  But it only happens when I'm streaming music to it.

     

    Here's my situation:

     

    1. Express used as main wifi router attached to Cisco cable modem.  Headphone jack out to stereo amp.

    2. Old Express in other bedroom, computer speakers hooked up to headphone jack.

     

    Here's what happens:

    1. Streaming music to new Express OR to old Express in that main router position causes the wifi network to drop. No Macs, phones, iPads, etc can connect.  Light is still green.  Light on old express flashes yellow.  Resetting power to main Express fixes issue.  Restarting anything else makes no difference.

    2. Streaming music to old Express in other room does not cause drops.  It just works.

    3. If I don't stream music to the Express in the main room, it doesn't lose connection.

    4. It makes no difference with a new or old Express.

  • johnnygoodface Level 1 Level 1 (10 points)

    Hi Dilznik,

     

    I've been using an Airport Extreme for over 2 years now without ANY type of drops, so either my Airport Extreme  is resilliant to any interferences or I'm in a "non problematic" environnement. But either way, with the Airport Express that's an other story all together: always drops after x min... light stays green but can be seen in Airport Utility, bla bla bla...

     

    The Express is flawed. Period.

     

    Apple: WE NEED A NEW FIRWARE UPDATE

     

    yours,

     

    Jean

  • Dilznik Level 1 Level 1 (125 points)

    New info:

     

    I hooked up an old square Express via ethernet to the new Express and streamed music to it.  No drops all night.

     

    To recap:

     

    Using Express, old or new, as main wifi router AND streaming music to it causes the Wifi to drop out to all devices.  Tested streaming from MBP and iPhone 4s.

     

    Anyone else have that particular scenario?

     

    This must be a firmware bug.  How do you submit a bug report to Apple?

  • dtrasbo Calculating status...

    I had the same problem as most of you are describing here and I got it working.

     

    Tl;dr: Call your ISP and have them update the firmware in their router. My ISP (Fullrate, DK) had a patch ready specifically for the AirPort Express.

     

    The gist of the setup: AirPort Express 2012 with latest firmware (bought less than two weeks ago). Set up to join the network existing network (aka client mode). Connected to an amp through the jack port.

     

    Problem #1 (diff. problem): For starters I set it up with an iPhone through Wi-Fi settings and it seemed to go smoothly. I went into the Music app and it worked. But in iTunes on Mac it would time out, unable to connect. But at the time I solved it by turning off IPv6 on the Mac as suggested elsewhere.

     

    Problem #2 (what's discussed here): Then I experienced what most people in here describe. Both on a Mac and an iPhone. It would work well to begin with, but then if you paused it just for a little while it would err (Error code -50). Interestingly it would be marked with a warning sign in AirPort Utility (as in, it had become invisible) but still stream successfully. But then if you paused it wouldn't be able to pick it back up.

     

    Problem #3 (also diff. problem): Just for fun* I configured the Express to create its own network instead. That meant having to connect it to my ISP's router. But the Express refused anything was connected. I don't know if this has also been solved as I haven't tried that configuration again, but it might have been. But I could connect to its network and stream music, I just couldn't go online.

     

    The solution: The folks at Apple Support suggested two things: Creating a new network (unsuccessful) and call the ISP because they might know which ports to unblock to get it working. I called the ISP and they applied a patch to their router specifically for the Express. I don't know if unblocking ports is what the patch did, but it solved the problem.

     

    Hope this can help some folks in here. :-)

  • johnnygoodface Level 1 Level 1 (10 points)

    Wow!

     

    What do you mean by : .... call the ISP because they might know which ports to unblock to get it working.

     

    Are we implying that some ISP would block certain ports that are essentials for the Airport Express to stop dropping the WiFi signal?

     

    I don't see any relation between the signal dropouts and opening/closing ports on the ISP side

     

    Can you help me understand your solution, because I don't wanna look stupid when my ISP is asking me why they should apply patches to their router and I don't understand the reason myself

     

    Do you know what ports/type need to be opened?

     

    Thank you very much

     

    Jean

  • Dilznik Level 1 Level 1 (125 points)

    How would having the ISP open ports on a router affect the wireless connection?

     

    router---<cable>---AE1---<cable>---AE2====wireless====laptop

    (music connection on AE1)

     

     

    The laptop doesn't touch the router when I'm streaming music.  As soon as I added AE2 and ran the music off of AE2 I never had another issue.  AE1 appears to not be able to handle internet and streaming music at the same time.  Even when the music was streaming off of AAC files on the laptop.

  • dtrasbo Level 1 Level 1 (0 points)

    An important nuance is the distinguishment between joining and extending the existing network. There are people in both camps in here. In my particular case I wanted the Express to act as a dumb client (e.g. a printer), so it joins the network.

     

    When it joins the network all trafic between the Mac/iPhone/whatever goes through the router. So in my case the router being the culprit makes sense.

     

    A guy from Apple support told me to try and call my ISP because someone in the router might be blocking the Express - he didn't actually mention ports but that's what first came to mind. So I found this page: http://support.apple.com/kb/TS1629 and searched for "AirPlay". Apparently it uses five different ports. So I figured maybe if it starts at port 80 which normally isn't blocked and then switches to a different port which is, it might think the Express has gone missing. Please remember, these are wild guesses.

     

    But when I called Fullrate and asked if he could unblock the ports AirPlay uses he said "well yes, I suppose so" at first. But then suddenly it occured to him that they had a patch ready for Express support. Never got a chance to ask what it did. Would've been awfully interesting to know.

     

    Edit: Maybe it's worth just giving it a shot and call the ISP and ask if any customers ever had issues with the Express. It's a relatively popular product, so there's a good chance they have something in stock.

  • dtrasbo Level 1 Level 1 (0 points)

    See my reply to johnnygoodface.

  • Angelo77 Level 1 Level 1 (0 points)

    I tried my AE with another router wifi g. It is stable without any issue since a week.

    I guess then that is incompatible with mine. I'll try to change it with another one.

  • Dilznik Level 1 Level 1 (125 points)

    So I now have my Airport Extreme connected to the router, the new AE in my bedroom hooked up to speakers, and two old AEs, also hooked up to speakers.  Everything works great except the new AE.

     

    It'll play a couple of songs and then drop.  Always it drops at the end of a song, not in the middle.  Weird.  All the rest work great.

     

    Too bad they have a 14 day return policy, not 30 days.  I'd take it back.  Piece of junk.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (6)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.