Skip navigation

Apple TV update 5.1 broken?

19582 Views 51 Replies Latest reply: Jan 30, 2013 2:05 PM by Riptide76x RSS
  • JanetMFC Calculating status...
    Currently Being Moderated
    Nov 28, 2012 6:57 AM (in response to Riptide76x)

    I updated as well and now despite home sharing being on on both computers they do not show up on my apple tv.  This renders it useless since I have someone who is unable to walk and needs to be able to access many things via the tv. 


    Any help?

  • Mr N Level 1 Level 1 (20 points)
    Currently Being Moderated
    Nov 28, 2012 7:35 AM (in response to JanetMFC)

    Hi Janet.


    I had this problem for ages too, and got no help from Apple.


    I managed to fix it though. Not saying this will work for you, but it's worth a try.


    For clarity, I have an Apple TV 2 updated to the latest system - 5.1 And I am using my late 2009 27" iMac (running Mountain Lion) to generate wifi from it's built-in card. I was fine with Home Sharing until 5.1, when it stopped working.


    Anyway, I fixed it.


    I went into System Preferences on my iMac. There, I clicked on 'Sharing', and then again on 'Internet Sharing', so I could go into 'Wifi options' down in the corner. When there, I clicked on the 'Security' dropdown. 5.1 means it only lists WPA2 Personal. But if you hold the option key and click the dropdown, you have a choice. I changed mine back to what it was before - 128-bit WEP. Then I entered the password, clicked 'OK', and re-checked the 'Internet sharing' box.


    Now my Apple TV can see my iMac. It still seems a little slower when initially loading a film or TV programme, but it's reliable.


    Let me know if this works, or if you have any questions. Good luck.

  • katsbrasil Calculating status...
    Currently Being Moderated
    Dec 1, 2012 1:03 PM (in response to Mr N)

    You solved my issue, I gotta give you big thanks!!

  • swamprock Calculating status...
    Currently Being Moderated
    Dec 6, 2012 1:02 AM (in response to Riptide76x)

    I have an Apple TV 3. 5.1 didn't really affect me much, as I use a Wi-Fi connection, but after updating to 5.1.1, I could no longer connect to Netflix, and couldn't get Hulu Plus to work either (although it did let me set up an account; one I quickly deleted). I tried these with ethernet, and they worked, but ethernet is impractical for me. I had to downgrade to 5.0.2 to get things working again. Instructions on how to do this are at


    It seems 5.0.2 is still a signed update, and the downgrade went off without a hitch.


    I reported this issue to Apple.

  • airplayman Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 30, 2013 11:04 AM (in response to Riptide76x)

    Everytime I try to turn airplay on to show my desktop screen on my apple tv I get the following error message:


    Er heeft zich een fout (-6722) voorgedaan tijdens de verbinding met het AirPlay-apparaat 'Apple TV'


    "An error has occurred (-6722) during the connection with the AirPlay-device 'Apple TV'


    Anyone else having this problem?

  • airplayman Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 30, 2013 11:08 AM (in response to airplayman)

    This problem has occured since I updated to version 5.1 of the Apple TV

1 2 3 4 Previous Next


More Like This

  • Retrieving data ...

Bookmarked By (4)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.