1 Reply Latest reply: Dec 11, 2012 1:41 AM by jeskasper
jeskasper Level 1 Level 1 (0 points)

Hi everyone,

 

I am at my last options now, so I thought I would ask the community.

 

I have been struggling with my iCloud sync these days, and finally got some of it working. Let me recap.

 

My setup is:

1 iPad 1 running iOS 5.11

1 iPhone 5 running iOS 6.0.1

1 MacBook Pro Retina running OS 10.8.2

 

I have Pages on all devices and all are up-to-date.

 

My problems started when I noticed that my Mac was not syncing to iCloud from Pages.app. I could create documents and it told me they were saved in iCloud, but when I logged in to iCloud there were no documents (I only have one iCloud ID - my personal email).

The iPhone and iPad was syncing perfectly with iCloud and documents created on these devices ended up on my Mac.

 

I tried disabling iCloud on the Mac and reenabling it - still no go. Finally I tried disabling iCloud, deleted the folder /Library/Mobile Documents, rebooted and enabled iCloud again. Lo and behold - it started working again.

 

I proceeded to add my documents to iCloud using the Pages.app windows and they appered on iCloud.com and also in the Pages iCloud view on my iPad. I arranged them in folders via Pages.app and these changes reflected on the iPad and on iCloud.com

 

I was a happy man - until I opened Pages on my iPhone. There was NO documents. When I create a document on the iPhone, it gets uploaded to iCloud.com and appears on my iPad - but nothing syncs back the other way.

 

I tried a lot of ways from apple discussions and nothing seems to have worked. This is some of the things I have tried:

 

1) Disable Documents from iCloud settings.

2) Disable use of iCloud in the Pages settings panel.

3) Enable Documents from iCloud settings.

4) Enable use of iCloud in the Pages settings panel.

 

Still no data.

 

I have then tried iterating upon this and throwing in:

 

1) ...

2) ...

2b) Delete Pages from iPhone

2c) Reboot iPhone

2d) Reinstall Pages from AppStore

3) ...

4) ...

 

Still nothing.

 

Third iteration involves the same, but not reinstalling Pages from appstore, but installing it by syncing with my iTunes on my Mac.

 

Still nothing.

 

I have no idea what to look for - if I go to Settings --> iCloud --> Storage and Backup --> Storage --> Pages then I see all the documents i SHOULD be seing in the app....

 

Any ideas?

 

Best regards,

 

Jes


iPhone 5, iOS 6.0.1