Skip navigation
This discussion is archived

Getting a 403 error on the podcast link, but works manually

1080 Views 6 Replies Latest reply: Dec 6, 2012 10:11 AM by Roger Wilmut1 RSS
SamMonson Calculating status...
Currently Being Moderated
Nov 30, 2012 5:57 AM

I'm going through the iTunes podcast submission process and I get an error when I enter the Podcast Feed URL:


Error message is "We had difficulty reading this feed. Bad http result code: 403"


But it passes the verifyer fine, and If you click on iTunes->Advanced->Subscribe to Podcast.. then it loads up the podcast fine, has all of the episodes etc.


So it seems to me that the issue must be in the process somewhere, are Apple having problems with their podcast submission process or is there anything else I'm missing? I can't see any contact form or anything where I can actually email somebody.



  • Roger Wilmut1 Level 9 Level 9 (63,940 points)

    Error 403 is 'access to this URL is forbidden'. Since it's perfectly accessible in a browser and in the iTunes application it's difficult to see what the problem is. Either the Store is having trouble with submissions process, which of course is something one can't test, or your server is throwing an objection when the request comes from them. This is unusual but it's not impossible - we've seen cases where podcast episodes which seemed OK wouldn't play in the Store - though I've never seen an explanation for it nor indeed confirmation that this really is the reason. I can only suggest you ask the people running your server. Perhaps their logs may show something.

  • aidancrawford Calculating status...

    I'm having the same problem. I even tried uploading the file to another server and resubmitting - same error.


    But it does work manually. It verifies on the feedvalidator. And it works fine on Feedburner.


    We can't be the only two people with this issue. Where is the support from Apple?

  • Roger Wilmut1 Level 9 Level 9 (63,940 points)

    As you haven't posted your feed URL one can only give a genernal answer which basically is the same as above: with a situation as you describe the server may be failing to handle requests which come from the iTunes Store. Since most people don't have any problem this suggests that the issue is with your server and it would be up to the people running it to sort this out. In your case as two servers have this issue that explanation may not cover it, but in that case there may be a problem with your feed. Validating in FeedValidator isn't necessarily a clean bill of health.

  • aidancrawford Level 1 Level 1 (0 points)

    Hi Sam,


    Are you using Wordpress? Someone just suggested a security plugin could be the culprit. And when I think back this all started when I updated Bulletproof.


    I'm trying an alternate domain this afternoon to see if that helps.

  • Roger Wilmut1 Level 9 Level 9 (63,940 points)

    SamMonson wrote:

    ...but then there doesn't seem to be any process to report issues to them.

    You could try emailing them at podcasts 'at', but don't be surprised if you get a form answer telling you you to submit a podcast.


More Like This

  • Retrieving data ...

Bookmarked By (0)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.