Skip navigation

iCloud Contacts Will Not Sync

290251 Views 189 Replies Latest reply: Mar 12, 2014 10:12 PM by Greeneida RSS
  • tamcole Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 17, 2012 2:50 AM (in response to kevincsd)

    An old post, I know - but I just started having this problem. I enter most of my new contacts into address book on my desktop machine and they suddenly stopped syncing to the ipad and the iphone.

     

    I did all the complicated stuff with deletions and vcards, but the simple solution appears to be related to account names, as someone has pointed out.

     

    I re-logged into icloud using my original .mac address instead .me (whick I normally use) - and lo and behold, all the contacts appeared where they should.

  • karenhofstetter Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 19, 2012 5:05 AM (in response to MarkyMarkSoCal)

    Hi Mark!

     

    What do you mean with "Merge the vCard back into your contact list." ? I couldn't get it. I'll appreciate if you could help me.

     

    Thanks!

  • dvb Level 1 Level 1 (5 points)
    Currently Being Moderated
    Nov 19, 2012 9:22 PM (in response to Jesse Barnum)

    so i have lots of contacts from many years under "on my mac." i see "icloud" and "All icloud" but i'm unable to drag and drop anything to this "all icloud" list. the vcard ghost appears as i drag it, but no "+" appears hovering over the all icloud and it just bounces back to it's previous place.

     

    (i tried making icloud my default account, but i then lose a lot of editing options for newly created contacts--instead of "edit" i see only "add contact" and "share.")

     

    puzzle puzzle.

    -db

  • plipsey Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 26, 2012 5:50 PM (in response to missingsc)

    I have been following these and other threads since I got my Iphone5 last week and ran into the syncing problem.  I tried all suggestions and a few of my own ideas.  Like many of you , I have invested hours on this problem including re-entering contacts and cleaning duplicates.  Computer glitches make me like a dog after a bone- I have to work it out.  All that said, my conclusion is that there is no problem with icloud- the problem is with Microsoft Outlook.  When I abandoned outlook ( as an instructor I do not need many of the features of Outlook although I enjoyed them for years) and use only the contact and calendar apps that came with my Mac Pro and Iphone.  It works seamlessly.  I can enter data either on the phone, in the cloud, or on my computer and they all sync.  Peace at last- may you find the same. 

     

    PS  I should note that I have the latest version of Microsoft Outlook and I believe that is where the problem exists.  My daughter has an older version of Outlook and an Iphone 4.  She has never had problems. 

     

    Message was edited by: plipsey

  • pocketJey Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 28, 2012 7:43 PM (in response to missingsc)

    The following solved it for me. For whichever device that is not syncing, go to the iCloud settings:

     

    1) Disable the iCloud option for the program that is not syncing (ex., Contacts).

    2) Select "keep local copy"

    3) Re-enable the iCloud option for the program

    4) Select "Merge"

     

    Worked for me on my Mac and iPhone 5. Hope it helps.

  • Phelsy Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 30, 2012 4:51 AM (in response to MarkyMarkSoCal)

    THANKS A MILLION TO MarkyMarkSoCal!!!!!

    I followed step by step his solution and it worked like a charm for me!!!

  • B1GM1KE Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 6, 2012 9:31 AM (in response to kevincsd)

    I was having a problem after creating a contact on my iPhone and it not showing up on my Mac using iCloud. Maybe what I did to fix it will work for you guys. Basically I just created a new iCloud account to sync contacts and set it up using my old info (my existing iCloud account) on my Mac. It synced the new contacts I had recently added but duplicated the others. To eliminate the duplicates I just went back and deleted the account I had just set up so that the only iCloud account was the original one and it worked. I realize that sounds a bit confusing but it worked! Hope it helps!

  • TomLusch Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 8, 2012 9:13 AM (in response to B1GM1KE)

    For the past 24 hours I have been so confused by this whole Contact syncing issue.  But I now believe I have a resolution.

     

    It was yesterday when I noticed that some contacts that I had added Notes information to on my iPhone, did not appear with those updated Notes in my Contacts application on my iMac.  I've spent hours upon hours trying to understand and resolve this issue.  I think the problem arose since I updated to Mountain Lion last month (but I just noticed it yesterday). 

     

    What I have finally resorted to is not storing the contacts on my iMac, but instead totally using iCloud for storage of those contacts. 

     

    If you look at the upper left of your Contacts window, you'll see "All Contacts", "On My Mac>All on My Mac", and "iCloud>All iCloud".  See image, wherein "All iCloud" indicates being selected (bold light blue wording)...

     

    Contacts upper left.jpg

     

    I plan to keep "All iCloud" selected from this point on (or until Apple resolves this issue and makes it simple).  I have deleted all my contacts in "All on My Mac". 

     

    If you try this method of resolving your sync issue, before deleting all your contacts from your Contacts application, you may want to select File>Export (from within your Contacts application), and create a backup. You may want to then select "All iCloud" and do the same thing (name it slightly differently so it doesn't overwrite). 

     

    Then, go back to "All on My Mac", select a single contact, then perform a "select all" (Command-A) so that all your contacts are highlighted.  Then hit your delete key on your keyboard.  You'll be given a warning.  Hit okay, and then all your contacts will disappear from your "All on My Mac" selection.

     

    Then select "All iCloud", and use that exclusively.

     

    Now, when I add a contact using my Contacts application on my iMac, that contact appears moments later on my iPhone (and vice versa), and edits all seem to work no matter where they originate.  That makes sense, as it is just one database that Contacts, iCloud, and my iPhone are working from now. 

     

    I'm concerned about not having a local backup of my contacts that are now exclusively stored in iCloud. Maybe I'll occasionally do an export and save those, so that if something happens to iCloud, I'll be able to restore from something locally stored. 

     

    I hope this helps you understand and possibly gets you back to having truly synced contacts (and saves you hours of trying to understand what should be a seamless operation).  Good luck.

  • LidsvilleBrown Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 18, 2012 2:34 PM (in response to TomLusch)

    Same problem here. I really can't believe that after all this time, changes made to my On My Mac contacts don't get sent to my iPhone through iCloud, which is fully activated. Changes to contacts in iPhone go to the Mac, but not vice versa. And all tips above have not, so far, worked for me to correct this problem. Totally a pain to use. I'm going to get off the iCloud. It constantly screws up iTunes playlists and is not the clever tool Apple thinks it is. It's a time-waster.

  • JerryN Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 28, 2012 2:34 PM (in response to LidsvilleBrown)

    I've just spent hours with Apple on the phone over two days trying to figure this out.

    The only solution seems to be to set up a new iCloud account and repopulate it with your most up-to-date data.

    I would suggest doing it all with the help of a senior Apple tech person, but here's what we did.

     

    So first, set up the new account.

    Then for example, if the best data is on your iPhone:

    1. backup your iPhone on iTunes (you should also back up all your data from your iMac etc., on Time Machine. You may even want back up, seperately, the data in iCal and Contacts)

    2. log out of iCloud on all your other devices

    3. click on settings on the iPhone

    4. click on iCloud

    5. delete account

    6. Save data on iPhone

    7. Then go back into settings on iPhone

    8. Set it up to the new iCloud account.

    9. Give it plenty of time to update.

    10. Reopen iCloud on your other devices using the new iCloud account.

    11. Be patient as the accounts all update

     

    I hope this helps!

  • Scubaman31 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 29, 2012 7:15 AM (in response to JerryN)

    I've had Contact sync problems from the day I purchased my iPhone 4S (November 2011) and tried migrating my previously M/S Outlook data - I suspect MicroSoft is involved in this somehow! Things improved with the release of IOS5 (how long ago was that!!) but there are still irritating problems that none of the Apple Tech Guys I've talked to have been able to solve. 

     

    As of today (December 2012) at least I have the same number of contacts on each device (MBP, iPhone, iPad).  The only trouble is I have duplicates and if I delete one duplicate it deletes the other one too!!  At some point I'm just going to have to bite the bullet and re-enter all my contact information as I've come to the conclusion this is the only way forward... 

     

    What with the IOS6 Maps fiasco you do begin to wonder what's got into Apple of late...

  • JerryN Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 30, 2012 12:31 PM (in response to Scubaman31)

    I think the reason "deleting one duplicate deletes the other one too" is that they're not really duplicates. See TomLusch's entry above. You may be seeing them as duplicates because you have the view selected to see all the contacts rather than just the ones in a particular group.

    Check in your Contacts list on your Mac. If there are indeed duplicates, you can delete them by going up to "card" in the Contacts menu, them click on "look for duplicates" in the drop down menu.

  • thedoor1 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 31, 2012 3:58 PM (in response to JerryN)

    JerryN mentioned starting complete with a new account. I think that is overkill.  This is what finally worked for me without have a new iCloud account.

     

    (Prelims:  assuming you have all contacts in Addressbook and you have safely archived already)

     

    1- Logout of iCloud on your Mac, iPhones, iPads, any other device, so they stop syncing.

    2- In address book, highlight all contacts, File>export> vCards (note where you save that one vCard file).

    3-highlight and delete ALL contacts on ALL devices. That means in Address Book, in iCloud in a web browser, iPhones, etc.  After deleting, log out of everything, reboot, and verify contacts were blank in all devices and on iCloud.com (for me there was one that kept appearing for a few minutes).  (I Reset all data on my iPad and started from scratch, as I had locally stored contacts on it).

    3- In a web browser, log onto iCloud.  Go to Contacts.  Drag and Drop your vCard file into contacts. It will populate.

    4- On your Mac, log back into iCloud under system preferences and allow the merge when prompted.

    5- Open address book. It should have imported all the iCloud contacts.  If there are any in an "On my mac" group, delete them and that line item disappears, for good.

    6- Log into to iCloud on your devices and choose to allow iCloud to manage contacts.

     

    I tested adding, editing and deleting in all methods from there and it work.

     

    My hunch is that when you reload as a vCard file to iCloud.com, any history of those contacts doesn't go along with them and syncing gets to start fresh, like a new account.

  • MrGhost970 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 17, 2013 4:48 AM (in response to pocketJey)

    This worked for me. Thank you.

  • Queueman Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 22, 2013 3:53 PM (in response to MrGhost970)

    I have a MacBook Pro and an iPhone 5. The contacts on the iPhone were in sync with iCloud, but not the ones on my Mac. I think I've got the problem resolved.

    Here's what I did, somewhat different than "thedoor1" did.

    1. First I got all my contacts in the cloud looking the way I wanted. I used the phone to do this. When I had first imported some company names looked like people, that is last and first name, so I cleaned that up.
    2. Once everything on the iPhone looked good, I verified that the changes also took place on the Cloud.
    3. I exported all my contacts from iCloud to a flash drive with a copy on the hard drive, so I would have a backup (or two).
    4. On the Mac, I turned off syncing for contacts.
    5. I then deleted all "on my Mac" contacts. (I couldn't figure out how to delete all at once, so I did them one at a time.)
    6. Next I went back to my contacts in the cloud and did a "select all" from the settings at the bottom of the screen.
    7. After "select all", I chose export to vcard. The default seemed to go to the Mac, so that is where I let it go.
    8. My contacts all imported onto the Mac, but there was no longer an "on my Mac" folder, only iCloud.
    9. I then turned sync back on and tried adding and modifying both on the laptop and on the iphone, the sync seems to be working both ways.

    What I did differently than "thedoor1" was that I didn't delete iCloud or iPhone contacts, only the "on my Mac".

    This may not be the solution for everyone, but it worked for me. It seems that having both an iCloud and an "on my Mac" was causing the sync issue.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (11)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.