Skip navigation

Magsafe charger only works intermittently

5697 Views 13 Replies Latest reply: Nov 21, 2013 9:14 AM by sbuchan55 RSS
atenati Calculating status...
Currently Being Moderated
Jan 23, 2011 9:48 AM
So this is my second time posting the following, as it got deleted and completely disappeared (even from my own posts in my profile).

I own a 13" white 2007 MacBook:

Model Name: MacBook
Model Identifier: MacBook2,1
Processor Name: Intel Core 2 Duo
Processor Speed: 2 GHz
Number Of Processors: 1
Total Number Of Cores: 2
L2 Cache: 4 MB
Memory: 4 GB
Bus Speed: 667 MHz
Boot ROM Version: MB21.00A5.B07
SMC Version (system): 1.17f0

My girlfriend has a brand new MacBook Pro from this summer.
Both our computers suddenly started behaving weirdly about a week ago. I'm writing now on 5% batter power so I'll make it short. We have tried everything but our chargers just don't work properly. We have about 3 chargers and 5 heads/cords and all combinations have failed to yield result more than once. I have restarted my computer, taken the battery out, restarted PR-things and SMC and I have cleaned the heads and I have even tried to install an update from Apple but it told me my mac didn't need this update.
So what the * is wrong with the magsafes? It's a real pain because we can have them working for many hours as long as we don't touch them - then if we move or want to unplug the charger for even just 1 second, they might not work again for 2 days.

So please help us. We're both writing our BA theses and need our computers working. Thanks!

PS: I received a message telling me this was a duplicate but it is not the same issue addressed by most people here because we are using both L and T shaped magsafes and it makes absolutely no difference. Both behave stupidly.
macbook, Mac OS X (10.6.4)
  • Lyssa Level 6 Level 6 (14,780 points)
    Currently Being Moderated
    Jan 23, 2011 10:49 AM (in response to atenati)
    Everything you're mentioning is classic symptoms of a battery that needs to be replaced. I highly suggest you do so.

    ~Lyssa
    13" White Macbook; 160 GB black iPod Classic ^_^, Mac OS X (10.5.8), iBook G4 (Tiger); 3G iPod, Blueberry iBook/Gemini. iPhone 4 ^_^
  • Lyssa Level 6 Level 6 (14,780 points)
    Currently Being Moderated
    Jan 23, 2011 10:57 AM (in response to atenati)
    Hmm. An oddball question, but have you guys seen the same troubles if you're at someone else's house?

    ~Lyssa
    13" White Macbook; 160 GB black iPod Classic ^_^, Mac OS X (10.5.8), iBook G4 (Tiger); 3G iPod, Blueberry iBook/Gemini. iPhone 4 ^_^
  • TinChicago Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 26, 2011 4:06 PM (in response to atenati)
    Does anyone know if there is an update fix to address issues associated with new (supposedly improved) power adapters NOT lighting / charging with a MacBook running OX S 10.4.11? I find update fixes (SMC Firmware Update 1.4) at apple.com for OX S 10.5.8 and 10.6.4 and later only. Thanks.
    MacBook, 13-inch white
  • gjrowe Calculating status...
    Currently Being Moderated
    Aug 22, 2011 5:40 PM (in response to atenati)

    I am having the exact same problem. Any solution yet?

  • Csound1 Level 7 Level 7 (32,360 points)
    Currently Being Moderated
    Aug 22, 2011 5:45 PM (in response to atenati)

    At 1366 cycles your battery should be replaced, hers I'm not so sure but maybe. Get a new battery for yours and see how the Magsafes behave, take hers to the Apple Store and let them diagnose.

  • fqmontesclaros Calculating status...
    Currently Being Moderated
    Nov 22, 2011 1:05 AM (in response to atenati)

    Hi, I am having exactly the same issues with my new Macbook Pro 15" (2011) . Tried different outlet at different locations (home and work) and I got different results; sometimes it works sometimes it doesn't. Did you get resolution for this issue?

  • Stin0 Calculating status...
    Currently Being Moderated
    Nov 11, 2012 1:23 AM (in response to atenati)

    Same problem, MBA 11" Juli 2011. Laptop sometimes charges, but most often not. Friends 60w Magsafe works, own 45w Magsafe works on friends MBP, no signs of wear on adapter. Tried SMC reset, with no effect.

  • cmeseen Calculating status...
    Currently Being Moderated
    Dec 6, 2012 8:08 AM (in response to atenati)

    I am having the same problem with a MacBook Pro 13, intermittent charging, any solution yet?

  • Stin0 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 6, 2012 11:16 AM (in response to cmeseen)

    Hi,  After I had it checked at the Apple store Genius desk, a new adapter fixed it for me.

  • sbuchan55 Calculating status...
    Currently Being Moderated
    Nov 21, 2013 9:14 AM (in response to atenati)

    I had this problem 2 months after I bought a MBP in 2013. I followed theese steps http://support.apple.com/kb/ts1713 and found that there was a little metal speck in the magsafe port on the laptop. I cleaned it with a q-tip and the problem was solved.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.