Skip navigation

apps for 3g 4.2

257 Views 8 Replies Latest reply: Dec 6, 2012 11:18 AM by profwimbley RSS
profwimbley Calculating status...
Currently Being Moderated
Dec 6, 2012 11:06 AM

Hi there

 

I wonder if anyone will be able to help me.

 

I lost my phone and the replacement is a second hand iphone 3g with iOS version 4.2.

 

Every time I try and download an app, I get a message saying that the app requires iOS version 4.3 which apparently I cant get with a 3g.

 

Is there somewhere I can get basic apps, camera apps, sleep talking, facebook, twitter etc. for a 3g bog standard peasant iOS 4.2, or is there a way to upgrade to a 4.3 that anyone knows of??

 

Help gratefully recd, thanks for your time

iPhone 3GS
  • razmee209 Level 7 Level 7 (21,195 points)
    Currently Being Moderated
    Dec 6, 2012 11:08 AM (in response to profwimbley)

    Sorry you can't since you have a 3G and the highest IOS is 4.2.1

     

    YOu'll have to upgrade your phone to use those apps.

     

    For facebook you can use safari to log in.

  • Allan Eckert Level 8 Level 8 (39,335 points)
    Currently Being Moderated
    Dec 6, 2012 11:10 AM (in response to profwimbley)

    Your iPhone 3g can't be upgraded above iOS 4.2

     

    The developers of apps found that newer version of iOS were so much better that they dropped support for 4.2

     

    So about the only path for you is newer hardware which allow you to run a newer version of iOS

     

    Allan

  • ChrisJ4203 Level 7 Level 7 (26,390 points)
    Currently Being Moderated
    Dec 6, 2012 11:12 AM (in response to profwimbley)

    You were told in another thread that for the 3G, iOS 4.2.1 is the highest iOS it supports. If you want a higher iOS, you will need to purchase a device that will support it. The 3GS would be the least expensive one you could get, and it will support up to iOS 6.0.1, the current iOS. Also, the decision to support a particular iOS is the decision of the app developer, they decide what to offer in the app store.

  • razmee209 Level 7 Level 7 (21,195 points)
    Currently Being Moderated
    Dec 6, 2012 11:13 AM (in response to ChrisJ4203)

    Dang I didn't even catch that, and I responded to both threads.

  • ChrisJ4203 Level 7 Level 7 (26,390 points)
    Currently Being Moderated
    Dec 6, 2012 11:15 AM (in response to razmee209)

    Been a long day. I told someone earlier about getting their support voided on the forum by opening their phone.

  • ChrisJ4203 Level 7 Level 7 (26,390 points)
    Currently Being Moderated
    Dec 6, 2012 11:17 AM (in response to profwimbley)

    As others told you, the 3G is quite old, as far as phones are concerned, and as such the developers have decided to no longer support the iOS. You would need to search the App Store to see what apps may be supported by your device. As you check the app, see what iOS it supports, however, I'm afraid you may be disappointed. Great excuse to upgrade your device.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.