8 Replies Latest reply: Dec 6, 2012 11:29 AM by léonie
Morgenlstar Level 1 Level 1 (0 points)

I am really struggling with Aperture because of how long it takes to edit photos.  One stroke with the retouching brush brings up the "loading" notification with the spinning dial for 10-30 seconds and I can't get any work done!  I am running:

 

MacBook Pro 15-in early 2011

2.3 GHz Intel Core i7

4 GB 1333 MHz DDR3

Intel HD Graphics 3000 384 MB

OS X Lion 10.7.4 (11E53)

 

694.47 GB free out of 749.3 GB on my 750 GB SATA Disk Hard drive

Aperture Vers: 3.3.1

 

I do not have faces enabled and this computer was purchased brand new in February.  I don't think I should have to upgrade my ram on a brand new computer to run a program.  I have the same problem on my imac which was not improved after upgrading its ram to 16 GB.  This leads me to believe upgrading the ram on my macbook is not going to help.  What can I do?!

 

Please help before my laptop takes flying lessons!! =)


Aperture 3, Mac OS X (10.7.4)
  • 1. Re: Aperture is too slow!
    d-light Level 1 Level 1 (45 points)

    Hi Morgenlstar,

     

    have you already tried the following?

    1. create a new library and see if editing images in that one behaves any better
    2. Put the graphics card in Higher Performance mode (Energy Saver System Preferences) on the MacBook Pro
    3. Check if any  background online processes (such as backblaze, dropbox, MobileMe Sync) are running - as they may significantly slow down also Aperture's performance
    4. See if it makes any difference if you run as few additional apps as necessary. Also swapping between apps may slow things down

     

    Just a few ideas. BTW, I am working on an iMac, too. Mid 2010, i5, 16 Gb RAM (o.k. that is much). Well, it is no secret that Aperture is not the fastest image processing software in the world. But it performs quiet well in my case. Hardly any problems when e.g. retouching images (RAW originals).

     

    Cheers,

    d-light

  • 2. Re: Aperture is too slow!
    léonie Level 9 Level 9 (51,645 points)

    Hi,

    In addition to the things pointed out by d-light i'd recommend to do trouble shooting on your Aperture library. 10-30 seconds loading time on a brand new mac is much too slow, unless you have very large images and projects with thousand images or more. What is the file size and pixel size of your images btw? If your images are much larger than the usual 10-15 Megapixel, 4 GB RAM may be insufficient.

     

    A corrupted Aperture library may cause these symptoms too, so try to repair the library with the Aperture Library First Aid Tools. Hold down the options-command-key combination while you double click the Aperture icon to launch into First Aid mode, then select "Repair Database" and run the repair. If this does not help, try also "Repair Permissions" and "Rebuild Database".

     

    Regards

    Léonie

  • 3. Re: Aperture is too slow!
    SierraDragon Level 4 Level 4 (2,695 points)

    Morgenlstar wrote:

    I am running:

     

    MacBook Pro 15-in early 2011

    2.3 GHz Intel Core i7

    4 GB 1333 MHz DDR3

    Intel HD Graphics 3000 384 MB

     

    I don't think I should have to upgrade my ram on a brand new computer to run a program.

     

    Apple and Adobe have always blatantly lied about the RAM necessary to properly run their applications. Pro graphics apps have always demanded the best hardware for the best performance.

     

    In fact your laptop is the first that actually will run Aperture at a professional level - IF it is properly equipped with a good graphics card, minimum 8 GB RAM and an underfilled hard drive.

     

    You describe a 2011 15" i7 MBP with no graphics card, just integrated graphics. I thought all the 2011 15" i7 MBPs also had a graphics card, but if yours indeed does not then that definitely is limiting to Aperture.

     

    4 GB RAM generally is inappropriate in a 2011 MBP. I strongly recommend upgrading to at least 8 GB RAM. My Mac is similar, a 2011 17" MBP. In my case I page out 8 GB RAM all the time whith Aperture + Photoshop running. I am about to add an 8 GB DIMM for 12 GB RAM, and in your case I recommend that adding an 8 GB DIMM for 10 GB total RAM; then regularly testing, and if page outs exceed zero add another 8 GB DIMM of RAM for 16 GB total. Fortunately third party RAM from top vendors like OWC or Crucial is cheap now.

     

    Inadequate RAM may or may not be an issue, but often it is. Another common cause of slowing operation is hard drives slowing as they fill, so make sure no hard drive is more than ~70% full; even less full is preferable for speed.

     

    You should evaluate whether or not you have adequate RAM:

     

    Look at the Page Outs number under System Memory on the Activity Monitor app before starting a typical Aperture work session and write the number down. Recheck the Page Outs count after working and write the number down again. If the page outs change (manual calculation of ending page outs number minus starting page outs number) is not zero your workflow is RAM-starved. Ignore the pie charts and other info in Activity Monitor.

     

    If your test showed that page outs increased during operation you can

     

    • add RAM (very strongly recommended)

     

    • and/or simply try to run Aperture by itself

     

    • Restart before Aperture work sessions to clear possible memory leaks

     

    • and/or switch from 64-bit operation to 32-bit operation (which will make some additional RAM space available). See Switching Kernels:

    http://support.apple.com/kb/HT3773]Mac OS X v10.6: Starting up with the 32-bit or 64-bit kernel

     

    You mention an iMac with 16 GB RAM and lame performance. I suggest that you post your issues with that box as a separate thread because each setup is different.

     

    Also what Léonie said.

     

    HTH

     

    -Allen Wicks

  • 4. Re: Aperture is too slow!
    Integr8d Level 1 Level 1 (15 points)

    I'll take a crack at it...

     

    Depending on how much Aperture uses the video card, you could be in for some issues. I seem to recall one or two runs of the 15" MBP's that had integrated (Intel) video only. If this is you and if Aperture wants the video card to do the heavy lifting, that would be a big deal. And it sounds like that's what's happening. You make the stroke and it has to do the calculations. I get it.

     

    If you can open Activity Monitor and make a note of what happens, when you make that stroke, (i.e. cpu performance) that would be a good clue. Also, search the web for a program similar to gpu-z. Gpu-z is like Activity Monitor for the video card. It will let you see how much load it's under. Also, take a look at your memory and check for disk swaps in Acitivity Monitor. If you restart your computer and open Aperture then a few images and you start getting hits on your hard drive, you need more memory. But I have the same amount of memory and after a restart and opening a dozen or so 16MP raws, I still have ~1GB of memory free. So I doubt if that's it. And fwiw, Aperture seems to release the memory after about 7 or 8 images. So there seems to be a limit there.

     

    I found this b/c I was noticing a slow down in 3.3 and wondered if it was a massive issue. After restarting, all seems okay. Takes about 1.5 seconds to load a 16MP raw. It's not jpeg-instant. But it seems to be okay. Ironically, the image comes up quickly. It's the LUT that's taking forever. Definite math involved in that.

     

    Good luck, man.

  • 5. Re: Aperture is too slow!
    Integr8d Level 1 Level 1 (15 points)

    Something like this...

     

    http://www.atpurpose.com/atMonitor/

     

    This thread ( https://discussions.apple.com/thread/2688374?start=0&tstart=0 ) is where I found that link and also seems to hint that the amount of video ram is the limiting factor. In your case, 384MB is not a lot. No way to upgrade that either. Depending on how adventurous you are (I'm very), I'd search for a same-generation MBP motherboard with dedicated graphics and think about making the swap. There are probably shops around that'd do it for you. I've had the motherboard out on my old MBP a few times (first C2D model). Compared to the old models (I also have early 2011, matte high-res, 4GB, 256GB ssd, etc), the new ones are 100x easier to disassemble. And it would beat having to buy a new model. Plus, you'd have the opportunity to clean up the thermal grease on the cpu, gpu and northbridge. "Apple" does a sloppy job with it and if you use high-quality silver paste, your temps will drop and your fans won't constantly rev up like little leaf blowers.

  • 6. Re: Aperture is too slow!
    Integr8d Level 1 Level 1 (15 points)

    Final thought is that if you go to System Prefs, Display, choose the lowest resolution possible and restart, I'd like to know if Aperture performs any better. Theory is that the lowest res will consume the least amount of vram. You should notice a speed up.

  • 7. Re: Aperture is too slow!
    UTChris Level 1 Level 1 (0 points)

    leonieDF wrote:

     

    A corrupted Aperture library may cause these symptoms too, so try to repair the library with the Aperture Library First Aid Tools. Hold down the options-command-key combination while you double click the Aperture icon to launch into First Aid mode, then select "Repair Database" and run the repair. If this does not help, try also "Repair Permissions" and "Rebuild Database".

     

    Regards

    Léonie

    Great info guys and thanks for sharing the repair database info, Léonie!  Worked like a charm and now Aperture is so much faster and more pleasant to use.

  • 8. Re: Aperture is too slow!
    léonie Level 9 Level 9 (51,645 points)

    You are welcome, UTChris!