Skip navigation

TS1398: iOS: Troubleshooting Wi-Fi networks and connections

Learn about iOS: Troubleshooting Wi-Fi networks and connections

TS1398 Wi-Fi greyed out?

1989 Views 8 Replies Latest reply: Jul 8, 2013 1:11 PM by Ainswld RSS Branched to a new discussion.
chilli5122 Calculating status...
Currently Being Moderated
Oct 1, 2012 9:54 PM

I upgraded my operating system on my 4s to 6 & now I cannot access my wi-fi button as it is greyed out, it has

also affected my icloud backup, same thing its greyed out.

 

I went into my local Apple Store & they told me that they had never heard of this problem, they then told me

to connect to itunes & do a complete restore of my iphone, I have done this but its still the same, can anyone please assist?

 

Cheers

iPhone 4S, iOS 6
  • modular747 Level 6 Level 6 (15,675 points)
  • modular747 Level 6 Level 6 (15,675 points)
    Currently Being Moderated
    Oct 1, 2012 10:29 PM (in response to chilli5122)

    Did you notice the "or" in the tile of the support article?

  • modular747 Level 6 Level 6 (15,675 points)
    Currently Being Moderated
    Oct 1, 2012 10:56 PM (in response to chilli5122)

    It gave you several troubleshooting steps to try, which sometimes work. 

     

    However, in many if not most cases, this is due to a hardware failure.  Updating and restoring the phone is stressful to the device, and can cause marginally functioning components (such as the WiFi chip) to fail.  In that case, replacement will be your only option.

  • Funo Calculating status...
    Currently Being Moderated
    Dec 5, 2012 4:48 PM (in response to modular747)

    I had this problem. I contacted apple and they told me if I restore the phone and wifi/bluetooth is still greyed, it's most likely a hardware issue. After determining that is was indeed a hardware problem, they sent me a new phone. This is where it gets bad. They put a $600 hold on my checking account (I was aware of this beforehand) and mailed the new phone via FedEx. 7 days passed and I tracked it and it had been stuck in Memphis for 4 days. I called fedex and apperently it had been lost. They told me to contact apple and have them contact them (fedex) to figure it out. After apple contacted them, they called me back and said it was under "investigation" and that could take 7 business days. I asked if they could release the hold on my checking account and they said no. SO, now they continue to hold $600 of MY money for their phone's failure and fedex's failure to keep track of it. I find it unfair to have my money held from me due to their companies' failed product and service. I also find it to be poor business to not have a direct email contact to apple support to plead my case. I guess it's not their concern that other people have big plans for my money!

  • Rachelattack Calculating status...
    Currently Being Moderated
    Dec 6, 2012 6:22 PM (in response to chilli5122)

    Hey guys! I've got a weird tip for anyone having issues with their WiFi after updating to iOS 6.0.1. It won't work in everyone's case but I've had it work for a few folks I've spoken to who work for tech support:

     

    -What's your device named? If you're like so many of us, it's something like _____'s iPhone. If you've got an apostrophe in your devices name, that MIGHT JUST BE THE PROBLEM.

    Check out Settings>General>About>Name (all the first options) if you're not sure.

     

    -See an apostrophe? Tap on the name to edit it, and remove the apostrophe. Save the change.

     

    -Press and hold the Sleep/Wake button at the top right edge of the phone and the Slide to Power Off.

     

    -Start 'er back up again!

     

    -Check to see if you're now able to connect to Wi-Fi

     

    I don't have specific information as to why this can correct the problem, suffice it to say that it must be some setting getting in the way. The problem with restoring the device to factory settings - as so many have mentioned they've been told to do short of replacing the **** things - is that you may well be setting it up again with the same name as before.

     

    Give it a shot! Worst case scenario is that you lose about 45 seconds out of your day troubleshooting something infuriating.

  • Ainswld Calculating status...
    Currently Being Moderated
    Jul 8, 2013 1:11 PM (in response to Rachelattack)

    This worked, What the heck!!!!??

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.