Skip navigation

How to get applejack to run in single user on 10.6.8?

1748 Views 24 Replies Latest reply: Dec 18, 2012 9:37 AM by este.el.paz RSS
1 2 Previous Next
este.el.paz Level 1 Level 1 (90 points)
Currently Being Moderated
Dec 6, 2012 6:19 PM



Had this question added onto a thread I had posted in the 10.4.11 discussion, but this is about getting applejack to run on a MBPro with 10.6.8, so Mr Hillyer suggested that some folks over here could answer this question . . . "blindfolded, and with both hands tied behind their backs . . ." he said that . . . trust me.


I've tried to install applejack 1.6 on my MBPro running 10.6.8 about three times it says, "Installed successfully" . . . but when I boot into single user (command + S) . . . there is no "type applejack" in the CLI . . . and when I type "applejack AUTO shutdown" or any variation in the yellow text shell, it just returns a, "applejack is not recognized and isn't part of anything here . . . " words to that effect.  Whereas in the iMac 10.4.11 I can boot to CLI and it gives me the various options for running AJ, and I only installed it one time . . . .  Any thoughts?  Of course Onyx is always an option . . . but now I'm getting feedback that it isn't so good for the system????


Many thanks,



MBP 15 2.53 GHz, Mac OS X (10.6.8), iBook G4, 14, 933 MHz (10.4.11), iMac G4, 15, 800MHz
  • red_menace Level 6 Level 6 (14,275 points)

    Your single user mode is probably using a default shell, so you might try using the full path.

  • Linc Davis Level 10 Level 10 (107,995 points)

    Any thoughts?


    Yes. You don't need "Applejack," "Onyx," or any other third-party software for routine maintenance. If you actually need to do any of things that script is supposed to do more than once every few years, if ever, then something is seriously wrong with your computer and Applejack isn't going to fix it.

  • red_menace Level 6 Level 6 (14,275 points)

    Unless you have set various environment variables to tell the system where to start looking if you just type something like applejack auto shutdown, you need to use the full file path to wherever you installed the application, e.g. /path/to/where/you/installed/it/applejack auto shutdown.

  • Linc Davis Level 10 Level 10 (107,995 points)

    I have never used Applejack and cant help with it. According to the man page, it installs a shell profile for the root user with an alias pointing to the location of the script. Therefore you shouldn't need to enter the full path to that script in order to run it in single-user mode.


    This is an open-source project, and therefore you're expected to do most of your own troubleshooting with it. The developer's support page is here:


    AppleJack Project Page

  • Neville Hillyer Level 4 Level 4 (1,845 points)

    My contributions elsewhere based upon my Leopard experience were:


    The following Terminal command should list AppleJack if it is installed:


    sudo ls /private/var/root/Library/Scripts


    As a further check you can use the following Terminal command:


    sudo cat /var/root/.profile


    This should result in:


    alias applejack='/var/root/Library/Scripts/'     #AppleJack Installer

    echo ""     #AppleJack Installer

    echo "For troubleshooting assistance, just type 'applejack' at the prompt"     #AppleJack Installer


    You could try the following in single user mode:


    sh /var/root/Library/Scripts/


    You confirmed that the first 2 were OK but the third did not work.

  • Neville Hillyer Level 4 Level 4 (1,845 points)

    there was the whole MacWorld suggestion a few years back that if the computer is not fully awake 24 hours a day then the interal OSX maintenance scripts, daily, weekly, monthly . . . would not run


    I have not seen any evidence that this affects OSs other than 10.4 and 10.5. For these OSs I think you will find the following is the best solution:

  • Linc Davis Level 10 Level 10 (107,995 points)

    Why are you wasting your time searching for files you have no hope of ever finding, when the list is right there on the site I linked to earlier?




    What are you going to do with these files if you do find them, besides deleting them (which is what you should do)?


    Really, this Applejack garbage has already cost you far more in lost productivity than you'll ever get back from it, even if you do manage to get it to work.

  • Mark Jalbert Level 5 Level 5 (4,390 points)

    When I type ->


    whatis applejack

    I get


    applejack: nothing appropriate
1 2 Previous Next


More Like This

  • Retrieving data ...

Bookmarked By (0)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.