2 Replies Latest reply: Dec 8, 2012 7:18 AM by loot
loot Level 1 Level 1 (0 points)

I want to disable SSL for the Apple Wiki service.

(I need port 443 for Kerio Connect Mail Server running on the same machine, and the Wiki will only be accessed internaly or via VPN anyway..)

 

In Server.App (version 2.1.1) under Hardware -> Server -> Settings -> SSL Certificate -> Edit

 

There you can set which certificate to use for every service, you can also set it to NONE.

But for the Websites service I can NOT set it to none.

 

You can also set it globally for all services, there you can set it to NONE, but the little f***er just keeps reverting to custom!!!

 

Is this normal behaviour? can anybody check if you see the option NONE for the "Websites" service?

 

Cheers from Amsterdam!

-loot

 

Screen Shot 2012-12-07 at 15.33.44.png


OS X Server
  • 1. Re: How to disable SSL certificate on Mountain Lion Server?
    A  Level 1 Level 1 (35 points)

    This is in fact normal behavior. The Websites service has two default sites, one with SSL and one without SSL. You can change the certificate used for the SSL site, but you cannot delete its certificate, and that restriction makes sense since there's already a default site with no certificate.

     

    You can of course add custom sites, and use the SSL Certificates pane to configure each one of those sites either with a certificate or without a certificate.

  • 2. Re: How to disable SSL certificate on Mountain Lion Server?
    loot Level 1 Level 1 (0 points)

    Thanks for your reply A!

     

    It seems one can customize ports, certificates, IP binding etc for the web service hosting sites,

    but for the Wiki? nothing...

     

    I played around with some apache config files too, but I can't seem to get rid of port 443 if I want to use the Wiki...

     

    I can't seem to bind the Wiki/Apache to a specific IP either.

     

    I can't seem to change the 443 port used by the Kerio Connect mail server because it will freakout iOS when configuring accounts, so thats not an option either...

     

    As a work-around I'm doing the following after evert restart (not very viable for a server):

    Manually turn off the Wiki service, now port 443 is availble for Kerio's HTTPS service, so I manually start it,

    then start the Wiki service again, and since port 443 is now taken by Kerio the wiki will use port 80 only!

     

    So it looks like my options are:

     

    - Find a way to bind the Wiki to a specific IP.

    - Find a way to change or turn off port 443 for the Wiki service.

    - Run Kerio Connect mail server as a VM in Fusion.

    - Run Kerio Connect on a different machine on OSX Client.

    - Use the Apple Mail service.