6 Replies Latest reply: Jan 30, 2013 2:18 PM by DC11
John H Level 3 Level 3 (845 points)

I have migrated from lion to Mountain lion server and when I try to log in to the server ( via the default from the migration) app it says 'SSL error has ocurred and can't connect to to the serve"

I am on the server when I try this.

 

If i try to connect via "other mac" the password is rejected.

 

Is there some command line I can use to clear this SSL issue.

  • 1. Re: SSL Server app error
    John H Level 3 Level 3 (845 points)

    Logs not overly informative but FYI

     

    8/12/12 8:11:16.418 PM ReportCrash[717]: DebugSymbols was unable to start a spotlight query: spotlight is not responding or disabled.

    8/12/12 8:11:16.720 PM ReportCrash[717]: failed looking up LS service ( scCreateSystemService returned MACH_PORT_NULL, called from SetupCoreApplicationServicesCommunicationPort, so using client-side NULL calls.

    8/12/12 8:11:16.720 PM ReportCrash[717]: LaunchServices/5123589: Unable to lookup coreservices session port for session 0x186a0 uid=0 euid=0

    8/12/12 8:11:16.720 PM ReportCrash[717]: failed looking up LS service ( scCreateSystemService returned MACH_PORT_NULL, called from SetupCoreApplicationServicesCommunicationPort, so using client-side NULL calls.

    8/12/12 8:11:16.720 PM ReportCrash[717]: LaunchServices/5123589: Unable to lookup coreservices session port for session 0x186a0 uid=0 euid=0

    8/12/12 8:11:16.720 PM ReportCrash[717]: failed looking up LS service ( scCreateSystemService returned MACH_PORT_NULL, called from SetupCoreApplicationServicesCommunicationPort, so using client-side NULL calls.

    8/12/12 8:11:16.720 PM ReportCrash[717]: LaunchServices/5123589: Unable to lookup coreservices session port for session 0x186a0 uid=0 euid=0

    8/12/12 8:11:16.720 PM ReportCrash[717]: failed looking up LS service ( scCreateSystemService returned MACH_PORT_NULL, called from SetupCoreApplicationServicesCommunicationPort, so using client-side NULL calls.

    8/12/12 8:11:16.720 PM ReportCrash[717]: LaunchServices/5123589: Unable to lookup coreservices session port for session 0x186a0 uid=0 euid=0

    8/12/12 8:11:16.720 PM ReportCrash[717]: failed looking up LS service ( scCreateSystemService returned MACH_PORT_NULL, called from SetupCoreApplicationServicesCommunicationPort, so using client-side NULL calls.

    8/12/12 8:11:16.720 PM ReportCrash[717]: LaunchServices/5123589: Unable to lookup coreservices session port for session 0x186a0 uid=0 euid=0

    8/12/12 8:11:16.802 PM com.apple.launchd[1]: (com.apple.servermgrd[716]) Job appears to have crashed: Segmentation fault: 11

    8/12/12 8:11:16.803 PM com.apple.launchd[1]: (com.apple.servermgrd) Throttling respawn: Will start in 10 seconds

    8/12/12 8:11:17.017 PM ReportCrash[717]: Saved crash report for servermgrd[716] version 10.7.2 (10.7.2) to /Library/Logs/DiagnosticReports/servermgrd_2012-12-08-201117_mail.crash

    8/12/12 8:12:26.055 PM com.filemaker.syslogger[92]: Admin Server process has terminated abnormally.

    8/12/12 8:12:26.055 PM com.filemaker.syslogger[92]: Starting Admin Server process...

    8/12/12 8:12:26.074 PM com.filemaker.syslogger[92]: Admin Server process has terminated abnormally.

    8/12/12 8:14:26.314 PM com.filemaker.syslogger[92]: Admin Server process has terminated abnormally.

    8/12/12 8:14:26.314 PM com.filemaker.syslogger[92]: Starting Admin Server process...

    8/12/12 8:14:26.333 PM com.filemaker.syslogger[92]: Admin Server process has terminated abnormally.

  • 2. Re: SSL Server app error
    alienbabyGA Level 1 Level 1 (0 points)

    I have exactly the same problem with exactly the same errors listed in /var/log/system.log

     

    The one that stands out the version reported for servermgrd.  10.7.2

    Prior to the upgrade to Mountain Lion; 10.8.2, the box was fully upgraded to the latest Lion, 10.7, No outstanding patches.

     

    Just upgraded to 10.8.2 last night, and 10.8 server this morning.

     

    Open the server app to verify everything upgraded Ok from 10.7..  Go to login, and after providing my login for the server app, several moments later I get the error about an SSL issue.

     

    I have no idea where to go from from here..  Paid my money for a broken upgrade.

    Very upsetting.

  • 3. Re: SSL Server app error
    MDH825 Level 1 Level 1 (0 points)

    I also upgraded to server 10.8 today and am having the same problem with this SSL issue

  • 4. Re: SSL Server app error
    Humbertotime Level 1 Level 1 (10 points)

    I had this problem today and it had to do with previously changing the server name.  I corrected the error by opening keychain access and deleting the certificates associated w/ the older server name.

  • 5. Re: SSL Server app error
    lozzzz Level 1 Level 1 (5 points)

    As per Humbertotime, but I had to delete both the certificates and the private and public keys in keychain access. I did this after upgrading to ML. The problem was the original "machine.local" certs & keys, from before I applied its full name "machine.example.com".

  • 6. Re: SSL Server app error
    DC11 Level 2 Level 2 (195 points)

    For me, there was only 1 certificate that I had to delete: com.apple.servermgrd

    I had 8 certificates to choose from, and wasn't sure which one(s) needed to be removed. I tried logging into the server through the Server application from my computer, and was told that certificate could not be trusted. I set it to be trusted, but still couldn't log in. As soon as I deleted that certificate, the server setup began working, and I was able to login and finish.