Skip navigation

Change Permissions on Wiki People page?

3200 Views 21 Replies Latest reply: May 12, 2013 4:28 PM by tim_r_66 RSS
  • mehrab @ zettachem Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 22, 2012 4:14 AM (in response to joe_mck)

    Hi

     

    Right now in wiki in people page, when I click of eacj user except admin, it can not open profile of that user and says:

     

     

    Routing Error

     

    No route matches "/wiki/people/elvira.tufekcic/Elvira_Tufekcic.html"

     

     

    any idea?

     

    thanks in advance

  • basilmir Level 1 Level 1 (65 points)
    Currently Being Moderated
    Dec 20, 2012 11:51 AM (in response to joe_mck)

    There is a "master switch" you can use to disable people view everywhere.

     

    It's in the OS X Server: Advanced Administration Guide

     

    http://help.apple.com/advancedserveradmin/mac/10.8/#apd59153f0a-7ed3-4c64-9c74-3 a1fff831475

     

     

    You can change wiki service settings by editing plist files.

    You can change the following settings by editing /Library/Server/Wiki/Config/collabcored.plist

    disable_projects_view

    false

    Set this to true to disable the Wikis page in the wiki. Set this to false to enable the Wikis page in the wiki.

  • tim_r_66 Level 1 Level 1 (30 points)
    Currently Being Moderated
    May 5, 2013 9:47 AM (in response to joe_mck)

    This is what I found out too.  In fact, I originally thought the fix didn't work with Mountain Lion until I read this thread.  I guess for now I will set the permissions to my Wiki to be non public.  However, eventually I will likely want to make it public, and then I'll have to decide how to protect the privacy of the users.

     

    I guess one option would be to set up a second server, one for interal and one for external.

     

    Tim

  • tim_r_66 Level 1 Level 1 (30 points)
    Currently Being Moderated
    May 11, 2013 12:12 PM (in response to basilmir)

    Playing with this some more today and was amazed and how this is designed, not in a good way either.  I set disable_people_view to true and then brought of the Wiki (after restarting the service).  While people pages and my user settings, etc., no longer displayed, if I click on All Activity from the home page, even as an unauthenticated user, I can still see the blogs. 

     

    Editing the people_controller.rb as described above gets the closest to making blogs private but these are still visible to iPad (and I assume other mobile devices). 

     

    Disturbing.  I guess I'll got the route of create a special wiki for my own personal private use, and leave the blog open for information I am comfortable having others read.

  • tim_r_66 Level 1 Level 1 (30 points)
    Currently Being Moderated
    May 12, 2013 4:28 PM (in response to tim_r_66)

    I am going to add another twist to this.  Would be interested in knowing if someone else gets similar behavior.

     

    I created a private wiki for just me so I could move my content I did not want public to even iPad users.  I moved two blog entries to this new wiki.  And, when I went back in to look from the iPad as an unauthenticated user, none of the content was visible except for my main page (People).  

     

    The server doesn't prompt the unauthenticated user to log in, it just doesn't display the content.  This behavior differs from a full up Mac/Safari set up when the user is prompted to log in when trying to access any content.

     

    Things that make you go, "hmmmmmmmm".

     

    Tim

1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (3)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.