Skip navigation

No Wake-on-LAN possible since updating to ML

92060 Views 281 Replies Latest reply: Apr 11, 2014 5:32 AM by Abraham Zabih RSS Branched to a new discussion.
  • chasb441 Calculating status...
    Currently Being Moderated
    Nov 15, 2012 2:15 AM (in response to joda1956)

    Just making a point and I am not your daddy. Your post sounded like you had not read the whole thread as you made reference "I wonder if anybody else has tried it" and if you had read all the posts then you will have noted others have tried. Only making a statement of fact and if it upset you then please accept my apologies.

     

    I for one do not have a solution and yes I do suffer the same. If I see of or hear elsewhere of a solution I would share it with everyone. But making repeat posts and stating the obvious I do not do.

  • joda1956 Calculating status...
    Currently Being Moderated
    Nov 15, 2012 4:27 AM (in response to chasb441)

    @Chasb441

    So both of us are still waiting for a solution from Apple. I hope you did'nt mind my reply, I usually add a ;) to tell, that is more fun than seriously being upset. So accept my apologize aswell.

    Best regards from Madrid.

  • gglockner Calculating status...
    Currently Being Moderated
    Nov 20, 2012 7:56 AM (in response to SteffenKaiser)

    I have a variety of different Macs in my home, and some testing showed that the issue varies by the Mac model.  My biggest concern was waking my 2009 Mac Pro via LAN.  What I found was that when jumbo frames was enabled (MTU=9000), the Mac Pro failed to respond to the Wake On LAN command.  When I set the frame size back to standard (MTU=1500), it now responds to Wake On LAN.

     

    Newer Macs in my home don't seem to have this same issue.  So I'd say to give this a try.

  • Andreas Leupin Calculating status...
    Currently Being Moderated
    Nov 25, 2012 12:36 PM (in response to SteffenKaiser)

    To be clear I confess, that I havn't read the entire thread, but for me the WOL works within the LAN (Mac Pro, early 2008), if I set the subnet mask in the "Wake on LAN" app to 255.255.255.0.

    By this, the magic packet is broadcasted to all devices in the LAN.

    What is more cumbersome for me is to Wake the Mac over the Internet. This is, because my router (Netgear Wndrmac) doesn't support to forward the incoming magic packet to a broadcast address and it isn't also not possible to set a static entry in the ARP table (the problem seems to be here, that the ARP table of the router isn't updated anymore, when the mac goes to sleep, so it is no more possible to route the magic packet directly (by IP address) to the sleeping mac.

    I'm actually looking for a workaround for this by adding a (real) hub between the router and the mac with a device being up attached to the same router (to have an IP address to send the magic packet - a classic hub broadcasts the packet then to all its ports...)

  • loïcfernandezcastrillon Calculating status...

    Hello everyone, finally, I say finally because I've tried and tried many many stuff to fix this **** boring issue. And after many tests on different iMacs, I finally have one solution that should work for all of you.

     

    I'll tell you what I did on my iMac and on my friend's iMac, and now they both wake up when we use a remote app like team viewer/screens... I made some tests, even after 12 or 24 hours of sleep, the iMac still wakes up when I use my VNC app from my iPhone or "Back to my Mac" from my MacBook Pro.

     

    If you want to try :

    1. Repair disc permissions, to make sure everything's fine on your Mac. If you see that some permissions have been repaired, launch another repair until the list of permissions is empty.

    2. Open terminal paste that and hit enter: sudo periodic daily weekly monthly,

    It will ask for your password, type it. Then paste and hit enter: sudo dscacheutil -flushcache.

    3. Turn off your Mac.

    4. Start your Mac while holding the left shift key until you see a progress bar, let the Mac start, wait for 3 or 5 min. Then turn it off.

    5. When your start it, reset the PRAM.

    6. You're good!

     

    I made that on both iMacs and now they work like a charm. I guess the 2 commands in terminal solved the issue, because I made the other steps for weeks without success before.

     

    Hope it will work for you.

  • moomit Calculating status...

    Hi,

    Did try your workaround on my Mac Mini Late 2009 (like all the workarounds mentioned in this thread).

    Unfortunatly no luck for me.

    Anyone else luckier than me?

  • loïcfernandezcastrillon Level 1 Level 1 (80 points)
    Currently Being Moderated
    Dec 8, 2012 9:20 AM (in response to moomit)

    It is still working fine for me, the only moments I wasn't able to reach the iMac when I wasn't home were because my router change its IP sometimes, so I've installed the "Screens" app on my iMac that retrieves the IP, sometimes it can take 15min, so it was the only moments I wasn't able to access it.

     

    Otherwise, when I'm home on WiFi, no trouble at all!

  • moomit Level 1 Level 1 (0 points)

    I'm just guessing here, but maybe its a firmware problem.

    The darkwake feature isn't working either... and thats definitely firmware related.

    Don't think there will ever be a solution for older macs.

    How old are the iMacs you tried it on?

  • loïcfernandezcastrillon Level 1 Level 1 (80 points)
    Currently Being Moderated
    Dec 8, 2012 11:59 AM (in response to moomit)

    iMac early 2011, I also have a MacBook Pro late 2010, and this one doesn't have any trouble, so it's not Lion or Mountain Lion's fault, but a firmware update as you said.

     

    I remember, when I had my iMac the first days, it was working fine with Wake on Lan, except sometimes while using it, it was loosing the WiFi connection. A few days after that Apple came with an update to solve this WiFi issue, since that moment the problem came.

     

    I'm happy to have solved it, I hope it will work, cause sometimes it works for a few days and then the problem comes back... So I cross my fingers

  • loïcfernandezcastrillon Level 1 Level 1 (80 points)

    WOW I forgot to mention in my previous posts, that just after turning the iMac off, I unplugged it for 10min or so in order to reset the SMC.

  • loïcfernandezcastrillon Level 1 Level 1 (80 points)
    Currently Being Moderated
    Dec 8, 2012 12:06 PM (in response to moomit)

    Do you use an AirPort base station such as Time Capsule, AirPort Extreme or AirPort Express?

  • loïcfernandezcastrillon Level 1 Level 1 (80 points)
    Currently Being Moderated
    Dec 19, 2012 9:18 AM (in response to moomit)

    I've checked Computer/Library/Preferences/SystemConfiguration

     

    There is a file called "preferences.plist"

    Into it I found:

     

    </dict>

                                  <key>PPP</key>

                                  <dict>

                                            <key>ACSPEnabled</key>

                                            <integer>0</integer>

                                            <key>CommDisplayTerminalWindow</key>

                                            <integer>0</integer>

                                            <key>CommRedialCount</key>

                                            <integer>1</integer>

                                            <key>CommRedialEnabled</key>

                                            <integer>1</integer>

                                            <key>CommRedialInterval</key>

                                            <integer>5</integer>

                                            <key>CommUseTerminalScript</key>

                                            <integer>0</integer>

                                            <key>DialOnDemand</key>

                                            <integer>0</integer>

                                            <key>DisconnectOnFastUserSwitch</key>

                                            <integer>1</integer>

                                            <key>DisconnectOnIdle</key>

                                            <integer>1</integer>

                                            <key>DisconnectOnIdleTimer</key>

                                            <integer>600</integer>

                                            <key>DisconnectOnLogout</key>

                                            <integer>1</integer>

                                            <key>DisconnectOnSleep</key>

                                            <integer>1</integer>

                                            <key>IPCPCompressionVJ</key>

                                            <integer>1</integer>

                                            <key>IdleReminder</key>

                                            <integer>0</integer>

                                          <key>IdleReminderTimer</key>

                                            <integer>1800</integer>

                                            <key>LCPEchoEnabled</key>

                                            <integer>0</integer>

                                            <key>LCPEchoFailure</key>

                                            <integer>4</integer>

                                            <key>LCPEchoInterval</key>

                                            <integer>10</integer>

                                            <key>Logfile</key>

                                            <string>/var/log/ppp.log</string>

                                            <key>VerboseLogging</key>

                                            <integer>0</integer>

     

    Do you think we could solve the problem by changing some of the values?

  • knidsrok Calculating status...

    loïcfernandezcastrillon, you magnificent *******! That toally did the trick for me.

     

    If the part where you start up in safe mode is necessary, I'm wondering if it's clearing and rebuilding the kernel extension cache that's key.

  • loïcfernandezcastrillon Level 1 Level 1 (80 points)
    Currently Being Moderated
    Dec 20, 2012 4:33 PM (in response to knidsrok)

    Thanks a lot, what did you try? Changing the values of prefrecences.plist, or what I said before?

     

    Because the problem goes away for a moment, and comes back for any reason...

  • knidsrok Level 1 Level 1 (0 points)

    Whoops. Celebrated prematurely. It came back. Though, this time, the other computers on the network thought it as still wakeable. So I guess that's a start?

     

    I've got one computer running Mountain Lion that has wake for network access working perfectly, and one that doesn't. When I have a minute, I'll compare the plists in the SystemConfiguration and see if there are some relevent-seeming differences between the two.

1 ... 5 6 7 8 9 ... 19 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (11)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.