6 Replies Latest reply: Oct 20, 2013 9:36 PM by Woodclan7
Alfred R. Quezada Level 1 Level 1 (0 points)

Hi, my iPhone 4 [32 GB] displays the plugged in icon but its not charging, it sometimes does charges, 3 days ago I removed the cover it had and conected to the Mac and it showed the apple logo, before that it was flatted out with no charge at all and just displayed the red battery logo, but after I fully carged it it happened again and it didn't charged, I've read almost every thread about this but none help, At first the one that says to reboot your mac while charging works, it did worked for me, but right now the iPhone is at 6% for almost 13 hours, and it doesn't goes above than that, it was at 9% but I thought that if I let it discharge at least 3% it would charge then, but no use on that, something that seemed to work for me to charge it yesterday was to turn off everything putting it on Airplane Mode, but it ain't working no more, I've cleaned all the dust on the charging port, and still no use, I've also tried restoring 3 times and nothing, also did the reboot thing and nothing, so

 

What can I do to fix this?


iPhone 4, iOS 6.0.1