Skip navigation

MIDI keyboard not working in Garageband

7431 Views 9 Replies Latest reply: Jun 1, 2013 10:55 AM by CKCousins RSS
isaroo Calculating status...
Currently Being Moderated
Oct 6, 2012 2:30 PM

I just bought a new M-Audio Oxygen 25 USB MIDI keyboard controller for school (I'm a student at Berklee College of Music) and I'm trying to use it to record in Garageband. I put in the disc that came with the keyboard, clicked "install," and it said the installation was successful and I had to restart my computer, which I did. I then opened Garageband, plugged in my keyboard, turned it on, and tried to play it. Whatever key I press, I just hear the same pinging sound. It won't play different pitches, and when I try to record anything, the right notes show up onscreen in the track itself, but nothing plays back. The keyboard shows up in the Garageband preferences and in the Audio MIDI setup, so my computer definitely recognizes it, but I don't know why it won't play anything. I'm using Garageband '11 on a MacBook Pro running OS X 10.7.5, if that helps. I'm a bit technologically illiterate, so if there's anything really obvious that I forgot to do, definitely let me know! I've never used MIDI before so I kind of have no idea what I'm doing, but I have a project due later this week so any help would be much appreciated! Thanks very much.

GarageBand (Mac) '11, Mac OS X (10.7.5), M-Audio Oxygen 25 USB MIDI keyboard
  • gjmnz Level 3 Level 3 (850 points)
    Currently Being Moderated
    Oct 6, 2012 7:10 PM (in response to isaroo)

    Did you install the DirectLink drivers?

     

    Check this page http://www.m-audio.com/index.php?do=products.directlink and follow the link to the drivers. Don't worry that it only lists GB 08 & 09 as compatible. I use GB 11 with my M-Audio keyboard and it is fine. Hope that helps.

  • gjmnz Level 3 Level 3 (850 points)
    Currently Being Moderated
    Oct 6, 2012 8:10 PM (in response to isaroo)

    If the keyboard is class compliant then you do not need any drivers. However M-Audio supplies a special driver called DirectLink that enables mapping of knobs and faders for certain popular DAW's. Garageband is one of those. If you want to extend your controllers usability beyond keys, sustain, pitch bend etc and use the knobs and transport controls then you will have to install DirectLink.

     

    I am not suggesting that your controllers problems are due to not doing the DirectLink install, I am suggesting that perhaps by doing the install you may solve your problem.

     

    Another thing you may want to do first is download a trial version of another popular DAW and see if your controller exibits the same behaviour. That way you can eliminate the keyboard as the issue.

     

    Not sure what else to say. I am still on 10.6.8 and would normally do a Repair Disk Permissions as my first stop.

  • isteveus Level 5 Level 5 (4,125 points)
    Currently Being Moderated
    Oct 6, 2012 8:51 PM (in response to isaroo)

    Does software keyboard or musical typing work?

  • isteveus Level 5 Level 5 (4,125 points)
    Currently Being Moderated
    Oct 7, 2012 5:28 AM (in response to isaroo)

    Do you have the audio output set correctly in garageband preferences.

  • Chevontez Calculating status...
    Currently Being Moderated
    Dec 8, 2012 2:23 PM (in response to gjmnz)

    I have garageband 11 and I'm trying to get direct link working and it won't. I downloaded the direct link software that was on m-audio's website and also the software on the original disc. I have it on preset 10, but I'm not sure what I need to do. What folder is the M-Audio.Bundle file supposed to be in?

  • CKCousins Calculating status...
    Currently Being Moderated
    Jun 1, 2013 10:55 AM (in response to isaroo)

    Hello. I am posting this here in case it helps you out. I was having no luck using my midi controller - a M-Audio plug and play Keystation 61es - when it was plugged in to a USB port on the back of my brand new iMac. I finally tried plugging it in to a USB port on my computer's keyboard (the one you type on), and it works fine. Very odd, but it solved my problem. Garageband would recognize my keyboard, but would not allow it to interact in any way with the software - no response when I would play it.

     

    After plugging my controller into the computer's keyboard, it worked fine.

     

    This may be a Mountain Lion issue, or a new iMac hardware issue. I have an older laptop running Snow Leopard, and when I plugged directly into that computer, I had no problems at all.

     

    I hope this helps someone. I had spent two or three days trying to get this to work.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.