Skip navigation

Mail bug in Mountain Lion

95849 Views 432 Replies Latest reply: Feb 7, 2014 10:16 AM by Big Rock RSS Branched to a new discussion.
  • DWFaust Level 1 Level 1 (25 points)
    Currently Being Moderated
    Nov 26, 2012 12:06 PM (in response to markmal)

    Hopefully we’ll see a fix with 10.8.3... beta was released today... anyone with access to the dev seed that can confirm?

  • chispasco Calculating status...
    Currently Being Moderated
    Nov 26, 2012 12:17 PM (in response to DWFaust)

    If Apple fixes this issue, I'd be thrilled. As it is, I'm still occassionally sending emails from the wrong email address, looking careless & unprofessional and longing for the good old Microsoft days when things just worked.

  • applefish Calculating status...
    Currently Being Moderated
    Nov 27, 2012 7:36 AM (in response to markmal)

    Can't believe this much time as passed and this hasn't been fixed. I totally agree with the last post. By replying with the wrong address it is confusing my clients and messing with my company branding.

  • CMathis Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 27, 2012 7:56 AM (in response to chispasco)

    I've been using Macs since 1987 and Apple's prior to that.

     

    I just switched to Thunderbird and may never use Apple's Mail program again. I cannot afford to look like an idiot to me clients. This is simply unacceptable.

     

     

    chispasco wrote:

     

    …. the good old Microsoft days when things just worked.

     

  • Andreas Carlsson Level 2 Level 2 (235 points)
    Currently Being Moderated
    Nov 30, 2012 1:08 PM (in response to markmal)

    Same here!

  • doug38 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 2, 2012 10:48 AM (in response to Dgroo)

    Deleted.  Responded to wrong post. 

  • applefish Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 2, 2012 12:49 PM (in response to doug38)

    I think I'm having an "a-ha!" moment thanks, accidentally, to doug38.

     

    But it needs a bit of clarification: You need to edit your iCloud account.

    Go to PREFERENCES.

    Choose ACCOUNTS

    Click on your iCLOUD account.

    There is a dropdwon menu for Aliases- Choose CUSTOM.

    Enter your preferred reply-from email address.

    Note how that address should slide to the top of the account lists.

     

    If Doug38 trick is right, that should do the trick!

  • iacas Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 2, 2012 1:01 PM (in response to applefish)

    That isn't the problem others are describing. Even doug realized it and deleted his comment.

  • stucollins Calculating status...
    Currently Being Moderated
    Dec 2, 2012 1:08 PM (in response to applefish)

    FOUND A FIX!!!!

    (I think)...

    I started reading this thread shortly after posting my own problem, couldn't be bothered to wade through the 17 pages of this one so excuse me if this has already been said:

    Right, I had multiple email accounts, all gmail, address 1 2 & 3.

    All mail went to the right addresses, fine. But when I compose, lets say from address 1 or 2, it ALWAYS ends up being received the other end by address 3. I only find this out until I get a reply delivered to the wrong address.

     

    SO  go to preferences, select one of the problematic addresses, then outgoing mailserver (SMTP:) in this case it will say Gmail. Click it so you get the drop down and edit SMTP list. There is a tab that says advanced. This is where I noticed the problem. On my list of SMTP servers I had one for my microsoft account, and then one Gmail one for all 3 gmail accounts. And what did I find for authentication? the username and password of the problem address that ALL my gmail accounts were sending through. You need to create SEPERATE smtp servers for each and every account, especially when using multiple accounts of the same kind (e.g. 3 gmails!)

    This fixed the problem for me perfectly and now my emails send from the CORRECT selected address. HOORAH!

     

    Hopefully solved a lot of problems (presuming everyone's problem is the same) THING TO REMEMBER:

    Regardless weather it by gmail or hotmail you compose from, mac defaults to using the next working server. Before setting up seperate smtp servers for each gmail I just deleted the one that was there and then it started sending from microsoft account etc... just to clarify that it works regardless of account type!

  • stucollins Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 2, 2012 1:09 PM (in response to markmal)

    FOUND A FIX!!!!

    (I think)...

    I started reading this thread shortly after posting my own problem, couldn't be bothered to wade through the 17 pages of this one so excuse me if this has already been said:

    Right, I had multiple email accounts, all gmail, address 1 2 & 3.

    All mail went to the right addresses, fine. But when I compose, lets say from address 1 or 2, it ALWAYS ends up being received the other end by address 3. I only find this out until I get a reply delivered to the wrong address.

     

    SO  go to preferences, select one of the problematic addresses, then outgoing mailserver (SMTP:) in this case it will say Gmail. Click it so you get the drop down and edit SMTP list. There is a tab that says advanced. This is where I noticed the problem. On my list of SMTP servers I had one for my microsoft account, and then one Gmail one for all 3 gmail accounts. And what did I find for authentication? the username and password of the problem address that ALL my gmail accounts were sending through. You need to create SEPERATE smtp servers for each and every account, especially when using multiple accounts of the same kind (e.g. 3 gmails!)

    This fixed the problem for me perfectly and now my emails send from the CORRECT selected address. HOORAH!

     

    Hopefully solved a lot of problems (presuming everyone's problem is the same) THING TO REMEMBER:

    Regardless weather it by gmail or hotmail you compose from, mac defaults to using the next working server. Before setting up seperate smtp servers for each gmail I just deleted the one that was there and then it started sending from microsoft account etc... just to clarify that it works regardless of account type!

  • Andreas Carlsson Level 2 Level 2 (235 points)
    Currently Being Moderated
    Dec 2, 2012 1:12 PM (in response to stucollins)

    That is the predictable behavior of Gmail, and is unfortunately not a solution to the other problem.


    Maybe it helps someone though.

  • applefish Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 3, 2012 7:46 AM (in response to iacas)

    Thta's my point. When I applied what I did via Doug's accidental suggestion I found my emails as (at least) responding from the correlating eamail rather than always from my icloud account.

     

    Hey...my life is a little btter now.

  • shophat Calculating status...
    Currently Being Moderated
    Dec 7, 2012 9:41 AM (in response to markmal)

    I have been experiencing this issue ever since upgrading to Mountain Lion.  It doesn't happen all of the time, but there are regular occurrences of the case where replying to an email sent to my Exchange mail account is defaulted to send through my Gmail account.

  • slurpee03 Calculating status...
    Currently Being Moderated
    Dec 8, 2012 2:19 PM (in response to markmal)

    If I am understanding this issue correctly, just go to the sidebar and under Mailboxes, drag the preffered account to the top.  Then a new message will be sent using that account.

  • Kawanaut Calculating status...
    Currently Being Moderated
    Dec 8, 2012 2:24 PM (in response to slurpee03)

    Unfortunately that only fixes the issue with new mails being sent from the wrong address.

     

    The much more serious problem is that when you reply to an e-mail that has been placed in another folder (either by you or by a rule), Mail will no longer reply from the e-mail it was originally sent to. So if you have set your private email to be the one that Mail will use for new mails, and you receive a work mail that you place in a "do eventually"-folder, and you reply it later, then Mail will put your private e-mail address as sender, not the work e-mail as it would have if you left the mail in the Inbox it arrived in -or if you use Mail in any previous version of OS X.

    slurpee03 wrote:

     

    If I am understanding this issue correctly, just go to the sidebar and under Mailboxes, drag the preffered account to the top.  Then a new message will be sent using that account.

1 ... 15 16 17 18 19 ... 29 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (22)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.