Skip navigation

Can't boot into Safe mode

17246 Views 16 Replies Latest reply: Feb 5, 2014 3:50 PM by dblel RSS
1 2 Previous Next
Mark1411 Calculating status...
Currently Being Moderated
Dec 9, 2011 10:43 AM

List members: My MacPro won't boot into safe mode (holding shift key at start-up); the moving bar stops in the middle. I'm able to run fsck in single-user mode (command+S at start-up) without problems. All tests show my hardware to be OK. What could cause this strange behavior? Thanks for any thoughts.

 

    - Mark

Mac Pro, Mac OS X (10.7.2)
  • Kappy Level 10 Level 10 (221,095 points)
    Currently Being Moderated
    Dec 9, 2011 10:46 AM (in response to Mark1411)

    Try reinstalling:

     

    Reinstalling Lion Without the Installer

     

    Boot to the Recovery HD: Restart the computer and after the chime press and hold down the COMMAND and R keys until the menu screen appears. Alterhatively, restart the computer and after the chime press and hold down the OPTION key until the boot manager screen appears. Select the Recovery HD and click on the downward pointing arrow button.

     

    Repair the Hard Drive and Permissions: Upon startup select Disk Utility from the main menu. Repair the Hard Drive and Permissions as follows.

     

    When the recovery menu appears select Disk Utility. After DU loads select your hard drive entry (mfgr.'s ID and drive size) from the the left side list.  In the DU status area you will see an entry for the S.M.A.R.T. status of the hard drive.  If it does not say "Verified" then the hard drive is failing or failed. (SMART status is not reported on external Firewire or USB drives.) If the drive is "Verified" then select your OS X volume from the list on the left (sub-entry below the drive entry,) click on the First Aid tab, then click on the Repair Disk button. If DU reports any errors that have been fixed, then re-run Repair Disk until no errors are reported. If no errors are reported click on the Repair Permissions button. Wait until the operation completes, then quit DU and return to the main menu.

     

    Reinstall Lion: Select Reinstall Lion and click on the Continue button.

     

    Note: You can also re-download the Lion installer by opening the App Store application. Hold down the OPTION key and click on the Purchases icon in the toolbar. You should now see an active Install button to the right of your Lion purchase entry. There are situations in which this will not work. For example, if you are already booted into the Lion you originally purchased with your Apple ID or if an instance of the Lion installer is located anywhere on your computer.


  • Kappy Level 10 Level 10 (221,095 points)
    Currently Being Moderated
    Dec 9, 2011 11:04 AM (in response to Mark1411)

    So, then, restart the computer then after the chime press and hold down the SHIFT key until you see the spinning gear. After a while you should see a progress bar below the spinning gear. Then what exactly happens?

     

    Which Mac Pro model do you have, btw?

  • Kappy Level 10 Level 10 (221,095 points)
    Currently Being Moderated
    Dec 9, 2011 11:27 AM (in response to Mark1411)

    How long do you wait after the progress bar appears to stop moving? It may take several minutes or more. Safe boot does more than just run fsck. It also will check some system permissions, change the contents of the kextcache (certain kexts are excluded during a safe boot,) skip login items, third-party preferences, etc. Because safe boot does a bunch of stuff at startup it takes much longer than a normal startup. So my question relates to if you are waiting long enough for safe boot to complete.

     

    And, I'm guessing you've already seen: Mac OS X- Starting up in Safe Mode

  • Kappy Level 10 Level 10 (221,095 points)
    Currently Being Moderated
    Dec 9, 2011 1:53 PM (in response to Mark1411)

    Yes, I agree. Sorry, but I don't know why you would have such a problem with a newly installed system.

  • Rick Carlton Level 1 Level 1 (10 points)
    Currently Being Moderated
    Dec 9, 2011 2:28 PM (in response to Mark1411)

    What is safe mode? What's it for?

  • Kappy Level 10 Level 10 (221,095 points)
    Currently Being Moderated
    Dec 9, 2011 2:36 PM (in response to Rick Carlton)

    Mac OS X- Starting up in Safe Mode. This link is a couple of replies above.

  • doug gosciak Level 1 Level 1 (5 points)
    Currently Being Moderated
    May 14, 2012 6:08 PM (in response to Mark1411)

    Same for me. It never finishes! Why does Apple not chime in ob this issue!

  • Shaun Kennedy1 Level 1 Level 1 (55 points)
    Currently Being Moderated
    Jul 26, 2012 9:22 PM (in response to doug gosciak)

    Same here

    Mac pro early 2009

    Found this out after trying to reinstall office after reinstalling lion due to restart hangs

    Thoughts yet?

  • Allen Watson1 Level 1 Level 1 (15 points)
    Currently Being Moderated
    Dec 8, 2012 6:15 PM (in response to Mark1411)

    I'm having this identical problem in Mountain Lion. Safe Mode progress bar hangs, and I've let it run over an hour without seeing it budge once it gets stuck.

     

    Like another poster, I've booted in single user mode and run fsck, so the file system is clear. I've repaired permissions. I have not tried reinstalling Mountain Lion, but since that failed for others I doubt it will help with me.  I'm continuing to look for an answer.

  • WZZZ Level 6 Level 6 (11,880 points)
    Currently Being Moderated
    Jan 2, 2013 8:17 AM (in response to Mark1411)

    .

  • Peter N Lewis Calculating status...
    Currently Being Moderated
    Mar 6, 2013 5:33 PM (in response to Mark1411)

    So no ideas on this one?

     

    I have an Early 2008 Mac Pro and had this problem.  I've since done a clean install of Mac OS X without even migrating, copied my files across manually using Carbon Copy Cloner on various subdirectories, and the problem persists!

     

    Disk Utility verifies the disk without problems, but Safe Boot stops at 28% through the "Checking catalog file." process and never gets any further.

     

    How can a disk corruption survive that sort of clean rebuild of ths disk?  My only thought is maybe there is some sort of extended attribute corruption that Carbon Copy Cloner copies but that trips of the disk check.

     

    The only other symptom I have that may be related is Retrospect's backup fails with an opaque error message.

     

    It's very curious that it only appears to affect Mac Pros, and astounding that it manages to survive a clean format of the harddisk!

1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (2)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.