Skip navigation

SSL Server app error

1648 Views 6 Replies Latest reply: Jan 30, 2013 2:18 PM by DC11 RSS
John H Level 3 Level 3 (845 points)
Currently Being Moderated
Dec 7, 2012 8:14 PM

I have migrated from lion to Mountain lion server and when I try to log in to the server ( via the default from the migration) app it says 'SSL error has ocurred and can't connect to to the serve"

I am on the server when I try this.

 

If i try to connect via "other mac" the password is rejected.

 

Is there some command line I can use to clear this SSL issue.

  • alienbabyGA Calculating status...
    Currently Being Moderated
    Dec 8, 2012 10:36 AM (in response to John H)

    I have exactly the same problem with exactly the same errors listed in /var/log/system.log

     

    The one that stands out the version reported for servermgrd.  10.7.2

    Prior to the upgrade to Mountain Lion; 10.8.2, the box was fully upgraded to the latest Lion, 10.7, No outstanding patches.

     

    Just upgraded to 10.8.2 last night, and 10.8 server this morning.

     

    Open the server app to verify everything upgraded Ok from 10.7..  Go to login, and after providing my login for the server app, several moments later I get the error about an SSL issue.

     

    I have no idea where to go from from here..  Paid my money for a broken upgrade.

    Very upsetting.

  • MDH825 Calculating status...
    Currently Being Moderated
    Dec 8, 2012 10:46 AM (in response to John H)

    I also upgraded to server 10.8 today and am having the same problem with this SSL issue

  • Humbertotime Calculating status...
    Currently Being Moderated
    Dec 8, 2012 11:06 AM (in response to John H)

    I had this problem today and it had to do with previously changing the server name.  I corrected the error by opening keychain access and deleting the certificates associated w/ the older server name.

  • lozzzz Calculating status...
    Currently Being Moderated
    Dec 8, 2012 6:29 PM (in response to John H)

    As per Humbertotime, but I had to delete both the certificates and the private and public keys in keychain access. I did this after upgrading to ML. The problem was the original "machine.local" certs & keys, from before I applied its full name "machine.example.com".

  • DC11 Level 2 Level 2 (195 points)
    Currently Being Moderated
    Jan 30, 2013 2:18 PM (in response to John H)

    For me, there was only 1 certificate that I had to delete: com.apple.servermgrd

    I had 8 certificates to choose from, and wasn't sure which one(s) needed to be removed. I tried logging into the server through the Server application from my computer, and was told that certificate could not be trusted. I set it to be trusted, but still couldn't log in. As soon as I deleted that certificate, the server setup began working, and I was able to login and finish.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.