5 Replies Latest reply: Feb 12, 2013 7:44 AM by sgtravels
Kodyman Level 1 Level 1 (0 points)

got the new Iphone 5 and it says i need the Mac OSX 10.6.8 or higher to use Itunes and sync my phone ? so do i have to buy this software now ?


iPhone 5, Mac OS X (10.5.8)