2 Replies Latest reply: Dec 8, 2012 11:56 PM by mende1
Doubleuabee Level 1 Level 1 (0 points)

I have an iMac with OS X 10.5.8 and want to be able to utilise iCloud. Can I upgrade to the latest OS?


iMac, Mac OS X (10.5.8)