Skip navigation

MBP 2011 (feb) Model having weird SD card issues

15484 Views 53 Replies Latest reply: Apr 22, 2013 8:42 AM by Argos-Artiste RSS
  • KoobcamUser Calculating status...
    Currently Being Moderated
    Jul 30, 2011 6:34 AM (in response to ligaard)

    I realize I'm late to this party, but I thought I'd go ahead and chime in. I had created another thread that give all the specifics of what's happening with my system. https://discussions.apple.com/thread/3109277

     

    Here's the gist. 13" mbp early 2011. Transcend SDHC class 6 8GB card. Canon Digital Rebel Xsi. My issue isn't with the card not showing up, it's that fact that none of my pictures are available for import on it. It's like the Macbook corrupts the file system every time I insert it. I have the most recent software updates for snow leopard 10.6.8 and it's the same situation as before.

     

    I'd get Lion like ligaard, but I have too much software that I'm afraid will break if I upgrade. I'm planning to make a trip to an apple store to chit chat about it. I'll post back with any info I gather.

  • omairaslam Calculating status...

    Hello all

     

    I have a Kingston 16 GB SDHC Class 10 card and was facing the same issue with the MBP 2011. It was detecting it fine and stopped detecting it one fine day.

     

    However, what worked for me was to not insert the SDHC card in all the way into the card reader.

    Push it in all the way, remember that position, take it out, give it some time and push it in again, but this time not all the way.

     

    Omair

  • nwrchk Calculating status...

    Same issue for me with a Play.com SDHC 4GB card on a MacBook Pro 15" (2011). The card never mounts, regardless of restart. I'm not uninstalling Growl for the sake of this.

     

    I wouldn't really care as I've never needed the SD slot it until 6 months after buying it.

    But if it was supposed to work, I would rather it did than not.

     

    I'm not sure it's worth sending the Mac to Apple, receive a new one and have to reinstall all apps and docs.

     

    I'm all up for a software update release that fixes this.

  • omairaslam Level 1 Level 1 (0 points)

    I had the same issue but I have figured out a solution. It seems like a design flaw with the sd card slot in the Mac Book Pro or with the SD card.

     

    I have seen that if I plug in the SD card and then pull it out a few millimeters, it is detected by the Mac. Seems like the slot is deeper than required which causes the connection to not be established with the SD card connectors.

     

    I hope this helps others.

     

    Omair

  • Justin from the Gold Coast Calculating status...

    I took mine back to apple 2 weeks ago and they replaced the logic board. All working no issues.

  • WillAll Calculating status...

    What I found with this particular card is that it is not lining up perfectly.  If I wiggle it, it will show up.  Weird.  I guess will just have to connect directly with Camera.  Annoying.  But used to it for it wouldn't read the CF card also through reader and need to connect directly to the Camera EOS 5DMIII. 

     

    Don't know if it is a Apple issue or SanDisk...  It is a SanDisk Extreme Pro Class 10 Card 32GB.  I have a 16GB Class 6 from LG and it runs just fine.

  • Sri Vishnu Calculating status...

    Hey, I had the same issue with my 13" MBP. I later figured out that upon insertion of the SD card in a particular way makes it detectable.

     

    Insert the card slowly, dont push it hard inside. now, push it a little inside on the side towards the USB ports. so that it isnt parallel to the MBP's boby. You can see the image i attached.. 

     

    Remember not to push the card completely inside. and place it non parallel and pushed on the side as shown.

     

     

    Hope this works for you also. I use a lot variety of memory cards. Doing like this works with all those cards.DSC_0544.jpg

  • vff Calculating status...

    Sad but true: confirmed to work like a charm! Thanks for sharing your tip!

  • Argos-Artiste Calculating status...
    What is  the solution? A class  action? A reminder of the motherboard connected to the SDXC technology?

1 2 3 4 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.