Skip navigation

Updating existing '09 library to use in '11 (NOT upgrading iPhoto itself from '09 to '11)

316 Views 9 Replies Latest reply: Dec 16, 2012 2:29 PM by RiverdaleMAC RSS
RiverdaleMAC Level 1 Level 1 (0 points)
Currently Being Moderated
Dec 9, 2012 5:34 AM

I have a new MBP running OS X 10.8.2 fresh from Apple a week ago. It is preinstalled with iPhoto '11 (Version 9.4.2) so this question is about UPDATING my existing '09 libraries to work with '11. I know there were many issues UPGRADING the program itself from '09 to '11 but since this is a new system presumably that isn't an issue here.

 

When I launch iPhoto using OPTION and select my '09 library it says the library must be updated and it starts an updating process. The progress bar quickly moves about 90% of the way across and then gets stuck for hours. When this happens, if I right click on iPhoto in the dock, it shows to be "Not Responding". However, I'm not sure if that is a normal response when the program is "working" on something, i.e. updating my library, or if it actually has a problem.

 

So I'm wondering if it just needs a very long time to complete the process or is there anything I should be doing BEFORE I try and update my older '09 libraries?

 

I have tried this UPDATING process with two different '09 libraries, one successfully and the other not. The only apparent differences between the two libraries is their size and location.

 

Problem Library:

 

Library is approximately 5000 pictures and 26GB in size

It has various calendar projects, as well as approx. 20 .M4V video files in it.

It's stored on an external USB 3.0 HDD

I have numerous backup copies.

 

Succesful Library:

 

Stored on the internal HDD and was approx.17GB including various slideshows.

MacBook Pro (15-inch, Mid 2012), OS X Mountain Lion (10.8.2)
  • Terence Devlin Level 10 Level 10 (121,860 points)

    There are no particular isses upgrading from iPhoto 09 to iPhoto 11.

     

    What format is the USB disk?

  • Terence Devlin Level 10 Level 10 (121,860 points)

    No, it's not normal.

     

    Option 1

    Back Up and try rebuild the library: hold down the command and option (or alt) keys while launching iPhoto. Use the resulting dialogue to rebuild. Choose to Repair Database. If that doesn't help, then try again, this time using Rebuild Database.

     

    If that fails:

     

    Option 2

    Download iPhoto Library Manager and use its rebuild function. (In Library Manager it's the FIle -> Rebuild command)

     

     

    This will create an entirely new library. It will then copy (or try to) your photos and all the associated metadata and versions to this new Library, and arrange it as close as it can to what you had in the damaged Library. It does this based on information it finds in the iPhoto sharing mechanism - but that means that things not shared won't be there, so no slideshows, books or calendars, for instance - but it should get all your events, albums and keywords, faces and places back.

     

     

    Because this process creates an entirely new library and leaves your old one untouched, it is non-destructive, and if you're not happy with the results you can simply return to your old one. 

    Regards

     

    TD 

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.