9 Replies Latest reply: Dec 16, 2012 2:29 PM by RiverdaleMAC
RiverdaleMAC Level 1 Level 1 (0 points)

I have a new MBP running OS X 10.8.2 fresh from Apple a week ago. It is preinstalled with iPhoto '11 (Version 9.4.2) so this question is about UPDATING my existing '09 libraries to work with '11. I know there were many issues UPGRADING the program itself from '09 to '11 but since this is a new system presumably that isn't an issue here.

 

When I launch iPhoto using OPTION and select my '09 library it says the library must be updated and it starts an updating process. The progress bar quickly moves about 90% of the way across and then gets stuck for hours. When this happens, if I right click on iPhoto in the dock, it shows to be "Not Responding". However, I'm not sure if that is a normal response when the program is "working" on something, i.e. updating my library, or if it actually has a problem.

 

So I'm wondering if it just needs a very long time to complete the process or is there anything I should be doing BEFORE I try and update my older '09 libraries?

 

I have tried this UPDATING process with two different '09 libraries, one successfully and the other not. The only apparent differences between the two libraries is their size and location.

 

Problem Library:

 

Library is approximately 5000 pictures and 26GB in size

It has various calendar projects, as well as approx. 20 .M4V video files in it.

It's stored on an external USB 3.0 HDD

I have numerous backup copies.

 

Succesful Library:

 

Stored on the internal HDD and was approx.17GB including various slideshows.


MacBook Pro (15-inch, Mid 2012), OS X Mountain Lion (10.8.2)
  • 1. Re: Updating existing '09 library to use in '11 (NOT upgrading iPhoto itself from '09 to '11)
    Terence Devlin Level 10 Level 10 (123,770 points)

    There are no particular isses upgrading from iPhoto 09 to iPhoto 11.

     

    What format is the USB disk?

  • 2. Re: Updating existing '09 library to use in '11 (NOT upgrading iPhoto itself from '09 to '11)
    RiverdaleMAC Level 1 Level 1 (0 points)

    Mac OS Extended (Journaled) and from what I can tell, I have no other isssues with the USB disk. I can copy, delete, open things from it etc.

     

    Is it normal for iPhoto to show as "Not Responding" while it is working on things or does this actually mean there is a problem? If that is normal, I'll just give it another try and leave it for much longer.

     

    Thanks

  • 3. Re: Updating existing '09 library to use in '11 (NOT upgrading iPhoto itself from '09 to '11)
    Terence Devlin Level 10 Level 10 (123,770 points)

    No, it's not normal.

     

    Option 1

    Back Up and try rebuild the library: hold down the command and option (or alt) keys while launching iPhoto. Use the resulting dialogue to rebuild. Choose to Repair Database. If that doesn't help, then try again, this time using Rebuild Database.

     

    If that fails:

     

    Option 2

    Download iPhoto Library Manager and use its rebuild function. (In Library Manager it's the FIle -> Rebuild command)

     

     

    This will create an entirely new library. It will then copy (or try to) your photos and all the associated metadata and versions to this new Library, and arrange it as close as it can to what you had in the damaged Library. It does this based on information it finds in the iPhoto sharing mechanism - but that means that things not shared won't be there, so no slideshows, books or calendars, for instance - but it should get all your events, albums and keywords, faces and places back.

     

     

    Because this process creates an entirely new library and leaves your old one untouched, it is non-destructive, and if you're not happy with the results you can simply return to your old one. 

    Regards

     

    TD 

  • 4. Re: Updating existing '09 library to use in '11 (NOT upgrading iPhoto itself from '09 to '11)
    RiverdaleMAC Level 1 Level 1 (0 points)

    Went out this afternoon while iPhoto was updating the library and six hours later it's still not responding.......

     

    So do I try TD's Option 1 on a fresh untouched backup copy of the library which would still be an iPhoto '09 library as it has yet to be updated to '11?

     

    Or should I be trying it on the library which I have tried to update but has not yet been succesfully completed?

     

    Thank you.

  • 5. Re: Updating existing '09 library to use in '11 (NOT upgrading iPhoto itself from '09 to '11)
    RiverdaleMAC Level 1 Level 1 (0 points)

    Progress report:

     

    Trying Option 1 on the library I have already tried to update. First I repaired the permissions as it occurred to me this library was created using iPhoto on my old MBP (still via the same USB HDD), not this new MBP. Then tried rebuilding the librray. All was going well as it started importing 10,000+ pics, although as they rapidly flashed by on the screen I could see a siginificant number that appear to be distorted and/or only 1/2 the picture itself was there.

     

    That aside, it imported all the pics but the IMPORTING PHOTOS menu item in the left side menu bar shows it is still working (grey spinning wheel) and the main screen shows a blue IMPORT folder with a scrolling progress bar and it seems to be stuck here well over an hour after I saw the last few pictures being "imported". I should also note iPhoto is still responsive while this is going on.

     

    Screen Shot 2012-12-10 at 8.40.55 AM.png

  • 6. Re: Updating existing '09 library to use in '11 (NOT upgrading iPhoto itself from '09 to '11)
    RiverdaleMAC Level 1 Level 1 (0 points)

    Ha, never fails........Of course as I posted this, the process finished. Forgive my impatience.

     

    However, it appears there are a significant number of pics that are almost entirely grey, with just slivers of the original photo visible. I will wait until FACES has finished cycling through everything and then see what it looks like.

     

    At this point I'm thinking I will be trying the whole thing over again with this library but with REBUILD DATABASE instead of REPAIR.

     

    If that doesn't work, then I will do it all again with the untouched, fresh backup copy of the library.

     

    *sigh*

  • 7. Re: Updating existing '09 library to use in '11 (NOT upgrading iPhoto itself from '09 to '11)
    RiverdaleMAC Level 1 Level 1 (0 points)

    A little further investigation of the either enitrely BLANK pictures and those with just slivers of the original showing leads me to believe these are NOT actually missing or distorted pictures but "incomplete" copies of the other photos. Based on the most recent pictures, and thus the freshest ones in my mind, and comparing the meta data using the INFO. button, there appears to be a GOOD copy, then a BLANK COPY, and in some cases an INCOMPLETE copy.

     

    Also, it seems many of the BLANK pictures are the ones with my titles on them while the ones that actually show the picture have the generic IMG_XXXX assigned to them.

     

    In addition, the keywords don't seem to want to show up under the thumbnails, even tough I have KEYWORDS checked off under VIEW. However, I can still perform a search by KEYWORD and it seems to give me the correct result, although I cannot be 100% certain obviously as I cannot see the keywords asigned to the photos in the search results. Also, my list of keywords is visible under the MANAGE KEYWORDS option.

     

    These issues are perhaps related to the REPAIR option I chose, so as noted above, I'll go through it again with the REBUILD option.

  • 8. Re: Updating existing '09 library to use in '11 (NOT upgrading iPhoto itself from '09 to '11)
    RiverdaleMAC Level 1 Level 1 (0 points)

    I have also just realized the REPAIRED library is ~36 GB while the original '09 library is ~26GB. It seems there is a "new" untitled EVENT in the REPAIRED library which contains 10,000+ photos which appear to be duplicates. There are only slightly over 5,000 in ALL the remaining EVENTS added together. Based on my recollection, 5,000 is about correct for this library.

     

    Trying a REBUILD now on a copy of this UPDATED from '09 to '11 library, as opposed to the above detailed REPAIR attempt.

  • 9. Re: Updating existing '09 library to use in '11 (NOT upgrading iPhoto itself from '09 to '11)
    RiverdaleMAC Level 1 Level 1 (0 points)

    Ended up using iPhoto Library Manager to rebuild the lirary and this seems to have created a new library fully comptible with '11 and no "conversion" necessary. Thus, with the exception of the well documented items which don't transfer via iPhoto Library Manager (Calendars, Slideshows, etc.) this is the most complete iPhoto '11 workable copy I have been able to recreate. I do have a couple of issues with it still, mostly realted to squashed and rotated pics but I will dig around in the forums to see if there is an exiting solution before I post about it.

     

    It seem any picture that I had cropped in the old library appears squashed/stretched in this new library until I go to EDIT and it "pops" back to normal. Also it seems ALL of my portrait orientation pics have been rotated to Landscape which is annoying but fixable.