Skip navigation

Pages won't open after installing new HD

801 Views 16 Replies Latest reply: Dec 13, 2012 9:53 PM by fruhulda RSS
1 2 Previous Next
travelingG Calculating status...
Currently Being Moderated
Dec 9, 2012 10:58 PM

I have a 2009 intel iMac running Snow Leopard (10.6.8).  After installing a new hard drive, the OS, and all my programs, none of the iWork 09 programs (Pages, Numbers, Keynote) will open.  (All other programs work fine.)  For example, when I click on the Pages icon, it says "Pages could not open because of a problem... Click Report to see more detailed information and send a report to Apple."  When I click on Report, it says:


Process:     Pages [5683]
Path:        /Applications/iWork '09/
Version:     ??? (???)
Build Info:  Pages-7270000~9
Code Type:   X86 (Native)

Parent Process:  launchd [5264]


Date/Time:   2012-12-10 06:52:01.480 +0000
OS Version:  Mac OS X 10.6.8 (10K549)

Report Version:  6

Sleep/Wake UUID: CF45A385-A5A1-495A-ABD4-5FA08FD560A5


Interval Since Last Report:      600344 sec
Crashes Since Last Report:       14

Per-App Crashes Since Last Report:   9

Anonymous UUID:                  39E2D0B7-95B8-433E-A50B-8070BC9FF2F9



Exception Codes: 0x0000000000000002, 0x0000000000000000

Crashed Thread:  0


Dyld Error Message:

  Library not loaded: @rpath/Inventor.framework/Versions/C/Inventor

  Referenced from: /Library/Application Support/iWork '09/Frameworks/SFCompatibility.framework/Versions/A/SFCompatibility

  Reason: image not found


Binary Images:

0x8fe00000 - 0x8fe4163b  dyld 132.1 (???) <4CDE4F04-0DD6-224E-ACE5-3C06E169A801> /usr/lib/dyld


Model: iMac9,1, BootROM IM91.008D.B08, 2 processors, Intel Core 2 Duo, 2.66 GHz, 4 GB, SMC 1.37f3

Graphics: NVIDIA GeForce 9400, NVIDIA GeForce 9400, PCI, 256 MB

Memory Module: global_name

AirPort: spairport_wireless_card_type_airport_extreme (0x14E4, 0x8E), Broadcom BCM43xx 1.0 (

Bluetooth: Version 2.4.5f3, 2 service, 19 devices, 1 incoming serial ports

Network Service: AirPort, AirPort, en1

Serial ATA Device: WDC WD1002FAEX-00Z3A0, 931.51 GB

Serial ATA Device: OPTIARC DVD RW AD-5670S

USB Device: Built-in iSight, 0x05ac  (Apple Inc.), 0x8502, 0x24400000 / 3

USB Device: Keyboard Hub, 0x05ac  (Apple Inc.), 0x1005, 0x24300000 / 2

USB Device: Apple Optical USB Mouse, 0x05ac  (Apple Inc.), 0x0304, 0x24310000 / 5

USB Device: Apple Keyboard, 0x05ac  (Apple Inc.), 0x021d, 0x24320000 / 4

USB Device: IR Receiver, 0x05ac  (Apple Inc.), 0x8242, 0x04500000 / 2

USB Device: BRCM2046 Hub, 0x0a5c  (Broadcom Corp.), 0x4500, 0x06100000 / 2

USB Device: Bluetooth USB Host Controller, 0x05ac  (Apple Inc.), 0x8215, 0x06110000 / 3

FireWire Device: FreeAgent FW, Seagate, Up to 800 Mb/sec



I tried reinstalling iWork, but it has no impact.  How can I fix this?  Thanks.

iWork, Mac OS X (10.6.8)
  • mende1 Level 10 Level 10 (89,480 points)
    Currently Being Moderated
    Dec 9, 2012 11:02 PM (in response to travelingG)

    Welcome to the Apple Support Communities


    If you restored from your Time Machine backup, you'll have to reinstall iWork from the disc

  • Jerrold Green1 Level 7 Level 7 (28,190 points)
    Currently Being Moderated
    Dec 10, 2012 1:36 AM (in response to travelingG)



    Try deleting the located in HD > Users > (your account) > Library > Preferences.


    If you are using Lion or Mountain Lion, you can access the User Library folder from the Go menu in Finder while holding down the Option key.


    This sometimes clears that SFCompatibility error.



  • fruhulda Level 6 Level 6 (14,740 points)
    Currently Being Moderated
    Dec 10, 2012 8:07 AM (in response to travelingG)

    Did you do the Software updates after installing from the disc? You need to update to iWork 9.0.4. You can use this link

  • fruhulda Level 6 Level 6 (14,740 points)
    Currently Being Moderated
    Dec 10, 2012 12:10 PM (in response to travelingG)

    Do delete the and also restart the computer with the shift key pressed. If Pages works  restart again without the shift key pressed.

  • Jerrold Green1 Level 7 Level 7 (28,190 points)
    Currently Being Moderated
    Dec 10, 2012 3:46 PM (in response to travelingG)

    travelingG wrote:


    Jerrold Green1, I am using Snow Leopard (10.6.8).  Should I still delete

    Yes, and use the path I listed. You can confirm if this is necessary before doing it if you wish.


    Switch to a different User Account and see how Pages works there. If necessary, go to Users and Groups in System Preferences and create a new, auxilliary, admin account for testing purposes.



  • Jerrold Green1 Level 7 Level 7 (28,190 points)
    Currently Being Moderated
    Dec 11, 2012 6:30 AM (in response to travelingG)

    travelingG wrote:


    Pages does not open even when I start from a different user account. 

    That rules out any plist file problem in the main User account. So the problem seems to be isolated to one of the System Library files or the app itself, or some problem with the OS. Grasping at straws here, but here are some other things to try, assuming that you have the original media for installing iWork:


    Use OnyX to purge caches and repair permissions for a general maintenance of your system.


    Use Yvan Koenig's iWork '09 uninstaller script to wipe all traces of iWork and it's ancilliary files from your system. Find it on this page.


    Reinstall iWork



  • Jerrold Green1 Level 7 Level 7 (28,190 points)
    Currently Being Moderated
    Dec 13, 2012 10:04 AM (in response to travelingG)

    Thanks for the feedback, tG.


    Good luck.



  • fruhulda Level 6 Level 6 (14,740 points)
    Currently Being Moderated
    Dec 13, 2012 10:14 AM (in response to travelingG)

    What exactly did the trick?

1 2 Previous Next


More Like This

  • Retrieving data ...

Related Articles

Bookmarked By (0)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.