Skip navigation

Aperture wont import other aperture library files - no error message?

742 Views 10 Replies Latest reply: Dec 15, 2012 3:22 AM by léonie RSS
meduk1 Calculating status...
Currently Being Moderated
Dec 8, 2012 6:30 AM

I have my main Aperture library on my mac mini, with all masters reallocated on a NAS.


I have a secondary Aperture library on my MBP that I use for importing and editing from my camera.  My process is then exporting the library from the MBP to the Mini - has worked fine in the past.


When I try it now Aperture will perform as if its importing them, with a pop up box saying adding/merging, few minutes later it disapears - no error messages etc, however no new photos have been added?


Things I've tried so far are:


- Repair disk permissions

- Repair and Rebuild aperture library

- Re exporting original library

- Openening up the library on the Mini, it opens up fine.  Ive then tried re-exporting it directly from the mini and then importing again into the main library


Still no luck - any help?

Mac mini, Mac OS X (10.7.1)
  • léonie Level 8 Level 8 (46,380 points)

    What is your Aperture version? Is the profile signature Mac OS X (10.7.1) current?


    Have tried to rebuild the Libraries both on the MBP and the Mini? Are both machines using the same version of Aperture?


    So far I have only seen this strange behaviour, when importing a library that contains images imported from the Photos stream. Then Aperture will go through the motions, but will not import a single image. But you said, the images you want to import came from your camera? Have they been directly imported into Aperture on the MBP or are you using Photo Stream (asuming your system version supports it)?




  • léonie Level 8 Level 8 (46,380 points)

    Only thing that has changed is a rebuilt my mini with a fresh install a few months ago and used a backup of my aperture library but don't see how that can be a prob. Aperture itself is working fine.

    Did you use a backup of the library on your MBP for this? Is the library on the iMac now a descendent of the library on the MBP? Aperture has a strange quirk that it will not import and merge a copy of a library into the original of the library. Then simply nothing will happen, as I have seen occasionally.


    In that case it might help to turn your library on the MBP into a new library by creating a new library and importing your current MBP-library into it.

  • léonie Level 8 Level 8 (46,380 points)

    Does it work, if you import an exported library from the MBP-library to your IMac library, if you import using the "Add" option instead of the "Merge" option?


    How do you transfer between your Macs? Using the network?

  • léonie Level 8 Level 8 (46,380 points)

    Where is the option to add vs merge?  I'm just going to import library - no further questions are asked.


    There should be the option:

    When I am importing a library I usually see this panel after selecting "ImportLibrary":


    Only if there are no duplicate or updated images will Aperture proceed with the import without prmpting for "Merge" or Add". You could try to include a duplicate into you export to force this panel to be shown.

    All images are imported into there original projects, if the matching project exists, so it may not be noticable that an import has happened.

  • léonie Level 8 Level 8 (46,380 points)

    Great, I am glad that works for you now!


More Like This

  • Retrieving data ...

Bookmarked By (0)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.