10 Replies Latest reply: Dec 12, 2012 6:53 AM by tineline
tineline Level 1 Level 1 (0 points)

I just started using Pages (switched from Neooffice/MS Word). While I love the way it deals with many things, this one things really bugs me. Since I am multilingual, I use a variety of languages when writing, although my main software language is UK English (which is what I want). BUT - Sometimes I have to write a letter or something in my native language, Norwegian. In this language, the letter "i" is in fact a whole word on its own, and it seems I cannot turn off the capitalisation of just this one letter without also turning off all capitalisation. This is just too ridiculous for me. Surely there must be a solution to this simple problem?

 

If it means that I have to switch languages every time I want to write in a separate language, that is something that should not be necessary as long as Norwegian does not have its own dictionary in Pages, or as long as it is such an intricate operation to switch. The list of auto correct options for symbols etc does not have i/I as options either, and this frustrates me because I keep not seeing that I missed fixing it by "undo" (yes, I know about cmd+Z).

 

Anyone know of a solution without switching languages? And if not, where can I report this problem? The only capitalisation that I want is the one that automatically corrects lower case with uppercase at the beginning of a new sentence. This was so easy to set in Neooffice, that I cannot believe it is not an option in Pages.

 

Hope you guys can help! I have found the solution to my problem many times on these forums, and I have high hopes that there are some experts out there for anything.

 

tineline


MacBook, Mac OS X (10.7)
  • 1. Re: Turn off capitalisation of "I"?
    tineline Level 1 Level 1 (0 points)

    Edit: It turns out that changing language does not do anything about the i/I-situation... It did when my main OS language was set to Norwegian, but in order to make the British Dictionary work, I had to switch the OS language to English. Are these just bugs or what?

  • 2. Re: Turn off capitalisation of "I"?
    Tom Gewecke Level 9 Level 9 (71,735 points)

    Are you unaware that you can add things to autocorrection using the plus button at the bottom?

     

    You don't have to change the OS language to change the spellcheck, that is done via Inspector > Text > More > Language.

     

    You can add a Norwegian dictionary

     

    http://m10lmac.blogspot.com/2011/06/norwegian-spell-check-and-dictionaryapp.html

  • 3. Re: Turn off capitalisation of "I"?
    tineline Level 1 Level 1 (0 points)

    Thank you for your reply, Tom Gewecke.

     

    First of all -the capitalisation still continues even when I switch language to Danish or Swedish, which both use the same word ("i"), or to None.

     

    I am aware that I can add and subtract corrections in the list, and I tried this, but the problem is not in the symbol auto-correct, but in the capitalisation itself. Also - it does not actually change it from capital I to small i even when I added this in the list. That means I am only able to fix this by also turning off capitalisation of first letter of new sentences - Not really an ideal solution.

     

    Thanks for the link to the dictionary. I am not really looking to switch language for every language I use in Pages (especially when capitalisation still prevails even then). I don't mind red lines in the text when I write in Norwegian - I don't need a spell check on my native language. But I do need it in UK English, which is the language I use for my work, and I would like to keep it on. Fixing this has never been a problem in Word or in Neooffice and Openoffice. I don't understand why Apple are seemingly oblivious to this issue...

     

    I read somewhere that an update to pages might fix my problem. Does anyone know which update that would be? I would be very grateful.

  • 4. Re: Turn off capitalisation of "I"?
    VikingOSX Level 5 Level 5 (5,500 points)

    I would support Tom's advice.

     

    Additionally, if you are willing to give up all auto-capitalization in a sentence or after a full stop, you can turn off the “Fix capitalization” setting in Pages preference: Auto-Correction Preferences.

     

    This permits an isolated ‘i’ without automatic case promotion to capital.

  • 5. Re: Turn off capitalisation of "I"?
    Tom Gewecke Level 9 Level 9 (71,735 points)

    tineline wrote:

     

    I read somewhere that an update to pages might fix my problem. Does anyone know which update that would be? I would be very grateful.

     

    Nobody in these forums can tell you anything about Apple's update plans.  Unfortunately Pages seems to rarely get fixed -- there is a long list of bugs outstanding.  But you can ask at

     

    http://www.apple.com/feedback/pages.html

     

    It seems like there should be some way to do what you want, I will look further...

  • 6. Re: Turn off capitalisation of "I"?
    tineline Level 1 Level 1 (0 points)

    Thanks, Tom. I very much appreciate it!

     

    Going back to Word (for integrating EndNote) is not an option when they changed the whole interface, so I will be sticking with Pages. But I would very much like this to have an easy solution.

  • 7. Re: Turn off capitalisation of "I"?
    Tom Gewecke Level 9 Level 9 (71,735 points)

    Two ideas:

     

    1) Use this app to change Pages only to Norwegian more easily

     

    http://www.tj-hd.co.uk/en-gb/languageswitcher/

     

    2) Navigate to this .plist file and see if it can be edited to omit the i > I feature

     

    Macintosh HD/Library/Application Support/iWork/'09/Frameworks/SFWordProcessing.framework/Versions/A/Resources/En glish.lproj/AutoCorrect.plist

  • 8. Re: Turn off capitalisation of "I"?
    tineline Level 1 Level 1 (0 points)

    Thank you so very much, Tom Gewecke! Removing the .plist file solved the problem. I'd rather capitalise all the "i"s myself, or add it to Auto-Correct for the English dictionary. What a completely complicated solution to a problem that should not even be a problem...

     

    For some reason, the language switcher does not pick up iWork or Pages on my computer.

     

    Anywho, I am very pleased, and will definitely NOT move back to Word. Have a good day!

  • 9. Re: Turn off capitalisation of "I"?
    fruhulda Level 6 Level 6 (15,110 points)

    Uncheck "Fix capitalisation" in the Pages preferences > Auto correction!!!

  • 10. Re: Turn off capitalisation of "I"?
    tineline Level 1 Level 1 (0 points)

    Unchecking "Fix capitalisation" does not really help me, because I would like to keep capitalisation after punctuation on. But removing the .plist file that Tom Gewecke mentions above, took away the i/I-capitalisation, and now all is well.