Skip navigation

Turn off capitalisation of "I"?

336 Views 10 Replies Latest reply: Dec 12, 2012 6:53 AM by tineline RSS
tineline Calculating status...
Currently Being Moderated
Dec 10, 2012 3:51 AM

I just started using Pages (switched from Neooffice/MS Word). While I love the way it deals with many things, this one things really bugs me. Since I am multilingual, I use a variety of languages when writing, although my main software language is UK English (which is what I want). BUT - Sometimes I have to write a letter or something in my native language, Norwegian. In this language, the letter "i" is in fact a whole word on its own, and it seems I cannot turn off the capitalisation of just this one letter without also turning off all capitalisation. This is just too ridiculous for me. Surely there must be a solution to this simple problem?

 

If it means that I have to switch languages every time I want to write in a separate language, that is something that should not be necessary as long as Norwegian does not have its own dictionary in Pages, or as long as it is such an intricate operation to switch. The list of auto correct options for symbols etc does not have i/I as options either, and this frustrates me because I keep not seeing that I missed fixing it by "undo" (yes, I know about cmd+Z).

 

Anyone know of a solution without switching languages? And if not, where can I report this problem? The only capitalisation that I want is the one that automatically corrects lower case with uppercase at the beginning of a new sentence. This was so easy to set in Neooffice, that I cannot believe it is not an option in Pages.

 

Hope you guys can help! I have found the solution to my problem many times on these forums, and I have high hopes that there are some experts out there for anything.

 

tineline

MacBook, Mac OS X (10.7)
  • Tom Gewecke Level 9 Level 9 (70,850 points)
    Currently Being Moderated
    Dec 10, 2012 5:13 AM (in response to tineline)

    Are you unaware that you can add things to autocorrection using the plus button at the bottom?

     

    You don't have to change the OS language to change the spellcheck, that is done via Inspector > Text > More > Language.

     

    You can add a Norwegian dictionary

     

    http://m10lmac.blogspot.com/2011/06/norwegian-spell-check-and-dictionaryapp.html

  • VikingOSX Level 5 Level 5 (4,700 points)
    Currently Being Moderated
    Dec 10, 2012 6:39 AM (in response to tineline)

    I would support Tom's advice.

     

    Additionally, if you are willing to give up all auto-capitalization in a sentence or after a full stop, you can turn off the “Fix capitalization” setting in Pages preference: Auto-Correction Preferences.

     

    This permits an isolated ‘i’ without automatic case promotion to capital.

  • Tom Gewecke Level 9 Level 9 (70,850 points)
    Currently Being Moderated
    Dec 10, 2012 7:01 AM (in response to tineline)

    tineline wrote:

     

    I read somewhere that an update to pages might fix my problem. Does anyone know which update that would be? I would be very grateful.

     

    Nobody in these forums can tell you anything about Apple's update plans.  Unfortunately Pages seems to rarely get fixed -- there is a long list of bugs outstanding.  But you can ask at

     

    http://www.apple.com/feedback/pages.html

     

    It seems like there should be some way to do what you want, I will look further...

  • Tom Gewecke Level 9 Level 9 (70,850 points)
    Currently Being Moderated
    Dec 10, 2012 8:02 AM (in response to tineline)

    Two ideas:

     

    1) Use this app to change Pages only to Norwegian more easily

     

    http://www.tj-hd.co.uk/en-gb/languageswitcher/

     

    2) Navigate to this .plist file and see if it can be edited to omit the i > I feature

     

    Macintosh HD/Library/Application Support/iWork/'09/Frameworks/SFWordProcessing.framework/Versions/A/Resources/En glish.lproj/AutoCorrect.plist

  • fruhulda Level 6 Level 6 (14,750 points)
    Currently Being Moderated
    Dec 12, 2012 6:37 AM (in response to tineline)

    Uncheck "Fix capitalisation" in the Pages preferences > Auto correction!!!

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.