Skip navigation

Import Preparing to import... hangs

726 Views 6 Replies Latest reply: Dec 10, 2012 10:31 AM by RaiderJim RSS
RaiderJim Calculating status...
Currently Being Moderated
Dec 8, 2012 11:20 AM

I am using iPhoto 9.4.2 under Mountain Lion 10.8.2.  I am unable to import photos into my iPhoto library anymore.  This happens both with photos already on my disk and photos from web pages.


After I start to import, iPhoto hangs with "Import Preparing to import..." in the top of the iPhoto window.


I have used all 4 steps in Photo Library First Aid (including Rebuild Database) without resolving the problem.


I tried using iPhoto Library Manager to rebuild the library, but this app launches iPhoto and starts an Import which hangs (I left it alone for several hours without any progress shown for importing events).


My iPhoto Library is 11GB in size.  I have 22.5GB free on my boot drive.  My iMac has 8GB of RAM.

iMac, Mac OS X (10.6.7)
  • Old Toad Level 10 Level 10 (113,125 points)
    Currently Being Moderated
    Dec 8, 2012 11:28 AM (in response to RaiderJim)

    Try this:  launch iPhoto with the Option key held down and create a new, test library.  Import some photos and check to see if the same problem persists.  If it does log into another user account and try iPhoto there.  If that also fails then it's a problem with the application and it should be reninstalled. To do so you'll have to delete the current application and all files with "iPhoto" in the file name with either a .PKG or .BOM extension that reside in the:


    HD/Library/Receipts folder (10.5 and earlier)


    or from the /var/db/receipts/  folder (10.6) .




    or from the /private/var/db/receipts folder (10.7 or later)


    Then install iPhoto from the source it came from originally.



  • Old Toad Level 10 Level 10 (113,125 points)
    Currently Being Moderated
    Dec 9, 2012 8:23 AM (in response to RaiderJim)

    Book into  Mac OS X: Starting up in Safe Mode and see if iPhoto works there.  It if does then there's a system component that causing the problem, possibly damaged.  A long shot but any port in a storm.

  • Old Toad Level 10 Level 10 (113,125 points)
    Currently Being Moderated
    Dec 10, 2012 9:12 AM (in response to RaiderJim)

    It's beginning to look like a reinstall of the system is in order. This Apple document describes reinstalling Mt. Lion: OS X: About OS X Recovery. Be sure you have a backup of your drive so that you don't lose any documents.


    This MacWorld webpage also describes the process: Hands on with Mountain Lion's OS X Recovery and Internet Recovery | Macworld


More Like This

  • Retrieving data ...

Bookmarked By (0)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.