Skip navigation

Netflix login page doesn't load for some users

1601 Views 2 Replies Latest reply: Dec 10, 2012 10:38 AM by a brody RSS
Peter Booth1 Level 1 Level 1 (135 points)
Currently Being Moderated
Mar 20, 2011 4:57 PM
I have a Netflix account and use it all the time to watch movies on our comptuer. (iMac G4). My daughter has her own login with Parent Controls activated. I have listed www.netflix.com as an "OK" site for her to visit. When she goes there the netflix home page loads, but when she clicks on "login" in order to enter our family's account info, the page will not load. I went so far as to go back to MY user, logout of Netflix and then went to the login page and copied that specific URL and pasted it into Parent Controls as an "OK" address. Still no deal.
The message she gets is NOT a 'you don't her permission from your parents to view this content' message, it's the standard "Safari can't load this page" message that you get when you type in a non-existent URL. Same thing with IE and Firefox. I'm completely flummoxed.
Any ideas?

Thanks,
Peter Booth
G4, Mac OS X (10.5.8)
  • Kippie Calculating status...
    Currently Being Moderated
    Dec 9, 2012 10:20 PM (in response to Peter Booth1)

    I know this is an older thread but it seems that it is still a very real problem.  Here is our solution - thanks to my wonderful husband who figured it out:

     

    1) Turn off parental controls, then log in to Netflix, so that the cookie is stored, etc.

    2) Turn parental controls back on.

    3) Try to go to:  http://movies.netflix.com/WiHome

    4) You may need to add it as an "allowed" site at the domain level - netflix.com

     

     

    We had an add'l problem related to Silverlight.  It was not installed, which was another error we were getting, but it didn't tell us that.  My husband works in IT and was able to analyze the errors and realize what the fix was.  So make sure that:

     

    1) Silverlight must be installed

    2) Silverlight must not be restricted for your child.

     

    I hope this helps!

  • a brody Level 9 Level 9 (62,045 points)
    Currently Being Moderated
    Dec 10, 2012 10:38 AM (in response to Peter Booth1)

    G4s don't support Netflix streaming.  That may be part of the problem.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.