Skip navigation

Different Input Source (language keyboard) from OS language on Mountain Lion

613 Views 8 Replies Latest reply: Dec 11, 2012 7:52 AM by Tom Gewecke RSS
SilvaLazarus Calculating status...
Currently Being Moderated
Dec 9, 2012 6:49 AM

Like many users worldwide, I have my Macs with OS X Mountain Lion in English but I write in another language (European Portuguese) and I need the Input Source to be in Portuguese not in English.

Never had any problems with it in previous OS versions.

Now with Mountain Lion, every other day (not always, strangely...) I find an American US keyboard setup by default when I turn my iMac on and I have to go to Systems Preferences and reestablish the Portuguese Keyboard.

This is not happening on my MacBook with Mountain Lion where I have exactly the same System Preferences.

Any help/suggestions appreciated.

iMac, OS X Mountain Lion (10.8.2), English System
  • sapper Level 1 Level 1 (70 points)

    Hi SilvaLazarus, in System Preferences click on Languages and Text. Click on 'Input sources' and below, click on the language(s) you would like to use which will show up in the tool bar to the right of your screen as the Portuguese flag. Also click on the Keyboard and character icon. If you are using a UK keyboard, you can select the Portuguese keyboard viewer to enable using the Portuguese language characters.

     

    When all that is set up, all you do is to click on the flag icon, and from the drop down list, click Keyboard viewer and remember to tick the 'Show input menu in menu bar' box.

     

    Hope that helps.

  • Tom Gewecke Level 9 Level 9 (70,845 points)

    You might try creating a new user account and see if you have the same problem when logged into that.  If not, it means some .plist in your main account has gotten corrupted and needs to be trashed.  Finding the right one is another issue....

     

    In general to bring something to Apple's attention, you need to use the feedback channels

     

    http://www.apple.com/feedback

     

    since these forums are really just for users.

  • K T Level 7 Level 7 (23,215 points)

    How many different keyboards have you tried?

     

    As an exercise, try one of them with the MB and see if it triggers the issue(s) there.

     

    Also, be sure your primary desired lang is pushed to the top of the list, above English as an example.

     

    Apple loves to hear about such issues, so if you can't find an online feedback channel, call Support and/or walk into your nearest Apple Store and ask them to take a look, etc.

  • Tom Gewecke Level 9 Level 9 (70,845 points)

    SilvaLazarus wrote:

     

    I have a MacBook pro that I use daily with the same exact configuration and no problems.

     

     

    In system preferences/language & text/input sources, is the box for "US" unchecked in both of them?

  • Tom Gewecke Level 9 Level 9 (70,845 points)

    SilvaLazarus wrote:

     

    Yes. "US" keyboard is unchecked.

     

     

    What keyboard is active when you have to login to your account?  If it is the wrong one, you can try running the setup assistant again.

     

    http://apple.stackexchange.com/questions/57651/how-can-i-re-run-the-initial-setu p-assistant-on-mountain-lion

     

    But a new account is required for that too now.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.